Rocscience International Conference 2023 | April 24-26, 2023 Learn More about RIC2023
 

Search Results

Using RSLog Cross Sections in Slide2

1.0 Introduction

RSLog allows you to log test holes for soil and rock, in geotechnical, environmental, oil and gas, or mining projects. A feature of RSLog is the ability to design a cross section with your field data. This cross section can be easily imported into Slide2.

In this tutorial you will learn how to:

  • Create a cross section in RSLog
  • Bring the section into Slide2 using your RSLog account (online)
  • Bring the section into Slide2 by uploading a file (offline)
This tutorial assumes you are familiar with creating a project and defining test holes. To learn how to do this, see the RSLog tutorial, How to Create a Project.

2.0 RSLog Project

On your web browser, go to the RSLog login page: https://www.rslogonline.com/ Login with your credentials. We will open the project “RSLog Example Project #1 (Imperial)”, which comes with your RSLog account.

To ensure we start with an unmodified copy of the project, we will restore a copy of the default project from RSLog:

  1. On the left-hand side, select Tools > Settings.
  2. Click Import Example Projects.
  3. Click Yes in the Warning message.

You will be taken to the Projects page, and the project we just imported will be active and highlighted orange. It will be named “RSLog Example Project #1 (Imperial)-copy”. If you have multiple copies, it will have an additional “-copy” appended to the name. Let’s name it something more distinguishable:

  1. Double-click on the project.
  2. Set Title to “Slide2 Tutorial”.
    Update Project Details dialog
  3. Set Client to “ABC Client Company Ltd.
  4. Click Save.
  5. A warning message will say “Do you want to edit test holes for this project?”. Click Yes.

Three test holes have been defined for this project. You can double-click on each test hole to see more information.

Test Holes page

Notice the name of the active project in orange at the top of the page.

3.0 Create Cross Section in RSLog

We will create a simple cross section between boreholes 1 and 2:

  1. Select Data Entry > Cross Section.
  2. In the map, single click on AH20-1. Make sure to click in the center of the blue symbol.
  3. Double click on AH20-2 to finish defining the cross section.
  4. In the pop-up, name the section “Slide2 Section.”
  5. Click Save.

Create Cross Section


The new section will appear on the list. Click Open. By default, you will see the two test holes as well as a legend indicating the materials in each borehole. The legend can be moved out of the way by clicking and dragging.

We will design a simple cross section as follows:

  1. Select the “Draw Soil / Rock Layer” icon at the top.
    Cross section designer
  2. Starting with the left borehole (AH20-1), and the bottom layer, click on the vertex labeled 29:
    Cross section designer
  3. Now scroll over to the second borehole by clicking and dragging, and click on vertex 18. Then click on vertex 33:
    Cross Section designer
  4. Now return to the first borehole and click on vertex 35. Press Enter.

We will assign the appropriate material to this layer.

  1. Click on the black polygon.
  2. In the Object Properties on the left side, under Polygon, change the following:
    1. Fill Style = Pattern.
    2. Pattern Type = TILL.

Your screen will look as shown:

Cross section designer

Using the same methodology, you can match the materials in the left borehole to those in the right borehole to design the section with the knowledge you have available. However, we will leave this as an optional exercise. For more information on defining cross sections in RSLog, see Cross Section Overview in the RSLog help.

For the sake of consistency in this example, we will use a predefined cross section.

  1. Click Save to close the Slide2 Section.
  2. Open Cross Section A.

Your screen will look as shown:

Cross section designer

4.0 Import Cross Section to Slide2 (Online)

We will now import this section into Slide2 as a soil profile. To do this:

  1. Launch Slide2.
  2. Select File > Import > Import RSLog Cross Section or use the toolbar icon rslog import icon.
  3. You will see the dialog below:
    import cross section - login dialog
  4. You can do this either by logging into your RSLog account (online) or by importing a file saved to your machine (offline). We will use the online method. See the end of the tutorial for details on the offline method.
  5. Input your credentials in the dialog and click Next.
  6. You will now see the list of projects in your account. You can click on each one on the left side to see general details about each project.
  7. Select Slide2 Tutorial on the left side and click Next.
    Import RSLog data dialog
  8. You will now see the two cross sections defined for this project. Click on each one to see the preview image of each section.
    Import RSLog data dialog
  9. Select Cross Section A.
  10. Notice the Import as Soil Profile checkbox. By default, this is on, since the user would most likely need to cut the slope out of their cross section in Soil Profile mode. If you want to import the cross section directly as a slope, you can uncheck this box.
  11. Click Finish.
  12. The display units of the cross section are imperial whereas the units of the Slide2 project are metric. Click OK in the message to automatically switch the units in Slide2 to imperial. Click OK again in the units message.
  13. You will see the cross-section as shown:

Imported RSLog Cross section

Notice that the colours are imported from the RSLog section. Select Properties > Define Materials. The materials displayed are named after the selected hatch. All materials are default Mohr-Coulomb and will need to be defined by the user. Click Cancel.

We can now cut the desired slope out of the section:

  1. Select the Geometry workflow tab.
  2. Select Boundaries > Add External Boundary.
  3. Click Add External as Polyline.
    Add External Options dialog
  4. We will define the external with a coordinate table. Type t in the command line and press Enter. Copy and paste the coordinates shown:
  5. 1.406378

    10.00966

    1.059428

    6.553506

    0.46139

    0.596148

    0

    -4

    538.9697

    -3.90406

    539.3928

    0.509314

    539.9722

    6.553506

    539.9998

    6.841314

    540

    10.87085

    399.1216

    11.14801

    356.5649

    13.26937

    326.1641

    13.5572

    223.1107

    16.62731

    136.5458

    22

    115.9351

    21.90406

    2.061069

    16.53137

  6. The table will look as shown:
    Coordinate table dialog
  7. Click OK.
  8. Press Enter to finish defining the external.

Your model will look as shown:

Final Model with external

The user can then proceed with material property definitions and compute the analysis. This concludes the tutorial.

5.0 Import Cross Section to Slide2 (Offline)

The above example demonstrates the import of the RSLog cross section by logging into your RSLog account. If you won’t have internet access while making your Slide2 model, you can export the RSLog section ahead of time as follows:

  1. In RSLog open Cross Section A.
  2. Click on the Export button at the top and select “Rocscience Section (JSON)”. This downloads a Rocscience Section file.
    Export JSON file
  3. In Slide2 select File > Import > RSLog Cross Section.
  4. This time click the Import button in the dialog.
  5. Select the file you downloaded in step 2 above and click Open.
  6. This will import the file in soil profile mode.
Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee