Rocscience International Conference 2023 | April 24-26, 2023 Learn More about RIC2023
 

Search Results

Conversion to XFEM

1.0 Introduction

This tutorial shows how to convert the current jointed model into XFEM. The model was built in four stages. In the first stage the model is under equilibrium and joints do not have any initial deformation, while in the second stage the excavation above the slope is applied and the water table is lowered. The concrete is poured on the excavated zone in the third stage and finally the bolts are installed in the fourth stage to increase the strength of the soil.

Model

2.0 Constructing the Model

  1. Select File > Recent Folders > Tutorial Folder > Jointed Rock
  2. Select XFEM conversion initial
  3. Begin by importing a file created by explicit joints, in which geometry, mesh, materials, and boundary conditions in all stages have already been assigned. Since the construction and assignment of piezometric lines, bolts and boundary conditions are already covered in the other tutorials, here, we skip them and only focus on the XFEM conversion.

  4. Select Analysis > Project settings icon Project Settings
  5. In the Project Settings dialog select Units tab and ensure that stress units are set to Metric, stress as kPa.

    project settings - units
  6. Select Solver Options tab. Select the checkbox for Use XFEM.

    project settings - solver options
  7. By clicking Ok, the initial mesh assignment would disappear.

2.1 MESH

Mesh workflow tab

  1. Select Mesh > Mesh setup icon Mesh Setup
  2. Use Uniform mesh in the Mesh Type section.
  3. Pick 6 Noded Triangles as Element Type.
  4. Enter the Approximate Number of Mesh Elements as 1500.
  5. Select Discretize, then select Mesh.
  6. Select OK to close the dialog.

Mesh setup dialog

The finished model should appear:

Finished model

3.0 Compute

Select: Analysis > Compute icon Compute

4.0 Results and Discussion

Select: Analysis > Interpret icon Interpret

4.1 CONTOURS OF MAJOR PRINCIPAL STRESS – SIGMA 1

The maximum compressive stress (sigma 1) would be displayed.

  1. Right click on the screen, select Display Options display option icon
  2. Under Nodes and Elements section of Stress tab, select the checkbox for Elements. Mesh will be displayed.
  3. Display Options_display mesh

  4. Select Done to close the dialog.

Contours - Sigma 1

As it can be seen in the initial stage, where the slope is under equilibrium, the minimum compressive stress is happening on the free surface of the slope. This value keeps increasing in depth where more weight is applied to the rock mass.

4.2 CONTOURS OF TOTAL DISPLACEMENT

At the top right on the tool bar change Sigma 1 on the drop-down menu to Solid Displacement > Total Displacement. In order to compare the obtained XFEM results with regular joint, the similar simulation is repeated for the latter without XFEM (explicit) and the total displacement at each stage is displayed here. The explicit model is included in the tutorial folder with filename: XFEM conversion (explicit) under File > Recent Folders > Tutorial Folder > Jointed Rock.

Stage 1 of model

Stage 1 (left) XFEM (right) explicit joint network

Stage2 of model

Stage 2 (left) XFEM (right) explicit joint network

Stage 3 of model

Stage 3 (left) XFEM (right) explicit joint network

Stage 4 of model

Stage 4 (left) XFEM (right) explicit joint network

As it can be seen, the results are in a very good comparison. The slight difference is conducted by different mesh sizes that is imposed in each of these models.

4.3 VISUALIZING JOINT DATA

Select: Analysis > Show Values

Show values dialog

Pick Joint and select Shear Displacement on drop down menu. By clicking OK, the curves on all joints in the model would appear that shows the shear displacement along the joint. These curves are also compared in last stage with explicit method which are in close agreement.

Model with Shear Displacement

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee