Rocscience International Conference 2023 | April 24-26, 2023 Learn More about RIC2023
 

Search Results

Liner Local Coordinates

1.0 Introduction

In this tutorial, we introduce the liner local coordinate tool in RS3. This tool allows users to define local coordinate systems for groups of liners to better analyze the displacements, axial forces, shear forces and bending moments.

The model is based on the RS2 Tunnel Lining Design Tutorial-part 3. A circular tunnel of radius 4 m is to be constructed in Schist at a depth of 550m. The tunnel axis is 20 degrees counterclockwise about the z-axis measured from the y axis (trend angle of -20 degrees). Taking the tunnel face as in-plane, the in-situ stress field has been measured with the major in-plane principal stress equal to 30 MPa, the minor in-plane principal stress equal to 15 MPa and the out-of-plane stress equal to 25 MPa. The major principal stress is on the horizontal plane and perpendicular to the tunnel axis. The minor principal stress is vertical. The strength of the Schist can be represented by the Generalized Hoek-Brown failure criterion with the uniaxial compressive strength of the intact rock equal to 50 MPa, the GSI equal to 50, and mi equal to 10. To compute the rock mass deformation modulus, the modulus ratio (MR) is assumed to be 400. The support is to be installed 2 m from the tunnel face. The tunnel is excavated 2 m per stage. In RS2, the tunnel wall deformation prior to support installation is estimated using the internal pressure reduction method. In RS3, we directly model the excavation and support installation staging to find the tunnel wall deformation. The RS3 model was created using the Tunnel Designer Tool.

The image below shows the RS3 model of the rock/soil with tunnel excavation.

Tunnel design model

All tutorial files installed with RS3 can be accessed by selecting File > Recent > Tutorials folder from the RS3 main menu. The finished product of this tutorial can be found in the Tunnel Lining Design.rs3dmodel file.

2.0 Starting the Model

Open the starting file from File > Recent > Tutorials > Tunnel Lining Design - starting file.rs3dmodel

All the project settings, material/support definitions, and tunnel sequencing are predefined in the starting file.

3.0 Defining the Liner Local Coordinates

Excavation Tab

The liner local coordinates can be defined under any tab. We will select the [Excavation] tab to better view the tunnel volumes. Hide the Rock Mass external volume.

tunnel close look

Select the tunnel side faces with Faces Selection b_face selectionmode active in the toolbar. Hold SHIFT when selecting a tunnel side face. This will quickly select all connected faces. Note that for the last tunnel volume the tunnel end face may be selected as well when holding SHIFT. To deselect the tunnel end face, release SHIFT, hold CTRL and click on the tunnel end face. You may need to rotate your model to see the end face.

tunnel face selection

Select: Support > Liners > Define Liner Local Coordinates for Tunnels

In the Define Liner Local Coordinates for Tunnels dialog under the Select Edge tab, we can input a vector manually or use the geometry to define the tunnel axis which will be the local y-axis. We can also choose to input trend and plunge angles in the Trend and Plunge tab. For this case, in the Select Edge tab, select the right pick edge tool to use the geometry to define the tunnel axis. Now select any edge pointing in the tunnel axis direction and the vector coordinates will be automatically filled. Select OK.

define liner local coordinates for tunnels

A new tunnel frame entity is created, which shows the local coordinate system for each side face of the tunnel. When defining a tunnel frame using the Define Local Coordinates for Tunnels option, it is important to select all faces that liner results will need to be converted to the frame’s local coordinate system. Liner results that are not on a face defined in the tunnel frame are not guaranteed to be converted using the correct local coordinate system based on the liner’s orientation at that point. There is also an option to manually define the local coordinate system using Support > Define Liner Local Coordinates which does not require the selection of faces. When using a frame defined in this manner, all liner results will be converted to the frame’s local coordinate system.

tunnel with local coordinate frame

4.0 Compute

Next, we move to [Compute] tab. From this tab, we can compute the results of our model. First, save your model: File > Save As.

Use the Save As dialog to save the file, and next, you need to save the compute file: File > Save Compute File. You are now ready to compute the results.

compute icon Select: Compute > Compute

compute dialog

Defining and saving new liner local coordinate frames does not delete results or require recomputing. You can always go back to computed models and add or remove liner local coordinate frames.

5.0 Results

results tab

Next, move to the [Results] tab. Select Tunnel Stage 10. To the right of the model, set the Legend to Solids and Total Displacement.

compute bar

5.1 TUNNEL CONTOUR RESULTS

show exterior contourSelect: Interpret > Show Exterior Contour.

In the Visibility Pane, hide Excavation Contour, Contour Plane XY Results and Contour Plane YZ Results entities.

Tunnel Contour Results in RS3

In the Visibility Pane under Roles, scroll down to [Group: Query]. Hide the Exterior Contours and show the following results: Excavation Contour, Contour Plane XY Results and Contour Plane YZ Results.

Visibility Role

contour results in planes

5.2 LINER LOCAL COORDINATES RESULTS - CONTOUR

Set the Legend to Liners and Axial Force X. In the Visibility Pane under Roles, scroll down to Group: Query again and ensure all Liner Results are visible.

visibility pane_roles_liner results

Notice that in the Legend there is a drop-down menu below the Liners result type defining the liner coordinate frame used. The Global Frame refers to using the global coordinates as the liner coordinates for displaying results. Change the frame to Tunnel Frames 1 which is the frame we defined earlier (as shown in the figure below). In this frame, the Axial Force X is the force along the hoop direction, tangent to the circumference of the tunnel.

legend bar

liner results in local frame

Set the Legend to Moment Y. This is the moment about the tunnel axis (local y axis of Tunnel Frames 1).

liner results_moment Y

Let’s try plotting and exporting liner data in the current selected local liner coordinate frame.

5.3 LINER LOCAL COORDINATES RESULTS - QUERY

A plane will be created to use the Add Liner Line Query at Intersection add liner line query at intersection iconoption, in the order to obtain liner query data around the tunnel wall at a specific location.

primitive planeSelect: Geometry > 3D Primitive Geometry > Plane

In the Edit Plane dialog, open the Plane Definition section. Set the origin (X, Y, Z) to (-0.3, 9.5, -0.5). Define the plane orientation by a normal vector of (-0.342, 0.94, 0). Leave the role as construction and click OK. This creates a plane parallel to the circular tunnel face that cuts fully through the tunnel.

edit plane dialog

create a plane

In the viewport and with Entity Selection B entity mode active, hold CTRL and select the newly created Plane and the tunnel volume that it intersects called TNL 17: Region 0, Zone [4]_24. You can also select these entities in the Visibility Pane.

select tunnel entity at intersection

add liner line query at intersection iconSelect: Interpret > Queries > Add Liner Line Query at Intersection.

Click OK on the Query Options dialog.

query options dialog

Hide the Plane and Tunnel Frames 1 entities. A liner line query has been created around the circumference of the tunnel. Ensure the Legend is set to Liners, Tunnel Frames 1 and Axial Force X.

add liner line query at intersection_model

To graph the Axial Force X along the liner line query, select the liner line query from the visibility tree. In the Properties pane, click the Graph Data button. The graph will appear in a new Chart View tab.

Add Liner Line Query at Intersection_graph data

Axial Force X

In the Chart View tab, you can easily change plot data. Select the Change Plot Data button in the Chart Options pane. There are options to change the Primary Data, Horizontal Axis and plotted stages. Try changing the Primary Data to Moment Y and select OK.

Moment Y_Chart Option

Moment Y

A coarse mesh was used to improve computation speed as this tutorial focuses on showcasing the modelling process. A finer mesh would result in smoother plots.

Let’s export the data points.

Select: Chart > Copy Data to Clipboard.

You can also select the Copy Data to Clipboard copy icon or right-click in the chart area and select Copy Data to Clipboard. The data are comma-separated values, which can be pasted and easily processed in Excel or any text editor. Below is the pasted data in Excel and converted to columns using their Text-to-Columns option that can delimit by commas.

Excel Data

This concludes the tutorial.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee