Rocscience acquires DIANA. Read more

Search Results

Application of Discrete Fracture Networks

1.0 Introduction

This tutorial demonstrates how to apply Discrete Fracture Network (DFN) to the RS3 model. The DFN approach for modeling fractured rock masses refers to explicit representation of fractures forming a network. This tutorial covers the use of DFN to represent a joint set applied to a sector of an open pit mine, which consists of sandstone, schist, shale, and siltstone. The joint set dips at 63 degrees, dipping towards 259 degrees (in near opposite direction from the slope).

All tutorial files installed with RS3 can be accessed by selecting File > Recent > Tutorials folder from the RS3 main menu. The initial file of the tutorial can be found in DFN application - starting file.rs3v3 file and the finished tutorial can be found in the DFN application - final.rs3v3 file.

2.0 Starting the Model

  1. Select File > Recent > Tutorials from the menu.
  2. Open the starting file DFN application - starting file.rs3v3.

The model should have initial project settings and material properties of external volume already defined for the user.

  1. Select: Analysis > Project Settings Project Settings icon
  2. The Project Setting dialog is used to configure main analysis parameters for your RS3 model. Under the tab [Units], set Units as Metric, stress as MPa. The dialog should look as shown below:
    Project Settings
  3. Click OK to close the dialog.

3.0 Assigning DFN

  1. Select Materials > Discrete Fracture Networks (DFNs) > Define DFNs…

The Define DFNs dialog appears, which is divided in three sections with each section designated for users to:

  • Add/remove DFN set or add/remove Parallel or Cross Jointed DFN types under the certain DFN set.
  • Control the geometry of the bounding box (when having DFN set selected) or assign DFN parameters (when having DFN type selected) from the input data fields, which are grouped under headings. Labels (descriptions) of the input fields are shown on the left cells while the corresponding actual input fields are on the right.
  • See or manipulate the preview of the defined DFN within the bounding box.
The bounding box is an arbitrary space that limits the extent of DFN for the preview on the viewport of Define DFNs dialog, which helps users to visualize the density of the joint planes for the given space. By default, bounding box defines the coordinate based on the size of the model.
  1. Click the text of the set name on left section of the dialog to change the name of the DFN set from “DFN”, to “Parallel Joint Set."
    DFN name change
  2. Enter the scale of the Box as following
    1. Box Min: X1 = -530, Y1=-640, Z1=-370
    2. Box Max: X2=540, Y2=650, Z2=230
  3. Select Add Parallel DFN from the three dots drop down menu next to the DFN to create a new set of parallel joint network.

Define DFN

3.1 JOINT NETWORK INPUT

When new Parallel or Cross jointed DFN is added, the Define DFNs dialog automatically selects the newly added DFN type and the input data fields also switches accordingly.

  1. Keep the Property of the DFN to Joint 1 and Infinite Plane enabled.
  2. Enable the Is Spacing Stochastic with Normal spacing distribution and specify the following distribution parameters:
    • Sp. Mean = 20
    • Sp. Std. Dev = 7
    • Rel. Min = 10
    • Rel. Max = 30
  3. Specify the joint orientation of 63/259 for dip/dip direction and click Preview. Then click OK.

Define DFN Parallel Define

Due to the nature of stochastic distribution, the joint network shown in the figure or in the final model is not going to match with the model being created following these steps.

The model should already have joint properties defined, but it can be checked to make sure that the assigned inputs are as shown below

  1. Select: Materials > Joints > Define Joint Properties Joint Properties icon

Joint properties dialog

3.2 ADDING DFN

We are going to assign the DFN to Shale entity.

  1. Select the Shale entity from the visibility tree or viewport (But make sure the Entity Selection entity selection icon mode is enabled when selecting from the viewport).
    Shale selected
  2. Select: Materials > Discrete Fracture Networks (DFNs) > Add a DFN…
  3. The Add DFN dialog should appear as below (Checking the Preview check box geometry of the joint network). Clicking OK will add DFN to the Shale entity.

DFN preview

The model with DFN successfully added (and selected) to the Shale entity should look similar to below. As described earlier on note, the joint distribution in the model generated following the described steps may NOT look identical to the figure below.

DFN selected

3.3 DIVIDE ALL GEOMETRY

Now that we have completed assigning DFN, we can use the Divide All Geometry function to fully integrate the DFN for the stress analysis computation.

  1. Select: Geometry > 3D Boolean > Divide All Geometry

The Divide All Parameters dialog appears, which can be used to fine-tune the details of subdividing external boundaries. Keeping Quality in Default is suitable for a wide range of models in general, however, there are cases where changing the setting is required to successfully intersect every geometry with the external volume.

For more detail about each option under Divide All Parameters, please refer to Divide/Un-Divide All Geometry.
  1. We will keep the Quality default for this tutorial. Select OK to begin dividing.

Divide All Parameters

4.0 Field Stress

  1. Select the Loads workflow tab Loads workflow tab
  2. This tab allows you to define loading condition and field stress.

  3. Select: Loading > Field Stress Field Stress icon
  4. The Gravity field stress option is used for this model, which applies in-situ stress field that varies with depth. Gravity field stress is typically used for surface or near surface excavations modelling, which has varying ground profile elevation.

  5. The depth and the unit weight of overlying material determines the vertical stress distribution throughout the model. The horizontal stresses are then calculated by multiplying the vertical stress by the Horizontal/Vertical Stress Ratio(s).

  6. Since this model does not consists of soil material, Use effective stress ratio is disabled. In the Field Stress dialog, the following parameters are used to define a Gravity stress field.

Field Stress

5.0 Restraints

  1. Move to the Restraints workflow tab Restraints workflow tab to assign restraints to the external boundary of the model .
RS3 has a built-in “Auto Restrain” tools, which provide shortcut to apply default external boundary restraints.

For this tutorial, we need to apply XYZ restraints on all surfaces other than the excavated slope face.

  1. Select: Restraints > Auto Restrain (Surface) Auto Restrain (Surface) icon

After the application of restraints, your model should look similar to the one below

Restraint applied

6.0 Mesh

  1. Next, we move to the Mesh workflow tab Mesh workflow tab

Here, we may specify the mesh type and discretization density for our model. For this tutorial, we will use a default setting, 4-noded tetrahedra graded mesh.

  1. Select: Mesh > Mesh Settings Mesh icon
    Mesh Settings (Default)
  2. Click the Mesh button from the dialog to begin meshing the model and click OK when completed.

Your model should look like the figure below.

Meshed model

7.0 Computing Results

  1. Next, we move to Compute workflow tab Compute workflow tab

From this tab, we can compute the results of our model. Before commencing the stress analysis computation, it is recommended to save the final model as a separate file so that you can access the original file anytime: File > Save As.

  1. Select: Compute > Compute Compute icon

8.0 Result Interpretation

  1. Next we move to Results workflow tab Results workflow tab

8.1 SOLID DEFORMATION

Following procedures will guide you to see the deformation of solid elements.

  1. Select Solid Displacement > Total displacement for the contour plot.
    Select Tot Displace
  2. Select: Interpret > Show Exterior Contour Show Exterior Contour icon

The slope deformation is concentrated at the upper region of the shale with the maximum total displacement of 0.18 m.

Solid displacement

  1. Having Shale entity selected, select Interpret > Displacement Vectors Displacement vector icon
  2. The vectors that show the direction of the element displacement appears. Since the size of these vectors are too small to visualize, having the newly created Displacement Vectors entity selected from the visibility tree, increase the Max Length to 20 under Properties pane. Also, switching the vector color to black produce vectors more distinct like the figure below.

Solid displacement_RE2

To examine the displacement within the region of high deformation with respect to depth, we will create a contour plane to make a section view of the contour.

  1. Select: Interpret > Show data on plane > XZ Plane XZ Plane icon
  2. Enter the origin location/orientation of the plane as following:
    1. X1 = 12536.7, Y1= 18814.9, Z1= -69.1
    2. Orientation (Dip/Dip Direction): 90/-9.0
  3. Click Add and then Close.
    adding contour plane_RE
  4. Hide all entities other than the created contour plane and maximize the Front view by right clicking on the viewport box in the top right hand corner.
    Contour plnae_RE
  5. The contour plane shows discontinuous displacement due to shearing of joints (See Section 8.2 for the state of the joint). The modeling result indicates that this region is prone to toppling failure. Toppling effect becomes more conspicuous after reducing the Interval Count to 20 and with Show Contour Lines enabled from Contour Option Contour Options
    Contour options-disp
  6. Click OK.

initial disp contour plane_RE1

8.2 JOINT STATE

The state of joint elements can be examined by following the procedure:

  1. Switch the Results Element Type under Legend from Solids to Interfaces & Joints

Data Type Interfaces Joints

  1. Select: Interpret > Yielded Elements > Pick Yielded Elements. From the Pick Yielded Elements dialog, enable Shear and Tension under Interface + Joint Elements.

Pick Yielded Elements

  1. Click OK. The yielded elements (shear and tension) will be displayed. But, since the contour data already is active, yielded joint elements may not be clearly visible. Following additional steps show tricks to help to visualize the yielded elements, which can be done by hiding the projected contour data. We can change the contour legend to be out of the range. If no changes were made to the contour data type, it should be set to Relative X Displacement in default (and the following steps are explained assuming that the Relative X Displacement plot is displayed).
  2. Select: Interpret > Contour Legend > Contour Options Contour options icon
  3. Switch Contour Range from Auto Range to Custom Range (1 to 2).

Joint disp contour options

The view port should show the location of failed joint elements as below. The modeling result shows the shear failure of most of the joint elements at the upper region of the shale, where the maximum deformation happens.

Joint Failure2

This concludes the tutorial.

Rocscience logo, click here to return to the homepage Portal Account Portal Account Log In Log Out Home Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" Previous Next PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's X page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Click here to visit Rocscience's Reddit page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSlope RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge RocTunnel Commercial License Education License Trial License Shop safe & secure Money-back guarantee