Rocscience International Conference 2023 | April 24-26, 2023 Learn More about RIC2023
 

Search Results

RS3 Quick Start

1.0 Introduction

This tutorial introduces some of the basic features of RS3. The model used in this tutorial analyzes the effect of a foundation being constructed near a sloped underground tunnel. We will create a multi-stage model using stages so that we may observe how the soil behaves at each specific step of the foundation's construction and compare the results. The stages that will be considered are:

  1. Initial Conditions
  2. Excavate Tunnel
  3. Excavate Foundation
  4. Pour Concrete Foundation
  5. Loading Foundation
All tutorial files installed with RS3 can be accessed by selecting File > Recent > Tutorials folder from the RS3 main menu. The finished product of this tutorial can be found in the Quick Start file in the Tutorials folder.

2.0 Starting a Model

Open RS3. You will see a blank workspace.

Project Settings icon Select: Analysis > Project Settings.

Our first step is to configure the analysis parameters for the model. Always check that you are working with the right units.

Units

Select the [Units] tab.

By default, the project settings dialog will be displaying the [Units] tab.

Set Units to Metric, stress as kPa and keep everything else as default. The dialog should look as shown below:

Project Settings Dialog under Units tab

Now we will be adding additional Stages to our analysis.

Stages

Select the [Stages] tab. Enter Number of Stages = 5 and input each stage name as shown in the table below:

Stages

Stage Name

1

Initial

2

Excavate Tunnel

3

Excavate Foundation

4

Pour Concrete Foundation

5

Loading Foundation

We will be applying different procedures at each stage, so it is important to keep track of the stages by labeling them with relevant names.

After inputting the stage names, the dialog should look as follows:

Project Settings Dialog under Stages tab

For this model, we will NOT be including any groundwater in the analysis so we must indicate this in the project settings.

Groundwater

Select the [Groundwater] tab. By default the Method is set to Phreatic Surfaces. Change Method to None.

More details on this feature are provided in Online Help (Keyword search: Project Settings/Groundwater). We will be covering this topic in more detail with the Transient Dam tutorial.

The dialog should look as follows:

Project Settings Dialog under Groundwater tab

Select OK to save and close the project settings dialog.

3.0 Defining the Materials

RS3 is designed with an intuitive workflow to help guide the user through the required steps in creating a model. Under each tab, the toolbars and menus are customized to provide the user with the functions they will need in each step of creating their model.

We will begin with the Geology tab.Geology Workflow tab

Materials icon Select: Materials > Define Materials.

The Define Materials dialog has several tabs that are used to assign different material properties.

By default, RS3 assigns “Material 1” to all entities created in the Geology tab. You can save some time assigning materials by defining "Material 1" as the material you want the majority of your model to have.

Enter the following properties for “Material 1” and “Material 2” in the [Initial Conditions] and [Stiffness] tab. Leave the other options with default settings.

Name

Initial Loading

Unit Weight (kN/m3)

Young's Modulus (kPa)

Poisson's Ratio

Material 1

Soil

Field Stress & Body Force

20

20000

0.3

Material 2

Concrete

Body Force Only

27

280000

0.3

The Material Properties dialog for Soil should look like the following:

Material Properties dialog box

Select OK to save and close the Material Properties dialog.

4.0 Creating Geometry

Ensure the Geology tab is still selected from the workflow.

RS3 uses an external box to act as the boundaries of the model; only objects contained within or a part of the external box will be considered in the calculations. As such, when creating a model, it is important to realize the model’s bounds before setting up the external box

Create External Box icon Select: Geometry > Create External Box.

A Create External dialog will open.

Enter First Corner (x, y, z) = (0, 0, 0), Second Corner (x, y, z) = (30, 30, -20)

Select OK.

Create External Dialog

The external volume geometry should now be displayed in the viewports. Under the visibility pane on the left, select the 'External' volume and re-name it to 'Soil' using properties pane below. Your screen should look like the following:

Screenshot of External Volume

When creating geometry keep in mind that RS3 uses the Z direction as the default for the direction of gravity. Orient your model accordingly.

5.0 Excavation

Select the Excavations tab from the workflow at the top of the screen.Excavations workflow tab

5.1 CREATING A CYLINDER FOR THE UNDERGROUND TUNNEL

We will now define a cylinder to represent the underground tunnel.

Cylinder icon Select: Geometry > 3D Primitive Geometry > Cylinder.

Enter the following axis and properties:

Axis Start Point (x, y, z) = (10, 0, -10),

Axis End Point (x, y, z) = (10, 30, -10),

Radius = 1

Subdivisions = 25

Role = Excavation

Select OK to save and close the dialog.

Create Cylinder dialog

The model should now look like the following:

image of model

Next, we are going to represent the foundation by creating an extruded circular polyline.

We could easily create the foundation through defining another cylinder as we did above for the tunnel, but for the purpose of demonstrating the draw polyline feature of RS3, this cylinder will be created through a different (more lengthy) process.

5.2 EXTRUDING A CIRCLE FOR THE FOUNDATION

Draw Ployline icon Select: Geometry > Polyline Tools > Draw Polyline.

A Draw Polyline pane will open on the left side of the screen.

Draw Polyline dialog

Set Plane Orientation = XY

Now input the following:

XY Origin (x, y, z) = (17.5, 15, 0)

Path Definition = Circle

Circle Definition = Center and Radius

Radius = 5

Coordinate Input U, V = 0, 0 (make sure to press enter),

Now select the green checkmark Green Checkmark iconlocated at the top-right corner to close the pane.

You can click the grey arrow beside Discretization Settings to enable the Number of Segments and Segment Length options. With these two options you can input the number of straight-line segments (that define the circle) and the approximate segment length, respectively. For the purposes of this tutorial the default is fine.

The model should look as shown below:

Model view (from 4 viewports) with circle polyline

If you want to rotate the 3D perspective model, select the counterclockwise arrow in the 3D viewport or select the viewcube and rotate the box to your liking.

Select Polyline in the visibility pane.

Extrude icon Select: Geometry > Extrude/Sweep/Loft Tools > Extrude

You can also extrude the polyline by selecting the Extrude icon in the toolbar

An Extrude Geometry dialog will appear as shown below.

Under Direction keep (x, y, z) = (0, 0, 1) and change Depth = -0.5,

Select OK.

Extrude dialog

Notice only the external layer is locked from the visibility tree. This is because the layer is defined as an external volume and the geometry CANNOT be modified.

The other entities (Cylinder and Polyline_extruded) in the visibility pane are geometry objects that are currently not interacting with the external volume.

Visibility Pane dialog

In order to integrate these objects into the external volume of the model, we need to use the Divide All Geometry function to convert the geometry objects to sub-volumes in the main model.

5.2.1 Divide All Geometry

Now that we’ve defined the external box and the objects to be cut into it, we can use the Divide All Geometry function.

Make sure none of the geometries in the visibility pane are selected so the function can be applied throughout the whole model. If you want to divide specific geometries separately, select the geometry of interest and apply the Divide All Geometry function.

Divide All Geometry icon Select: Geometry > 3D Boolean > Divide All Geometry.

The Divide All Parameters dialog helps users to fine-tune the behaviour of the Divide All function. Setting Quality to the Default option is suitable for a wide range of models in general, however, there are cases where changing the setting is required to successfully intersect every geometry with the external volume.

For more detail about each option under Divide All Parameters, please refer to Divide / Un-Divide All Geometry.

We will keep everything default for now. Select OK to begin dividing.

Divide All Parameters dialog

Your model should now look similar to the one below.

Model after using the Divide All function

If you look at the visibility pane you will notice that the names of each geometry are labelled with numbers. You can remove the numbers by simply selecting each and changing the names in the properties pane.

Select each geometry and name them according to the table below:

Geometry Entity

Name

Cylinder_1

Underground Tunnel

Soil_2

Soil

Polyline_extruded_3

Foundation

6.0 Staging

6.1 STAGING THE TUNNEL EXCAVATION

The Underground Tunnel is excavated at Stage 2. Therefore in Stage 1 it should still be modeled as “Soil”. While still in the Initial stage, make sure for Underground Tunnel that the Applied Property in the properties pane is set to Soil.

RS3 separates stages through tabs at the bottom of the window. As you select each stage the viewports will update the loads, materials, and other elements that were assigned that specific stage. This feature makes it easy to view the different states of the model at each stage.

Now we will move to the Excavate Tunnel stage.

Select the underground tunnel in the visibility pane and in the properties pane change the Applied Property = No Material.

Once you change the property of a body, RS3 will automatically carry over that property to all subsequent stages (e.g. if a body was excavated in Stage 1, indicated with Applied Property = No Material, the body will have an applied property of No Material for all subsequent stages).

6.2 STAGING THE FOUNDATION

Now we do the same thing for the foundation as we completed for the tunnel, but starting from the Excavate Foundation stage.

Select the stage tab Excavate foundation.

Select the foundation volume from the visibility pane and in the properties pane, change Applied Property = No Material.

Now select the Pour Concrete Foundation stage, and in the properties pane change the Applied Property = Concrete.

RS3 also provides a quick visual summary of the currently selected object’s state in each stage. For example, if you select the foundation in the visibility pane, on top of the stage tabs, you’ll notice stage 1 and 2 have a purple line above (indicating it is material 1), stage 3 is white (indicating it is defined as no material), and stage 4 and 5 are both light green (concrete).

Stages Summary tab

7.0 Adding Stress Loading

7.1 APPLYING A SURFACE LOAD TO THE MODEL

Select the Loads tab. Loads workflow tab

This tab allows you to edit the loading conditions. We will be applying a uniformly distributed load onto the foundation surface.

Faces Selection icon Select: Edit > Selection Mode > Faces Selection

Select the top face of the foundation either using the XY-plane modeler view or the 3D modeler view. When selected the 3D modeler view should look similar to the following:

Image of applying surface load to a model

Select: Loading > Add Loads to Selected.

Enter the following:

Magnitude = 200 (kN/m2)

Install at Stage = Loading foundation

For all other options keep the default values.

Notice that by default the Load Type is set to Uniform Load. This will allow the users to apply uniformly distributed load on the area of interest.

Select OK to save and close the dialog. Before closing you can check to see if your dialog looks like the one below:

Apply Load to Selected Faces dialog

7.2 APPLYING A FIELD STRESS

The Field Stress option allows you to edit the field stress loading conditions.

Select Loading > Field Stress.

Leave the settings as their default values (e.g. Field Stress Type is set to Gravity). Select OK.

Field Stress dialog

Field Stress is applied to elements where initial element loads are defined with field stress. If the elements do not have field stress assigned (i.e. initial element loading set to Body Force Only) this stress will NOT be used at all. Since we have soil with initial element load set to Field stress & Body Force, this load will be applied in our model. Please refer to RS2 online help for more information about initial element loading.

8.0 Setting Boundary Conditions

Move to the Restraints tab to assign restraints to the external boundary of the model. Restraints workflow tab

RS3 has a built-in "Auto Restrain" tool for use on underground models. For the purpose of this tutorial we will use the Auto Restrain (Surface) option.

Auto Restrain (Surface) icon Select: Restraints > Auto Restrain (Surface). The model should look as the following:

3D modeler view after Auto Restaint


This completes the construction of our model's geometry.

9.0 Meshing

Next, we move to the Mesh tab. Mesh tab

Here we may specify the mesh type and discretization density for our model. For this tutorial, we will use the default settings.

Mesh icon Select: Mesh > Mesh Settings

Mesh Settings dialog


Make sure that Element Type = 4-Noded Tetrahedra and Mesh Gradation = Graded.

For Element Type there are two types available; 4-noded tetrahedra and 10-noded tetrahedra. The 10-noded tetrahedra has mid-side nodes and has more computational points. Using the 10-noded tetrahedra generally yields more accurate result at the cost of computation time. For more accurate results, it is recommended that you use the 10-noded tetrahedra type and 4-noded tetrahedra if computational efficiency is a priority.

Select Mesh to mesh the model. Select OK to close the dialog.

In case if you selected OK before Mesh, your model will not have a mesh. You can simply select Mesh > Mesh to mesh the model.

10.0 Computing Results

Next, we move to Compute tab. Compute workflow tab

From this tab, we can compute the results of our model. First, save your model: File > Save As.

Use the Save As dialog to save the file. Next, you need to save the compute file: File > Save Compute File.

You are now ready to compute the results. Select Compute.

The RS3 Compute engine will perform the required finite element calculations. This computation may take a few minutes; however, more complex models may take longer to compute. Once the computation is complete, the dialog will close.

Compute dialog

11.0 Interpreting Results

11.1 DISPLAYING THE RESULTS

Next, we move to Results tab. Results workflow tab

From this tab, we can analyze the results of our model. First, let's refresh the results.

Refresh All Results icon Select: Interpret > Refresh All Results.

Refreshing the result allows us to plot new results of the model. Although we did not have any previous results from this model, it is good practice to refresh results before we view new contour plots.

On the top right corner of the screen you should see two drop-down menus; Element = Solids and Data Type = Sigma 1 Effective by default.

Results tab drop down menu

The “Element” drop-down menu allows you to view the results for solids, bolts, and liners. For this tutorial, we can only view results for Solids.

We will analyze a number of different “Data Type” results. Let’s turn on the exterior contours so we can see some results.

Show Excavation Contour icon Select: Interpret > Show Excavation Contour.

Show Data on Plane icon Select: Interpret > Show Data on Plane > XZ Plane

Enter the following origin (x, y, z) = (18, 15, -10).

Contour Plane dialog

Select Add and then Close. You should now see a contour plot in the XZ plane.

XZ Plane Contour in 3D modeler view
XZ Plane Contour in Stage 2 (Excavate Tunnel)

11.2 DISPLAYING THE PRINCIPAL STRESS RESULTS

In order to compare each stage against each other visually, the contour colour scheme should be standardized across all stages. We can do this by:

Contour Options icon Select: Interpret > Contour Legend > Contour Options

Select the checkbox Auto Range (All Stages) as also shown below. Select OK

Contour Options dialog


The Sigma 1 Effective results for stages 4 and 5 are shown below in different views:

Sigma 1 effective at Pour concrete foundation (Stage 4)

Sigma 1 effective at Loading foundation (Stage 5)

2D view

Stage 4 Sigma 1 Effective Contour in 2D View (XZ Plane)Stage 5 Sigma 1 Effective Contour in 2D View (XZ Plane)

3D view

Stage 4 Sigma 1 Effective 3D ViewStage 5 Sigma 1 Effective 3D View

Legend

Stage 4 Sigma 1 Effective Legend barStage 5 Sigma 1 Effective Legend bar

As shown in the contour plot, we can see the changes in the stress distribution across the soil model as a load of foundation is applied at stage 5. Next, we will investigate the change in the displacement across stages 2 to 5.

11.3 DISPLAYING THE DISPLACEMENT RESULTS

In the top right corner of the Results tab, ensure Element = Solids, and change Data Type = Total Displacement

Results drop down menu

Similar to principal stress result comparison, we will also use auto range across each stage for contour options.

Contour Options icon Select: Interpret > Contour Legend > Contour Options.

Select the check box Auto Range (All Stages).

The Total Displacement results for stages 2 through 5 are shown below in 3D view:

Excavate Tunnel (Stage 2)

Stage 2 Total Displacement Contour in 3D viewStage 2-4 Legend bar

Excavate Foundation (Stage 3)

Stage 3 Total Displacement Contour in 3D view

Pour Concrete Foundation (Stage 4)

Stage 4 Total Displacement Contour in 3D view

Loading Foundation (Stage 5)

Stage 5 Total Displacement Contour in 3D viewStage 5 Legend bar (total displacement)

This concludes RS3's Quick Start tutorial.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee