Join one of our upcoming courses taking place around the world! Explore now
 

Search Results

02 - Synthetic Joint Sets

1.0 Introduction

Joint sets are groups of joints which have similar orientation. Using distributions of joint set orientation, spacing, and size, we can statistically sample and generate joints across a provided traverse (i.e., scanline, borehole, etc.). This tutorial covers the use of synthetic joints in RocSlope.

Finished Product

The finished product of this tutorial can be found in the Synthetic Joint Set.rocslope_model file. All tutorial files installed with RocSlope can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocSlope main menu.

2.0 Opening the Starting File

  1. Select File > Recent > Tutorials Folder in the menu.
  2. Go to the Synthetic Joint Sets folder and open the starting file Synthetic Joints Sets - starting file.rocslope_model.

This model already has the following defined and provides a good starting point to start defining synthetic joint sets:

  • Project Settings
  • Material Properties
  • External Geometry

2.1 Project Settings

Review the Project Settings.

  1. Select Analysis > Project Settings project settings icon
  2. Select the Units tab. Ensure Units are Metric, stress as MPa.
  3. project settings dialog units tab
    Unit tab in Project Settings Dialog
  4. Select the Analysis tab.
    1. Ensure Successive Failure = OFF. We will only be analyzing the blocks which daylight and are readily removable.
    2. Ensure Design Factor of Safety = 1.2.
    project settings dialog analysis tab
    Analysis tab in Project Settings Dialog
  5. Select the Statistics tab.
    1. Ensure Synthetic Joint Sampling = Latin Hypercube and keep everything else as default.
    project settings dialog statistics tab
    Statistics tab in Project Settings Dialog
  6. Click OK to close the dialog.

2.2 Material Properties

Review the Material Properties.

  1. Select Materials > Define Materials define materials icon
  2. One (1) material property is defined. The Schist material property has:
    • Unit Weight = 0.026 MN/m3.
    • No Water Surface applied.
    define materials dialog
    Schist Material Property in the Define Materials Dialog
  3. Click Cancel to exit the dialog.

2.3 External Geometry

The External is of a pit shell and is composed of one volume assigned with the Schist material property.

3.0 Defining Joint Properties

  1. Navigate to the Joints workflow tab joints workflow tab
  2. Select Joints > Define Joint Properties define joints prop
  3. The Define Joint Properties dialog will open. This dialog allows users to define the Strength Model, Waviness, and Water Pressure for each joint property.

  4. Enter the following properties for Joint Property 1:
    1. Name = Smooth
    2. Under the Strength tab:
      • Strength Model = Mohr-Coulomb
      • Cohesion = 0 MPa
      • Phi = 10 deg
      • Override by Material = OFF
      • Waviness = 0 deg
      smooth joint strength properties
      Smooth Joint Property Strength tab in Define Joint Properties Dialog
    3. Under the Water Parameters tab:
      • Water Pressure Distribution = Dry
      smooth joint water parameters
      Smooth Joint Property Water Parameters tab in Define Joint Properties dialog
  5. Click OK to save and close the Define Joint Properties dialog.

4.0 Adding Synthetic Joints

In this example, we will be defining synthetically joints sampled using set statistics data from Dips. For a given Synthetic Joint Property, the following distributions are specified:

  • Orientation (i.e., dip and dip direction)
  • Spacing (i.e., distance between adjacent joints in a set)
  • Radius

With the orientation, spacing, and radius distributions, the user then defines the traversal path as a polyline on which the X, Y, Z center location of each joint is sampled, according the the spacing. For each joint, the orientation and radius is sampled according to their respective distributions. Like Measured Joints, Synthetic Joints are also modelled as a planar disk.

4.1 Define Synthetic Joints

While still in the Joints workflow tab:

  1. Select Joints > Define Synthetic Joints define synhtetic joints icon
  2. The Define Synthetic Joint Properties dialog contains a list of all defined synthetic joint properties. Each synthetic joint property is defined by distributions of Joint Orientation, and Radius and Spacing. A different Joint Property can be assigned to each joint using the Joint Properties defined in Define Joint Properties dialog.

    For this demonstration, we will be importing the set statistics data directly from a Dips file.

  3. Click the Import From Dips dips icon button.
  4. In the Open dialog, select the Joint Sets.dips8 file from the Tutorials > Synthetic Joint Sets folder and click Open.
  5. Dips 2D Stereonet View with 3 joint sets defined
    Dips 2D Stereonet View with 3 joint sets defined
  6. In the Import Synthetic Joints From Dips dialog:
    1. Set Terzaghi Weighting = Unweighted. See the Terzaghi Weighting topic from the Dips User Guide for more information.

    2. A listing of Joint Sets from the Dips file is shown with Name, Set ID, the mean Dip and Dip Direction, and Fisher K.

    3. Select Overwrite Existing Synthetic Joint Properties. This will overwrite the existing Synthetic Joint Property.
    4. Import Synthetic Joints from Dips dialog
      Import Synthetic Joints from Dips dialog
    5. Click OK to import the three (3) Synthetic Joint Properties from Dips.
    6. When importing from Dips, only the Mean Dip, Mean Dip Direction, and Fisher K are imported, used to statistically sample the joint orientations according to the Fisher distribution. See the Fisher Distribution topic from the Dips User Guide for more information. The Radius and Spacing are set to default values.

  7. For each Dips Set (1m, 2m, and 3m), edit the Radius and Spacing Statistics by clicking the Distribution Distribution icon icon to the right of the Mean Radius and Mean Spacing fields. By default, the Distribution will be set to None.

    For Dips Set 1m:
    1. Set Mean Radius = 100, Distribution = Normal normal distribution icon, Std. Dev. = 10, Rel. Min. = 30. Rel. Max. = 30.
    2. radius statistics popout menu
      Radius Statistics Settings
    3. Set Mean Spacing = 10, Distribution = Normal normal distribution icon, Std. Dev. = 2, Rel. Min. = 6, Rel. Max. = 6.
    4. spacing statistics popout dialog
      Spacing Statistics Settings
    5. Set Spacing Option = True Spacing. See the Define Synthetic Joints topic for more information on Joint Spacing.
    6. define synthetic joint properties dialog
      Dips Set 1m Synthetic Joint Property in Define Synthetic Joints dialog
  8. Repeat Step 5 for Dips Set 2m and Dips Set 3m.
  9. Click OK to save the synthetic joint properties and exit the Define Synthetic Joints dialog.

4.2 Add Synthetic Joint Set

Now define the traverse on which the joint locations are sampled based on the spacing of joints (distribution and spacing option).

To add a synthetic joint set:

  1. Select Joints > Add Synthetic Joint Set add synthetic joints icon
  2. Under the Draw Polyline pane, select Edit Table.
  3. In the Edit Polyline dialog, add 4 rows by clicking the Insert Row insert row icon button at the top of the dialog.
    1. Specify the X, Y, Z points of the polyline within the rows you created as follows:
XYZ
-350-5171004
-430-3381004
-473-2281004
-495-921004

Edit polyline dialog

Edit Polyline Dialog
    1. Click OK.
  1. Click the Done done icon button in the Draw Polyline pane to finalize the polyline.
  2. In the Add Synthetic Joint Set dialog:
    1. Set Joint Property = Dips Set 1m.
      Add synthetic joint set dialog
      Add Synthetic Joint Set dialog
    2. Click OK to add the synthetic joint set.

Select the Synthetic Joint Set entity in the Visibility Tree and the entity will be selected (highlighted red). The following information is shown in the Properties pane:

  • Name = Synthetic Joint Set
  • Applied Property = Dips Set 1m
  • Transparency = 0%, by default

The joints are drawn in the 3D View.

3D View showing Synthetic Joint Set 1m and the Open Pit
3D View showing Synthetic Joint Set 1m and the Open Pit

Repeat Steps 1-5 to add the second joint set:

  1. Select Joints > Add Synthetic Joint Set add synthetic joint icon from the menu or toolbar.
  2. Under the Draw Polyline pane, select Edit Table.
  3. In the Edit Polyline dialog:
    1. Specify the X, Y, Z points of the polyline the same as the first Synthetic Joint Set.
      1. Click OK.
    2. ​Click the Done done icon button in the Draw Polyline pane to finalize the polyline.
    3. In the Add Synthetic Joint Set dialog:
      1. Set Joint Property = [Dips Set 2m].
      2. Click OK to add the synthetic joint set.

    Repeat Steps 1-5 to add the third joint set:

    1. Select Joints > Add Synthetic Joint Set add synthetic joint icon from the menu or toolbar.
    2. Under the Draw Polyline pane, select Edit Table.
    3. In the Edit Polyline dialog:
      1. Specify the X, Y, Z points of the polyline the same as the first Synthetic Joint Set.
        1. Click OK.
      2. ​Click the Done done icon button in the Draw Polyline pane to finalize the polyline.
      3. In the Add Synthetic Joint Set dialog:
        1. Set Joint Property = [Dips Set 3m].
        2. Click OK to add the synthetic joint set.

      The joints are drawn in the 3D View.

      3 synthetic joint sets 3d view
      3D View of all 3 Synthetic Joint Sets and Open Pit

      4.3 Joint Colours

      By default, all joints are coloured according to the assigned Joint Property colour. In this model all three Synthetic Joint Sets are assigned the same Joint Property (i.e., Rough) and are therefore it is hard to distinguish between the sets.

      To colour joints by the Synthetic Joint Property:

      1. Select View > Display Options display options icon
      2. In the Display Options dialog, navigate to the Joints tab.
      3. Select Use Synthetic Joint Property Color.
        dipslay options dialog joints tab
        Joints tab in Display Options dialog
      4. Click OK to close the dialog.

      The joints are now coloured according to Synthetic Joint Property colours.

      3d view joint colours
      3D View of Synthetic Joint Sets coloured by Synthetic Joint Property colours

      4.4 Synthetic Joint Information

      To view a listing of all joints belonging to a Synthetic Joint Set:

      1. Select any of the Synthetic Joint Set nodes from the Visibility Tree.
      2. Select Synthetic Joint Information button from the Properties pane or select Joints > View Synthetic Joint Information joint info icon in the menu.
      3. The Synthetic Joint Information dialog shows a listing of joints in the set with Dip, Dip Direction, X, Y, Z, and Radius columns. The information can be copied by clicking the Copy copy icon button at the bottom-left of the dialog.
        synthetic joints info dialog
        Listing of Joints in Synthetic Joints Information dialog
      4. Information in the Synthetic Joint Information dialog is read-only and cannot be modified.

      5. Click Close to exit the dialog.

      4.5 Randomize Synthetic Joint Sets

      Synthetic Joint sampling is NOT a probabilistic analysis using joint orientation, radius, and spacing as random variables. We are only sampling the joints in a joint set once to get variations in joint orientation, radius and spacing across the traverse. In other words, the sampling only represents one realization of the joint set. The joint set sampling is determined according to the statistics defined in the applied Synthetic Joint Property (i.e., Orientation, Radius, Spacing), the Traverse polyline, and the Pseudo-random Seed value (default seed = 10116). ​

      The ability to form of blocks, the removability of blocks, and the kinematics of blocks are extremely dependent on the joint's orientation, persistence, and spatial location. In some cases, a user may want to see different realizations of the Synthetic Joint Sets so that a different statistical sampling of the synthetic joints are generated and potentially a different collection of blocks.

      To regenerate the sampling for a Synthetic Joint Set:

      1. Select any of the Synthetic Joint Set nodes from the Visibility Tree.
      2. Under the Properties pane, select Edit to edit the geometry.
      3. In the Edit Synthetic Joint Set dialog:
        1. Click the Randomize randomize icon button to randomly pick a new Pseudo-random Seed value. Note that the joints in Synthetic Joint Set 1 have been sampled again using the same distributions but different randomization.
          randomized synthetic joint set
          Randomized realization of the Synthetic Joint Set may not appear as displayed for user model
        2. Repeatedly click the Randomize button a few times to get different realizations.
        3. Select the dropdown from the Randomize button and select Edit Random Seed edit icon.The Random Seed dialog shows the current Pseudo-random Seed value.
        4. Select the dropdown from the Randomize button and select Reset Random Seed. The Pseudo-random Seed value is reset back to the default seed value of 10116. Joint Set 1 will be sampled identically to the initial realization of the joints.
          edit random seed dialog
          Edit Random Seed Dialog showing default seed value
        5. Click OK to close the Edit Synthetic Joint Set dialog.

      5.0 Compute

      RocSlope has a two-part compute process.

      5.1 Compute Blocks

      The first step is to compute the blocks which may potentially be formed by the intersection of joints with other joints and the intersection of joints with the free surface.

      To compute the blocks:

      1. Navigate to the Compute workflow tab compute workflow tab
      2. Select Analysis > Compute Blocks compute blocks icon

      As compute is run, the progress bar reports the compute status. Once compute is finished, the Results node is added to the Visibility Tree and All Valid Blocks are blocks are shown in the 3D View. The Results node consists of the collection of valid blocks and the socketed slope. The original External and Synthetic Joint Set(s) visibility is turned off.

      compute blocks 3d view
      3D view showing all valid blocks

      Once compute is finished, the blocks are coloured according to the Block Color option (Random Colors) set in the Results node's Property pane.

      Compute Blocks only determines the geometry of the blocks. In order to obtain other information such as the factor of safety, Compute Kinematics needs to be run.

      5.2 Compute Kinematics

      The second and final compute step is to compute the removability, forces, and factor of safety for each of the valid blocks.

      To compute the block kinematics:

      1. Ensure that the Compute workflow tab compute workflow tab is the active workflow.
      2. Select Analysis > Compute Kinematics compute kinematics icon

      As compute is run, the progress bar reports the compute status. By default, after Compute Kinematics is run, only Removable Blocks are shown.

      3D CAD view showing removable blocks only
      3D View showing removable blocks only

      6.0 Interpreting Results

      Once both blocks and kinematics are computed, all block results can be viewed in a table format.

        6.1 Block Information

        To view all block results:

        1. Navigate to the Results workflow tab results workflow tab
        2. Select Interpret > Block Information block info icon

        The Block Information pane shows the collection of blocks according to the Results Set settings. The Results Set shown can be selected in the Results tab of the Display Options, or the Properties pane for the Results Node. In this case, only Removable Blocks are coloured and listed in Block Information.

        Visualizing blocks can be difficult when the slope extents are large compared to the block extents.

        To zoom to a selected block:

        1. Select a row (or multiple rows by holding CTRL) in the Block Information listing.
        2. Select Zoom to Selected zoom to selected icon above the Block Information listing (or Zoom to Selected Blocks zoom selected blocks icon in the Interpret menu).

        To zoom into all blocks:

        • Select Interpret > Zoom To All Blocks zoom all blocks icon
        Block Information pane showing removable blocks only
        Block Information pane showing removable blocks only

        6.2 Contour Blocks

        Not only are the magnitudes of critical values such as the block's factor of safety or weight important to be aware of, the location also matters. The Contour Blocks option allows the user to plot a safety map of various block metrics so that the range of values can be visualized over the slope. Let's show the contour of Factor of Safety for only Failed Blocks.

        To show block contours for failed blocks:

        1. Select the Results node from the Visibility Tree.
        2. In the Results node Properties pane, set Results Set = Failed Blocks (FS < Design FS).
        3. Select Interpret > Contour Blocks contour blocks icon
        4. From the Legend pane to the right, select Factor of Safety from the dropdown.

        All the failed blocks are contoured by Factor of Safety. The minimum Factor of Safety blocks are contoured RED while the blocks with Factor of Safety > 5 are contoured BLUE.

        contour blocks results
        3D view showing failed blocks contoured by Factor of Safety

        This concludes Tutorial 02.

        Portal Account Log Out Home Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee