Rocscience International Conference 2025 is going to take place in Sydney, Australia Read more

Search Results

03 - Add Joint Surface

1.0 Introduction

The shape, size and spatial distribution of joint structures may be defined as any arbitrary planar/surface geometry, or a collection of discrete planar surfaces; these can include faults, folding fractures, foliations, or Discrete Fracture Networks (DFNs). This tutorial covers the use of an imported cross-jointed Discrete Fracture Network (DFN) which will be used to model the joints in RocSlope3. The DFN consists of bedding planes dipping 30 degrees toward the east and orthogonal cross-joints.

Finished Product

The finished product of this tutorial can be found in the Add Joint Surface.rocslope_model file. All tutorial files installed with RocSlope3 can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocSlope3 main menu.

2.0 Opening the Starting File

  1. Select File > Recent > Tutorials Folder in the menu.
  2. In the Add Joint Surface folder, open the file Add Joint Surface - starting file.rocslope_model.

This model already has the following defined and provides a good starting point to start defining joint surfaces:

  • Project Settings
  • Material Properties
  • External Geometry
starting file geometry
3D View of Open Pit External Geometry

2.1 Project Settings

Review the Project Settings.

  1. Select Analysis > Project Settings project settings icon
  2. Select the Units tab. Ensure Units are Metric, stress as MPa.
    units tab in project settings dialog
    Units tab in Project Settings dialog
  3. Select the Analysis tab.
    1. Ensure Design Factor of Safety = 1.2.
    2. Ensure Successive Failure = OFF. We will only be analyzing the blocks which daylight and are readily removable.
      analysis tab project settings dialog
      Analysis tab in Project Settings dialog
  4. Click Cancel to close the dialog.

2.2 Material Properties

Review the Material Properties.

  1. Select Materials > Define Materials define materials icon
  2. One (1) material property is defined. The Schist material property has:
    1. Unit Weight = 0.026 MN/m3.
    2. No Water Surface applied.​
      material properties dialog
      Schist Material Property in Define Materials dialog
  3. Click Cancel to exit the dialog.

2.3 External Geometry

The External is of a pit shell and composed of one volume assigned with the Schist material property.

3.0 Defining Joint Properties

  1. Navigate to the Joints workflow tab joitns workflow tab
  2. Select Joints > Define Joint Properties define joint properties icon
  3. The Define Joint Properties dialog will open. This dialog allows users to define the Strength Model, Waviness, and Water Pressure for each joint property.

  4. Enter the following properties for Joint Property 1:
    1. Name = Smooth
    2. Under the Strength tab:
      • Strength Model = Mohr-Coulomb
      • Cohesion = 0 MPa
      • Phi = 10 deg
      • Override by Material = OFF
      • Waviness = 0 deg
    3. smooth joint properties in dialog
      Smooth Joint Property Strength tab in Define Joint Properties dialog
    4. Under the Water Parameters tab:
      • Water Pressure Distribution = Dry
      water parameters of smooth joint
      Smooth Joint Property Water Parameters tab in Define Joint Properties dialog
    5. Click OK to save and close the Define Joint Properties dialog.

4.0 Add Joint Surface

In this example, we will be defining joint surfaces from a DFN geometry file. To import the DFN geometry:

  1. Select File > Import > Import Geometry import geomerty icon. Several geometry file formats are supported. See the Import Geometry topic for more information.
  2. In the Open dialog, select the DFN Cross-Jointed.rsgeomobj file from the Tutorials > Add Joint Surface folder and click Open.
  3. The Import Geometry dialog shows the file(s) and mesh entities available for import and a preview of the entity.
    1. Select All Geometry.
      DFN Cross-Jointed mesh in Import Geometry dialog
      DFN Cross-Jointed mesh in Import Geometry dialog
    2. Click Post-Processing.
    3. Click Done to import the geometry.

The geometry is imported into RocSlope3 and shown in the Visibility Tree. When selected, you will see the following under the Properties pane:

  • Name = DFN Cross-Jointed.Default.Mesh
  • Entity = Surface
  • Role = Geology
  • Transparency = 85%, by default
3d view of imported surface
3D View of imported DFN Surface and Open Pit geometry

4.1 Add Joint Surface

In order for RocSlope3 to treat the imported surface as joints, it must be assigned as a joint surface using the Add Joint Surface option.

  1. Ensure you are still in the Joints workflow tab joints workflow tab
  2. Select the DFN Cross-Jointed.Default.Mesh node from the Visibility Tree.
  3. Select Joints > Add Joint Surface add joint surface icon
  4. In the Add Joint Surface dialog:
    1. Set the Joint Property = Smooth. Each face of the entity is treated as a separate joint by RocSlope3, all with the assigned Joint Property.
      add joint surface dialog
      Add Joint Surface dialog
    2. Click OK to set the entity as a Joint Surface.

Select the Joint Surface entity in the Visibility Tree and the entity will be selected (highlighted red). The following information is shown in the Properties pane:

  • Name = Joint Surface
  • Entity = Surface
  • Applied Property = Smooth
  • Transparency = 0%, by default

The joints are drawn in the 3D View.

3d view of dfn surface set as joint surface
3D View of DFN Surface as Joint Surface and Open Pit geometry

5.0 Compute

RocSlope3 has a two-part compute process.

5.1 Compute Blocks

The first step is to compute the blocks which may potentially be formed by the intersection of joints with other joints and the intersection of joints with the free surface.

To compute the blocks:

  1. Navigate to the Compute workflow tab compute workflow tab
  2. Select Analysis > Compute Blocks compute blocks icon

As compute is run, the progress bar reports the compute status. Once compute is finished, the Results node is added to the Visibility Tree and All Valid Blocks are blocks are shown in the 3D View. The Results node consists of the collection of valid blocks and the socketed slope. The original External and Joint Surface visibility is turned off.

all valid blocks
3D View of all Valid Blocks

Once compute is finished, the blocks are coloured according to the Block Color option (Random Colors) set in the Results node's Property pane.

Compute Blocks only determines the geometry of the blocks. In order to obtain other information such as the factor of safety, Compute Kinematics needs to be run.

5.2 Compute Kinematics

The second and final compute step is to compute the removability, forces, and factor of safety for each of the valid blocks.

To compute the block kinematics:

  1. Ensure that the Compute workflow tab compute workflow tab is the active workflow.
  2. Select Analysis > Compute Kinematics compute kinematics icon

As compute is run, the progress bar reports the compute status. By default, after Compute Kinematics is run, only Removable Blocks are shown.

compute kinematics result
3D View of Removable Blocks

6.0 Interpreting Results

Once both blocks and kinematics are computed, all block results can be viewed in a table format.

6.1 Block Information

To view all block results:

  1. Navigate to the Results workflow tab results workflow tab
  2. Select Interpret > Block Information block info icon

Visualizing blocks can be difficult when the slope extents are large compared to the block extents.

To zoom into all blocks:

  • Select Interpret > Zoom To All Blocks zoom all blocks icon

The Block Information pane shows the collection of blocks according to the Results Set settings. The Results Set shown can be selected in the Results tab of the Display Options, or the Properties pane for the Results Node. In this case, only Removable Blocks are coloured and listed in Block Information.

removable blocks information
Block Information pane showing Removable Blocks only
Even though many valid blocks are formed, only few of them are geometrically removable since most blocks either do not daylight or daylight over only a small portion of the block; not enough to be pulled out of the socket.

To view only failed blocks which have a Factor of Safety less than the Design Factor of Safety (i.e., FS < 1.2):

  1. Select View > Display Options display options icon
  2. Navigate to the Results tab.
  3. Set Results Set = Failed Blocks (FS < Design FS).
  4. Click OK to close the dialog.

OR

  1. Select the Results node from the Visibility Tree.
  2. In the Results node Properties pane, set Results Set = Failed Blocks (FS < Design FS).

Failed Blocks are now coloured and listed in the Block Information pane.

failed blocks info
Block Information pane showing all Failed Blocks

All failed blocks occur on the west side of the pit shell since the bedding planes dip in the same direction as the west portion of the slope. They also have the same factors of safety since they all slide on the bedding planes which have a constant dip angle and only friction angle is considered. These are all planar type failures where sliding occurs on one joint only.

This concludes Tutorial 03.

Rocscience logo, click here to return to the homepage Portal Account Portal Account Log In Log Out Home Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" Previous Next PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's X page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Click here to visit Rocscience's Reddit page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSlope3 RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge RocTunnel RocSlope2 Commercial License Education License Trial License Shop safe & secure Money-back guarantee