Join one of our upcoming courses taking place around the world! Explore now
 

Search Results

01 - Quick Start

1.0 Introduction

This tutorial introduces some of the basic features of RocSlope. The model used in this tutorial is an open pit with measured structures (i.e., joints) of known orientation, size, and location. Assuming that the failure of the slope is structurally-controlled, we will be using the defined joint surfaces to form blocks which may become unstable.

Finished Product

The finished product of this tutorial can be found in the Quick Start.rocslope_model file. All tutorial files installed with RocSlope can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocSlope main menu.

Want to watch a video version of the tutorial? Check it out here:

2.0 Starting a Model

Open RocSlope. You will see a blank workspace.

2.1 Project Settings

Our first step is to configure the analysis parameters for the model in Project Settings.

  1. Select Analysis > Project Settings or click on the Project Settings project settings icon icon in the toolbar.
  2. Select the Units tab.
    1. Set Units to Metric, stress as MPa and keep everything else as default.
    Units tab in project settings dialog
    Units Tab in Project Settings Dialog
  3. Select the Analysis tab.
    1. Set Design Factor of Safety = 1.2.
    2. Set Successive Failure = OFF. We will only be analyzing the blocks which daylight and are readily removable.
    analysis tab in project settings dialog
    Analysis Tab in Project Settings Dialog
  4. Click OK to save the settings and close the dialog.

3.0 Defining Material Properties

RocSlope is designed with an intuitive workflow to help guide the user through the required steps in creating a model. Under each workflow tab, the toolbars and menus are customized to provide the user with the functions needed in each step of creating the model.

We will begin with the Geometry workflow tab to define the materials.

  1. Navigate to the Geometry workflow tab geometry workflow tab
  2. Select Materials > Define Materials in the menu or click the Define Materials define materials iconicon in the toolbar.
  3. The Define Materials dialog allows users to define the Unit Weight of the rock and Groundwater Settings.

    Since the failure is assumed to be structurally-controlled, rock mass strength is not considered in a RocSlope analysis; instead, the shear strength of the joints (defined in the Define Joint Properties dialog) are used to model shear resistance to sliding.
  4. Select Material 1 from the list on the left side of the dialog. Enter the following properties for Material 1.
    1. Name = Schist
    2. Unit Weight = 0.026 MN/m3
    3. Leave the default Groundwater Settings (i.e., no groundwater applied).
    define material properties dialog
    Schist Material Property in Define Materials Dialog
  5. Select Material 2 from the list on the left side of the dialog.
    1. Click the Delete delete icon button on the bottom-left of the dialog to delete Material 2.
  6. Repeat these same steps to delete Material 3.
  7. Click OK to save the changes and close the Define Materials dialog.

4.0 Creating Geometry

We will be using a pit shell surface geometry to create the external geology.

4.1 Import Geometry

To import the pit shell surface geometry into RocSlope:

  1. Ensure the Geometry workflow tab geometry workflow tab is still active.
  2. Select File > Import > Import Geometry import geometry icon. Several geometry file formats are supported. See the Import Geometry topic for more information.
  3. In the Open dialog, select the Open Pit Surface.rsgeomobj file in the Tutorials > Quick Start folder (located in your installation folder) and click Open.

  4. The Import Geometry dialog shows the file and mesh entities available for import and a preview of the entity.

  5. Ensure Geometry Role = Geology in the drop down at the top-left of the Import Geometry dialog.
  6. Select the All Geometry checkbox to select all the entities (in this case, only one 'Mesh' entity exists).
  7. import geometry dialog
    Open Pit Surface geometry preview in Import Geomoetry Dialog
  8. Click the Post-Processing button in the bottom-right of the dialog.
  9. Click Done to import the geometry.

The geometry is imported into RocSlope and added to the Visibility Tree. The Visibility pane is located on the top-left of the application window and shows a tree of entity objects in the model.

Click the Open Pit Surface.Default.Mesh entity in the Visibility Tree. The entity will be selected (highlighted red) and the following information is shown in the Properties pane (below the Visibility pane):

  • Name = Open Pit Surface.Default.Mesh
  • Entity = Surface
  • Role = Geology
  • Transparency = 85%, by default
3D CAD View of Imported Geometry
3D View of Imported Geometry

4.2 Create External Volume from Surface

To create a valid external for modelling, we have to convert the surface of the open pit to a volume.

To create the external volume from a surface:

  1. Select the Open Pit Surface.Default.Mesh surface from the Visibility Tree. The entity is highlighted in the 3D View.
  2. Select Geometry > Create External From Surface create external icon
  3. The Create External From Surface dialog allows the user to set the bottom of the volume (either by Elevation or by Depth).

  4. In the Elevation tab, set the Bottom Elevation = 500.
  5. create external from surface dialog
    Create External from Surface Dialog
  6. Click OK to extrude the model down to an elevation of 500 m and set the volume as an External.

Select the Open Pit Surface.Default.Mesh_extruded entity in the Visibility Tree. The entity will be selected (highlighted red), and the following information is shown in the Properties pane:

  • Name = Open Pit Surface.Default.Mesh_extruded
  • Entity = Volume
  • Role = Geology
  • Applied Property = Schist
  • Transparency = 85%, by default
3D View of Geometry with Extruded Volume
3D View of Geometry with Extruded Volume
The External may consist of several geology volumes and a different material property can be assigned to each volume piece. In RocSlope, different geology volumes and material properties may have an impact on:
  1. The Block's weight since the total weight of the block is the sum of all volume pieces and each piece may have a different Unit Weight (from Define Material Properties dialog).
  2. The Joint's shear strength if the Strength is set to Override by Material. See the Shear Strength topic for more information.
  3. The Joint's water pressure if the Water Pressure Method is set to Material Dependent. See the Joint Water Pressure topic for more information.

In this model, there is only one (1) Material Volume assigned with the Schist material property.

5.0 Defining Joint Properties

Without the consideration of loads and supports (i.e., self-weight of blocks only), the stability of a geometrically removable block depends on the shear strength of the joints on which it slides.

To define joint properties:

  1. Navigate to the Joints workflow tab joints workflow tab
  2. Select Joints > Define Joint Properties or click on the Define Joint Properties define joint properties icon icon in the toolbar.
  3. The Define Joint Properties dialog allows users to define the Strength Model, Waviness, and Water Pressure for each joint property.

  4. Select Joint Property 1 from the list on the left side of the dialog. Enter the following properties for Joint Property 1:
    1. Name = Smooth
    2. Under the Strength tab:
      • Strength Type = Mohr-Coulomb
      • Cohesion = 0 MPa
      • Phi = 10 deg
      • Override by Material = OFF
      • Waviness = 0 deg
    3. Under the Water Parameters tab:
      • Water Pressure Method = Dry
    define joint properties dialog
    Smooth Joint Property in the Define Joint Properties Dialog
  5. Add another joint property by clicking the Add add button button below the list of materials, at the bottom-left of the dialog. Enter the following properties for Joint Property 2:
    1. Name = Undulating
    2. Under the Strength tab:
      • Strength Model = Mohr-Coulomb
      • Cohesion = 0 kPa
      • Phi = 10 deg
      • Override by Material = OFF
      • Waviness = 3 deg
    3. Under the Water Parameters tab:
      • Water Pressure Method = Dry
    undulating joint properties
    Undulating Joint Property in Define Joint Properties Dialog
  6. Click OK to save and close the Define Joint Properties dialog.

The two joint properties model joints which are heavily weathered, providing very little shear resistance.

6.0 Adding Measured Joints

In this example, we will be defining the joints using measured orientation data from a CSV file. We can easily add a list of joints where for each joint, the orientation, location and size is known.

To define measured joints:

  1. Ensure the Joints workflow tab joints workflow tab is still active.
  2. Select Joints > Define Measured Joints or click on the Define Measured Joints define mesaured joints icon icon in the toolbar.
  3. The Define Measured Joints dialog is an Excel-like spreadsheet which allows users to easily input, drag, copy, paste, and import data. Formulas are also supported. Each row represents a single joint. Each joint is defined by a Dip, Dip Direction, and modeled as a planar disk with its center at Location X, Y, Z, and a Radius. A different Joint Property can be assigned to each joint using either the Joint Properties defined in Define Joint Properties dialog, or by specifying a different set of shear parameters for a given Shear Model.

  4. Select Use Joint Properties. We will be assigning the Joint Property from one of the two joint properties defined from earlier.
  5. For this demonstration, we will be importing the orientation data directly from a CSV file.

  6. Click Import CSV import csv icon
  7. In the Open dialog, select the Upper West Joint Mapping Data.csv file from the Tutorials > Quick Start folder and click Open.
  8. In the Import CSV File dialog:
    1. Set the Data Delimiter = Comma.
    2. Set the Start Row = 2 to skip the first header row.
    3. Under the Data Column Selection, set the following indices:
      • Dip = 1
      • Dip Direction = 2
      • Location X = 3
      • Location Y = 4
      • Location Z = 5
      • Radius = 6
      • Joint Property = 7
      • Additional column H = 8
      import csv dialog
      Data selection and preview in Import CSV Dialog
    4. Click OK to import the CSV data.
  9. In Row 1 under the Radius column, set the formula to "= H1/2". Half of the joint's persistence is assumed to be the radius of the joint. Drag the formula all the way down to the cell in the 85th row.
  10. Formulas in this grid control work like Microsoft Excel formulas, which is denoted by "=" followed by an expression. There are also various built in functions which have the same notation as Microsoft Excel.

  11. Assign the first 10 joint's Joint Property = Undulating and the remaining to Joint Property = Smooth.
    1. Right-click and select Assign Joint Property to All > Smooth. All populated rows are assigned with Smooth under the Joint Property column.
    2. Select the cells in the Joint Property column from Rows 1 through 10. Right-click and select Assign Joint Property to Selected > Undulating. The selected (10) rows are assigned with Undulating (as shown below).
  12. define measured joints dialog
    85 Joints populated in Define Measure Joints Dialog
  13. Click OK to save the inputs, exit the Define Measured Joints dialog and add the joints to the model.

Select the Measured Joints entity in the Visibility Tree. The entity will be selected (highlighted red) and the following information is shown in the Properties pane:

  • Name = Measured Joints
  • Applied Property = Measured Joint 1 (currently, only one set of Measured Joint data is supported by RocSlope)
  • Transparency = 0%, by default

The joints are drawn in the 3D View.

3d cad view of measured joints
3D View of Measured Joints and the Open Pit

7.0 Compute

RocSlope has a two-part Compute process.

7.1 Compute Blocks

The first step is to compute the blocks which may potentially be formed by the intersection of joints with other joints and the intersection of joints with the free surface.

To compute the blocks:

  1. Navigate to the Compute workflow tab compute workflow tab
  2. Select Analysis > Compute Blocks or click the Compute Blocks compute blocks icon icon in the toolbar.

As compute is run, the progress bar reports the compute status. Once compute is finished, the Results node is added to the Visibility Tree and All Valid Blocks are shown in the 3D View. The Results node consists of the collection of valid blocks and the socketed slope. The original External and Measured Joints visibility is turned off.

A valid block includes any block which is not attached to the "non-terrain" surfaces. The non-terrain surfaces are the sides and bottom of the model, and are automatically determined by RocSlope.

The blocks are coloured according to the Block Colors option. The Block Colors settings can be edited in the Results node's Property pane or in the Display Options dialog. By default, Block Colors is set to Random Colors, which colours each adjacent block a different colour to be able to easily distinguish between different blocks. The program's default Block Colors can be changed in the Display Options dialog.

3D View of Computed Blocks
3D View of Computed Blocks
Block Colors may appear with different colors than the Random Colors in this tutorial.

For this tutorial, 290 blocks have been computed (some may be invalid). This is indicated by the "Computed Blocks: 290" on the status bar at the bottom-right of the application window.

Compute Blocks only determines the geometry of the blocks. In order to obtain other information such as the factor of safety, Compute Kinematics needs to be run.

7.2 Compute Kinematics

The second and final compute step is to compute the kinematics for each of the valid blocks, including the removability, forces, and factor of safety.

To compute the block kinematics:

  1. Ensure that the Compute workflow tab compute workflow tab is selected.
  2. Select Analysis > Compute Kinematics or click on the Compute Kinematics compute kinematics icon option in the toolbar.

As compute is run, the progress bar reports the compute status. By default, after Compute Kinematics is run, only Removable Blocks are shown.

3D View of Removable Blocks
3D View of Removable Blocks

To show all blocks:

  1. Select View > Display Options or click on the Display Options display options icon icon in the toolbar.
  2. In the Display Options dialog:
    1. Navigate to the Results tab
    2. Set Results Set = All Valid Blocks
    3. Click OK to close the dialog.
Alternatively, the Results Set can also be selected from the Properties pane of the Results node. Removable Blocks and Failed Blocks (FS < Design FS) Results Set options are only available once Compute Kinematics is run.
3D View of All Valid Blocks
3D View of All Valid Blocks

The status of the kinematic compute is indicated by the "Kinematics: Computed" on the status bar at the bottom-right of the application window.

8.0 Interpreting Results

Once both blocks and kinematics are computed, all block results can be viewed in a table format.

8.1 Block Information

To view all block results:

  1. Navigate to the Results workflow tab results workflow tab
  2. Select Interpret > Block Information or click on the Block Information block info icon option in the toolbar.

Visualizing blocks can be difficult when the slope extents are large compared to the block extents.

To zoom into all blocks:

  • Select Interpret > Zoom To All Blocks zoom all blocks icon
Block Information Pane showing All Valid Blocks
Block Information Pane showing All Valid Blocks

The Block Information pane shows the collection of blocks according to the Results Set settings. The Results Set shown can be selected in the Results tab of the Display Options, or the Properties pane for the Results Node. Currently, All Valid Blocks are listed.

A number of columns are available including:

  • ID
  • Color (colour which corresponds to the block's colour in the 3D View)
  • Removable?
  • FS < Design FOS?
  • Factor of Safety
  • Volume
  • Weight
  • Driving Force
  • Resisting Force
  • Failure Mode
  • Sliding Direction Trend
  • Sliding Direction Plunge
  • Required Support Pressure
  • Slope Face Area
  • # of Joints

Any of the columns can be hidden. Let's hide the Volume, Driving Force, Resisting Force, and the # of Joints columns.

  1. Click on the arrow to expand the Visible Columns section the on the left side of the Block Information pane.
  2. Uncheck Volume, Driving Force, Resisting Force, and # of Joints.

The columns are now hidden.

block information pane with hidden columns
Block Information Pane with Volume, Driving Force, Resisting Force, and # of Joints columns hidden

The rows of block data can also be filtered. Let's filter by blocks which have a Weight >= 10 MN.

  1. Click the arrow to expand the Edit Filters section on the left side of the Block Information pane.
  2. Set the Weight minimum = 10 (MN).
  3. Hit ENTER.
block information pane with filter
Block Information Pane with Filter applied

Blocks which are filtered out are not listed in the Block Information table and are also not colored according to the Block Colors option (e.g., Random Colors, Active Contour) selected in the 3D View. A message "Block Results are Filtered" is displayed at the top center of the Perspective Viewport. More advanced filtering criteria can be specified in the Full Filter Editor. See the Filter topic for more information.

Blocks not considered from the selected Results Set in the Display Options nor the Current Filter are colored by Material Colors, so that the blocks blend in with the socketed slope. To hide blocks not considered in the Current Filter, unselect the Show User-Filtered Blocks checkbox in the Display Options dialog, so that only the socket is shown. In both cases, the entry is not shown in the Block Information table.

To save the current filter:

  1. Select the Save Current Filter save filter icon button ​at the bottom of the Edit Filters section.
  2. In the Save Filter dialog:
    1. Select Save As New Filter.
    2. Enter the name of the filter.
    3. Select OK to save the filter and close the dialog.

A list of saved filters can be selected from at a later time under the Saved Filters section from the left of the Block Information pane.

To remove the current filter:

  • Select the Clear Current Filter clear filter button at the bottom of the Edit Filters pane.

To see the detailed information for a given block:

  1. Select the Block ID. For this example, we will select Block ID = 32 from the rows of the Block Information (or graphically, by clicking the Block in the 3D View).
  2. Click the See Block Details button at the top of the Block Information pane.
  3. The Detailed Block Information dialog shows the 3D model of the Block, general block information as well as detailed information for Joints, Joint Line of Intersection, and Block Vertices.

    detail block info dialog for block 32
    Detailed Block Information Dialog for Block ID = 32
  4. Select the Filter button at the top of the Joints table to modify the visibility of columns in the table.
    1. Check or uncheck any column headers to show or hide columns in the Column Chooser dialog.
    2. Click X button to close the Column Chooser dialog.
  5. Click on the More/Less control at the bottom-left of the Detailed Block Information dialog, to expand or collapse the section containing the Joint Line of Intersections and Blocks Vertices tables.
  6. Export the block information to CSV using the Export to CSV export to csv icon button at the bottom-left of the Detailed Block Information dialog. ​
  7. Click Close to exit the dialog.

8.2 Contour Blocks

Not only are the magnitudes of critical values (such as the block's factor of safety or weight) important to be aware of, the location also matters. The Contour Blocks option allows the user to plot a safety map of various block metrics so that the range of values can be visualized over the slope.

To show block contours:

  1. Select Interpret > Contour Blocks or click on the Contour Blocks contour blocks icon option available in the toolbar.
  2. From the Legend pane to the right, select Factor of Safety from the second drop down.

All the removable blocks are coloured according to the Factor of Safety contour legend. The minimum Factor of Safety blocks are contoured RED while the blocks with Factor of Safety > 5 are contoured BLUE. The Contour Options contour options icon can be customized. See the Contour Options topic for more information.

3d cad view of factor of safety contours
3D View of all Valid Blocks contoured by Factor of Safety

From this heat map of Factor of Safety, locations with the lowest factors of safety and highest failure risk can be identified.

To contour blocks by failed weight:

  1. In the Visibility Tree, select the Results node.
  2. In the Properties pane, use the drop down to set Results Set = Failed Blocks (FS < Design FS).
  3. In the Legend pane to the right, select Weight from the second drop down.
3d cad view of failed blocks by weight
3D View of Failed Blocks contoured by Weight

From this heat map of failed block weight, locations with the largest failed volumes can be identified.

8.3 Translate Blocks

Translation animation of the blocks is possible for any blocks which are Removable (i.e., can be removed in at least one valid direction out of the joint socket). For the current Results Set = Failed Blocks (FS < Design FS), all blocks are removable since failed blocks are essentially a subset of removable blocks (i.e., a block that is not removable cannot possibly fail).

To translate a block:

  1. Select Interpret > Translate Blocks translate blocks icon (or right-click and select Translation > Translate Blocks).
  2. Select a block graphically by left-clicking, holding and dragging a block in the 3D View.
  3. When done, right-click and select Done to exit the block translation mode.

To translate all blocks:

  1. Select the Results node from the Visibility Tree.
  2. In the Properties pane, use the Block Translation slider to translate all blocks.
3d cad view of translated blocks
3D View of Translated Blocks

To reset the block translation:

  • Select Interpret > Reset Translation > Reset Selected Blocks reset blocks iconor Reset All Blocks reset all blocks icon to move the blocks back into the socket; OR
  • Click the Reset button from the Results node's Property pane, beside the Block Translation slider.

This concludes Tutorial 01.

Portal Account Log Out Home Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee