RocFall3 | Your new tool for 3D assessment of slopes at risk for rockfalls. Get started with RocFall3 today!
 

Search Results

Getting Started Tutorial

This tutorial is a simple introductory tutorial that helps you become familiar with the basic modelling and data interpretation features of RocFall3. RocFall3 is a 3D statistical analysis program designed to assist with assessment of slopes at risk for rockfalls.

Topics Covered in this Tutorial:

  • Import a geometry file
  • Material and seeder properties
  • Defining/editing seeders
  • Creating material regions
  • Compute
  • Analysis tools

Finished Product:

The finished product of this tutorial can be found in the Tutorial 01 Getting Started.r3DModel data file. All tutorial files installed with RocFall3 can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall3 main menu.

Want to watch the video version of the tutorial? Check it out here:

1.0 Model

Start RocFall3 by selecting Programs > Rocscience > RocFall3 > RocFall3 from the Windows Start menu. RocFall3 automatically opens a new blank document, which allows you to begin creating a model immediately. If the RocFall3 application window is not already maximized, maximize it now so the full-screen space is available for use.

Viewport - new file

1.1 Project Settings

The Project Settings dialog is used to configure the main analysis parameters of the model. To open the dialog, select Project Settings on the toolbar or the Analysis menu. For the tutorial, we'll keep all the default parameters.

  • Select: Analysis > Project Settings Project Settings icon

Units

1.1.1 Analysis Type

In RocFall3 there are two Analysis Types to choose from in the Project Settings Methods tab: Lumped Mass and Rigid Body.

Methods

  • The default method is Lump Mass. With the Lump Mass method, the rocks are assumed to be very small point masses with no physical size. We will be using the Lump Mass method for this tutorial.
  • The Rigid Body analysis method allows you to define rock shapes. Rock shapes are covered in later tutorials.

1.1.2 Engine Conditions

  1. Select the Solver Options tab.

Solver Options

Note the various control parameters. Once one of these conditions is met, the rock will stop moving. For more help on engine stopping conditions, see Engine Stopping Conditions Settings in RocFall3.
  1. For this tutorial, leave the default settings.
  2. Click OK.

1.2 Import Geometry

In RocFall3, the slope can be created from a point cloud, imported from a common geometry file, extruded from an existing RocFall2 file, imported from an RS3/Slide3 File or imported from satellite data (Import Terrain). In this tutorial, we're going to import a provided .obj file.

  1. Select File > Import > Import Geometry Import Geometry iconor Geometry > Import/Export > Import Geometry Import Geometry icon.
  2. Navigate to and open the provided Tutorial 01.obj file in the Tutorials Folder. By default the installation program puts the files in: C:\Users\Public\Documents\Rocscience\RocFall3 Examples\Tutorials
  3. You will see the Import Geometry dialog, which displays a preview of the geometry. Select the Mesh object and click on Post Processing.
  4. In the Post Processing step, you can simplify and repair the geometry. The supplied sample geometry file has been modified and fixed for this tutorial. We recommend to perform both simplify and repair on any imported geometry for fast and reliable compute and analysis results.
  5. Click Done.
  6. You will then be prompted to set the imported surface as the slope. Click Yes.

Starting Model

1.3 Material Properties

  1. Select Materials > Define Materials Define Materials icon

This opens up the Define Material Properties dialog. The program has 3 built-in materials.

  1. Rename the first material to Hard and change the mean Normal Restitution to 0.5 and Tangential Restitution to 0.9.
  2. Click on the Stats Normal distribution button for Tangential Restitution and change the Rel. Max to 0.1 so that the range will be from 0.78 to 1.0.

If you click on the Define All Statistic button it should look similar to the following:

PropertyDistributionMeanStd. Dev.Rel. Min.Rel. Max
Normal RestitutionNormal Normal Distribution0.50.040.120.12
Tangential RestitutionNormalNormal Distribution0.90.040.120.1
Friction Angle(deg)None None30---
  1. Select the second material and rename it to Soft.
  2. Change the mean Normal Restitution to 0.3.
  3. Make sure the mean Tangential Restitution is 0.8 and that the standard deviation for the two restitutions are both 0.04 and the relative min and max are all 0.12.
  4. Keep the Friction Angle at 30 degrees with no distribution.
  5. Click OK.

1.4 Define Material Regions

  1. Select Materials > Add New Material Region Add New Material Region icon

You'll notice that we're on the Material Regions tab in the left pane.

  1. Select the Soft material property to use and click OK.
  2. We're now in the Draw Polyline mode for defining the polygonal region with the Soft material assignment. Roughly trace around the bottom of the pit.
  3. When you're done, right-click and select Done.

The screen should look like the following:

Material Region

If you click on the Edit... Geometry button and you can see the points that define this polygon.

UV
160102.694058923059132.29539135
160244.947418063059127.62897955
160266.1556321323059115.05673741
160326.8427796983059113.75073891
160291.2430011393058972.65918698
160272.8841408393058966.53518082
160261.6019488453058936.60521903
160280.4427196943058924.80762183
160285.867302193058885.78409552
160247.1195300793058743.05811842
160101.0440860593058813.1153744
160045.4019088723058874.56311013
160030.6300761173058935.43969879
160034.2169384763059028.96548316
160060.3189963873059058.79155707
If you'd like, you can copy and paste the vertices from the above table into your model for exactly the same results.

Take note that the rest of the slope has the shading of the first (Hard) material. By default, if no material region is assigned, the first slope material is used.

  1. Click on the Visibility Tree tab in the left pane to get out of the Material Regions definition mode.

1.5 Seeder Properties

  1. Select the Seeders workflow tab. seeder workflow tab
  2. Select Seeder > Define Seeder Properties. This opens up the Seeder Properties dialog.
  3. For the first seeder, change the Number of Rocks to 200. We'll keep everything else the same, so the rock will be free falling from the seeder location.
  4. Define Seeder Properties - dialog

  5. Click on the Add add materials icon button to add a new property.
  6. In this second property, change the Number of Rocks to 20.
  7. Enter 1.5 m/s as the Translational Velocity.
  8. Click on the Stats button, change the Distribution to Normal and enter a Std. Dev. of 0.3.
  9. Click on the 3x button to auto set Rel. Min and Rel. Max at 0.9 (3x std. dev.).
  10. Click OK.
  11. In the Translational Velocity Orientation dropdown, select Trend/Plunge. Enter a 225 deg Trend Angle.
  12. Click on the Stats button, change the Distribution to Normal and enter a Std. Dev. of 5.
  13. Click on the 3x button to auto set Rel. Min and Rel. Max at 15 (3x std. dev.)

    Seeder Propert2
  14. Click OK to save and exit out of the Seeder Properties dialog.

1.6 Add Seeders

For this model, we'll add a line and a point seeder.

  1. Select Seeder > Add Line Seeder add line seeder icon
  2. The Add Line Seeder dialog pops up. Make sure the first seeder property with 200 rocks is selected for Property.
  3. Select the Height Above Surface radio button. Enter 5 m.
  4. Click on Add Points on Viewport. In the top view, try to trace along the crest of the 2nd uppermost bench on the left and lower left sides (See orange polyline in below image).

    Seeder1

  5. When you're done, right-click and select Done.

The Add Line Seeder dialog should look like the following:

Add Line Seeder dialog

  1. Click OK to save and exit out of the Add Line Seeder dialog.
It's not required, but if you want to have the exact same results as this tutorial, the exact seeder can be added by first creating a polyline in the XY plane with the following vertices. You can copy and paste the vertices from the table below into your model. Then select the polyline and convert the polyline into a line seeder. Seeder > Add Line Seeder from Polyline.

XY
160048.2257 3059164.003
160016.5722 3059089.927
159967.1206 3059039.271
159969.395 3058952.277
159975.6494 3058900.535
159984.7469 3058848.793
160024.7027 3058814.252
160074.17 3058765.922

Now let's add the point seeder.

  1. Select Seeder > Add Point Seeder.
  2. Select Seeder Property 2 in the Property dropdown.
  3. Select Enter Coordinates in the Select Point dropdown.
  4. Enter the coordinates 160366, 3059160, 2099 in the Coordinates area. Press OK.

2.0 Compute

Now we're ready to compute.

  • Select: Analysis > Compute Compute icon

3.0 Results

3.1 Path Contours

  • Select the Results flow bar option.

What you see immediately are the paths with the translational velocity contours projected.

In the Legend pane on the right, you can select from the drop-down to view other data: rotational velocity, mass, initial velocity, translational kinetic energy, bounce height, runout distances, end point location, path states, etc.

Rock Paths

3.2 Endpoint Chart

  • Select: Interpret > Graph Endpoints Graph icon

Select OK in the Chart Options dialog. This plots the horizontal runout distances histogram. Close the graph by clicking the X on the view tab.

Graph EndPoints

3.3 Surface Contours

  • Select: Interpret > Create Surface Heat Map Create Surface Heat Map icon

We recommend that you turn off the Rock Path Results using the Toggle Rock Path Results toolbar option.

Histogram


There are two modes: Histogram and Heatmap, and two data types: End Points and Impact Points.

For Histograms, you can adjust the resolution of the squares projected on the slope. It's a very helpful tool to see where most of the rocks end up on the slope. With the Impact Points Heatmap, you can see the contact points of the rocks on the slope.

3.4 Rock Path Information

  • Select: Interpret > Rock Path Information Rockpath Information icon

If the option is disabled, you must have turned off the rock paths when looking at the Heat Map. Simply turn on the rock paths again by selecting the Toggle Rock Path results toggle rock path results button option on the toolbar.

Now select the Rock Path Information Rockpath Information icon option.

Path Info

Here you can see a tabulated summary of the path runs. You can sort and/or filter by any of the column headers. For example, click on the Max Kinetic Energy header cell and the table is sorted from lowest Max Kinetic Energy to highest. Click on the header cell again to reverse the sort from the highest Max Kinetic Energy to the lowest.

Next, click on the filter icon in the Seeder header cell (shown below). In the pop-up dialog, select Point Seeder only.

Filter Header

You'll notice that the table and the result views only show the paths from the point seeder. You can clear off the filter by unchecking on the checkbox at the bottom of the table. You can also click on the pencil icon edit filter icon to edit the filter. The filter can also be edited by expanding the Edit Filters option to the left of the table. In the Runout (XY) option at the bottom, you can drag the slider to see only the paths with horizontal runout distances that are inside the range.

To the left of the table, click to expand the Saved Filters option. Click on the Save Filter button at anytime to save the current filter setup for later use.

We'll leave it as an exercise to explore all the customization you can make to this summary table and filter(s).

3.5 Animate

A very useful feature of RocFall3 is the ability to animate the rocks on your slope take as they fall.

  • Select: Interpret > Animate Rocks Animate rocks icon

Animate Rock Path dialog

Unlike RocFall2, with RocFall3 you have the option to animate one or all of the rocks at the same time.

This concludes the tutorial. You are now ready for the next tutorial: Terrain Generator.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee