Rocscience International Conference 2025 is going to take place in Sydney, Australia Read more

Search Results

5 - RocFall2 Section Creator

This tutorial demonstrates the creation of 2D cross-sections for export to RocFall2, including batch section creation and export.

Topics Covered in this Tutorial:

  • Multi-section export to RocFall2
  • Group plots in RocFall2
  • Runout distance reference line export to RocFall2

Finished Product:

The finished product of this tutorial can be found in the Tutorial 05 Terrain Generator data file. All tutorial files installed with RocFall3 can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall3 main menu.

1.0 Open RocFall3 Model

Start RocFall3 by selecting Programs > Rocscience from the Windows Start menu. RocFall3 automatically opens a new blank document, which allows immediate model creation. If the RocFall3 application window is not already maximized, maximize it now so the full-screen space is available for use.

  1. Select the File > Recent > Tutorial Folder > Tutorial 05 initial.
  2. Go to the Tutorials folder included with the RocFall3 install. The default location of this folder is C:\Users\Public\Documents\Rocscience\RocFall3 Examples\Tutorials. Select the Tutorial 05 Initial file and click Open.

Tutorial 5 import

This model geometry was created from the import of a digital elevation model from satellite data via the Import Terrain feature. The Hard and Soft material regions were defined using the Image Segmentation feature, and the water body regions were manually drawn. The line seeder properties and location were also set. For more information on the process described above, visit Tutorial 2 Terrain Generator.

2.0 Reference Line for Runout Distance Calculation

  1. Select Geometry > Draw Polyline Draw polyline
  2. Draw a line along the 2500 m elevation line, on the eastern slope, ensuring that it fully spans the model.

For exact polyline coordinates adopted for this model, open the provided Tutorial 05 Reference polyline.txt file in the Tutorials folder. Alternatively, the .txt file can be saved by right clicking here and selecting Save Link As. Select Import in the Draw Polyline dialog and import the points.

  1. Right-click and select Done.
  2. Name the polyline "reference line".

    Reference Line Dark
The transparency of the slope was decreased to emphasize the location of the reference line shown in red.

3.0 Compute

  1. Click on the Compute compute icon in the toolbar (or select Analysis > Compute in the menu).

    4.0 Results

    1. Navigate to the Results workflow tab.

    Contours of translational velocity are shown for the rock paths by default. The legend bar on the right can be used to select the result data type.

    Results

    5.0 RocFall2 Multi-Section Creation and Export

    RocFall3 supports batch section creation and export to RocFall2.

    This feature is only applicable if RocFall2 is installed.

    5.1 Creating Multiple Sections

    1. Select the Geometry workflow tab.
    2. From the menu, select Geometry > RocFall2 Section Creator RocFall2 icon
    3. In the Create/Edit Sections dialog, click Create Multiple Sections. add multiple section icon
    4. For the Creation Method, select the Sections per Segment option.
    5. For Number of Sections enter 1. This means 1 cross-section will be created perpendicular to each segment of the drawn polyline (discussed next).
    6. Click Draw, and then left-click to draw a line similar to the reference line as shown in the image below in magenta.
    7. When done drawing, right-click and select Done to exit drawing mode. Notice that 6 sections are created.
    8. Select OK to close the dialog.

      Batch Section Creator

    An alternative to drawing the polyline is to import its exact coordinates. Open the provided Tutorial 05 Creating Sections.txt file in the Tutorials folder. This .txt file is also available by right-clicking here and selecting Save Link As. Select Import in the Batch Section Creator dialog and import the points.

      5.1.1 Deleting Sections

      For this tutorial, delete the sections that don't intersect the reference line and line seeder.

      1. To delete a section, select the section from the list on the left of the Create/Edit Sections dialog and then select the Delete Icon delete located on the bottom-left of the dialog. Section 1-1 and Section 1-6 do not intersect the reference line or the line seeder, so delete these two sections.
      2. Do not close the dialog just yet as more cross-sections are added in the next tutorial section.

      Deleting 1-1

      5.1.2 Adding a Single Section

      1. To add a single section, click Add a Single Section add section located in the bottom-left corner of the dialog.
      2. Click Draw, then select 2 arbitrary vertices that define the cross-section on the model preview. The following image shows the drawn section in green.
      3. Click OK to save and close the dialog.

        section 4

      5.2 Exporting Multiple Sections to RocFall2

      RocFall2 must be installed on the same machine to continue with this tutorial. Please also ensure RocFall2 is updated to the latest version.
      1. Go to the Geometry workflow tab.
      2. Select Export All Section to RocFall2 export section rf2
      3. Options in this dialog can be used to control the model information to be exported to RocFall2.

        Exporting to RF2

      4. Select all cross-sections.
      5. Ensure that the polyline defined as "reference line" is selected from the drop-down Reference Lines menu.
      6. Click Open to load RocFall2.

      Once RocFall2 is open, all exported sections can be viewed.

      Line seeders in RocFall3 export as point seeders in RocFall2. Likewise, area and plane seeders in RocFall3 export as line seeders in RocFall2.

      The line seeder in RocFall3 is now a point seeder in RocFall2, displayed by a blue cross-hair. Any reference line from RocFall3 is displayed in RocFall2 as a dashed green line.

      RF2 Models

      6.0 Compute RocFall2 Model

      Given multiple RocFall2 sections were exported from RocFall3 using the batch export function, they can be computed using Batch Compute batch compute, accessed from the drop-down arrow located next to the Compute icon in the toolbar.

      7.0 Group Analysis

      A Group Plot displays results from multiple sections in the same plot. This is a powerful tool that can be used to compare rockfall trajectories among multiple cross-sections.

      1. In RocFall2, select the Results tab.
      2. From the menu, select Graphs > Group Plots > Graph Endpoints.
      3. Runout distances can be calculated with respect to a reference line. Select the Endpoint Distance From option in data settings, and select the polyline "reference line".
      4. Click Plot Data.

      Graphed Endpoint Dialog

      Runout distances

      This group plot shows the runout distribution in each slope section with respect to the same reference line. The result for each section is shown in a distinct colour (legend on the right). Notice that some of the runout distances are negative, mainly from Section 1-5. The negative values indicate that the rock paths stopped before reaching the reference line.

      Rocscience logo, click here to return to the homepage Portal Account Portal Account Log In Log Out Home Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" Previous Next PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's X page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Click here to visit Rocscience's Reddit page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSlope3 RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge RocTunnel RocSlope2 Commercial License Education License Trial License Shop safe & secure Money-back guarantee