Rocscience International Conference 2025 is going to take place in Sydney, Australia Read more

Search Results

4 - Rigid Body and Surface Texture

1.0 Introduction

This tutorial introduces the rigid body analysis method and how to apply a surface texture image to the slope surface.

Topics covered in this tutorial:

  • Rigid Body Analysis Method
  • Slope surface texture
  • Area Seeders

Finished Product:

The finished product of this tutorial can be found in the Tutorial 04 Rigid Body and Surface Texture.r3DModel data file. All tutorial files installed with RocFall3 can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall3 main menu. By default all tutorials and verification files are installed in the folder C:\Users\Public\Documents\Rocscience\RocFall3 Examples.

2.0 Model

Start RocFall3 by selecting Programs > Rocscience > RocFall3 > RocFall3 from the Windows Start menu.

2.1 Analysis Type

  1. Select: Analysis > Project Settings project settings
  2. In the Methods tab, select Rigid Body from the Analysis Type dropdown.
  3. Enable Scale Rn by Velocity.
  4. Click OK.
Project settings - methods tab
Rigid body analysis method and Rn scaling by velocity

    2.2 Import Geometry

    Import a provided *.obj file:

    1. Select File > Import > Import Geometry import geometry or Geometry > Import/Export > Import Geometry import geometry.
    2. Open the provided Tutorial 04.obj file in the Tutorials Folder. By default, the Rocscience Installer uses the folder C:\Users\Public\Documents\Rocscience\RocFall3 Examples\Tutorials.
    3. The Import Geometry dialog displays a preview of the geometry. Select the Mesh object and click Post-Processing.

      Import Geometry - Mesh

    4. In the Post-Processing step, the geometry can be simplified and/or repaired. Click Simplify Triangulation > Simplification Level > Custom and enter a triangle count of 50,000. Click OK.

    5. Simplify Triangulation dialog

    6. Find and Repair Defects next. Click on Repair to remove all defects. Click Close.
    7. Some defects may remain after an initial iteration of repair. This is because several defects or several different types of defects may be overlapping or adjacent to one another. Simply Repair again to resolve.
    8. Click Done.
    9. Repair Defects

    10. When prompted to "set the imported surface as the slope", click Yes.
    A surface can be set as the slope surface by first selecting the surface entity in the Visibility Tree and then Geometry > Set Slope Surface in the menu.

    Imported geometry

    2.3 Apply Surface Texture

    1. Select the Slope entity in the Visibility Tree. Whenever an entity is selected, it is highlighted in orange in the viewports.
      Selected Geometry
    2. Select Geometry > Assign Texture to Surface Assign texture to surface
    3. Open the provided Tutorial 04.jpg file in the Tutorials folder.

    4. Tutorials folder - JPG image

    5. The Texture Image dialog displays a preview of the image, which can be scaled and moved in this dialog to fit the slope geometry. The supplied image has already been adjusted to fit the slope. Click OK to accept and exit.

    6. Texture Dialog

      warning dialog

      A warning appears noting that the surface texture would be removed with any changes to the geometry. This is because a surface texture is meant to be added after the underlying slope geometry has been finalized. If the slope geometry is modified after adding a surface texture, then the image would be removed. Click OK in the warning window to continue.

    7. Notice the Slope is still selected. De-select the slope by either clicking in the viewport outside the slope geometry, or by clicking Clear Selection on the toolbar.
    8. The surface texture now overlies the slope geometry. Its visibility can be improved by adjusting the slope transparency. In the Visibility Tree, select the Slope entity. In the Properties pane below, decrease the transparency by dragging the slider or entering a lower value in the edit box. Change the slope transparency to 0%, then Clear Selection. The river and highway now can be seen very clearly.

    Texture - Model

    2.4 Show Topographic Lines

    Topographic lines can visually aid in the placement of elevation-dependent elements, such as material regions, seeders, and protection systems.

    1. Select Annotate > Topographic Lines in the menu or click on the Topographic Lines icon Topographic lines icon in the toolbar.
    2. In the Visibility Tree, select the Topographic Annotation entity to view its properties in the Properties pane below.
    3. In the Properties Pane, change the Spacing to 100 and make sure Show Colors is checked.

    Topographic Properties

    Topographic Lines

    The visibility of the topographic lines can be turned on and off by selecting the "eye" icon in the Visibility Tree. show selected geometry

    2.5 Material Properties

    1. Select Materials > Define Materials define material properties
    2. Define the following 3 materials as shown in the table.
    3. Change the colour of the Water material property to a light blue.
    4. Click OK when done defining material properties.

      Name

      Normal Restitution

      St. dev. / Rel.Min / Rel.MaxDynamic FrictionSt. dev. / Rel.Min / Rel.Max
      Hard0.2 (Normal)0.03 / 0.09 / 0.090.4 (Normal)0.04 / 0.12 / 0.12
      Soft0.1 (Normal)0.03 / 0.09 / 0.090.8 (Normal)0.04 / 0.12 / 0.12
      Water0.0 (None)-0.99 (None)-

      Material property hard
      Define Material Properties: Hard Material

      Material soft
      Define Material Properties: Soft Material

      Material property water
      Define Material Properties: Water

    2.6 Add Material Regions

    1. To add new material regions, select the Material Regions tab (located next to the Visibility Tree) or from the menu Materials > Edit Material Regions Edit Material Region icon. This is where the overlay texture image will aid us.

    2.6.1 Define Water Region

    1. Select Draw New Region.
    2. Select the Water Property and click OK.
    3. We're now in the Draw Polyline mode for defining material regions using the Water material assignment. Roughly trace (left-click) round the river near the bottom of the slope. Alternatively, for exact coordinates, select the Edit Table button in the Draw Polyline pane, and then Import the following Tutorial 04 Water Region.txt file.
    4. When done drawing or importing the coordinates for the material region, right-click and select Done to exit drawing mode.

    Water Region

    2.6.2 Define Soft Region

    1. Select Draw New Region.
    2. Select the Soft material property to use and click OK.
    3. Roughly trace around the flat areas around the river (including the highway). Alternatively, for exact coordinates of the material region, select the Edit Table button in the Draw Polyline pane, and then Import the following Tutorial 04 Soft Region.txt file.
    4. When done drawing or importing the coordinates for the material region, right-click and select Done to exit drawing mode.

    Soft Region

      2.6.3 Reorder Material Regions

      Notice that the soft green region now overlies and hides the blue water region. This means the green region is currently the top material layer and its properties would be used in computations. Material layers can be re-ordered, as follows:

      1. In the Defined Regions list, select Region 1 (the water region). Click the Up arrow up arrow icon to move the water region to the top of the list and also to the top of all material layers.
      2. Bump up water

      3. Click on the Visibility Tree tab in the left pane to get out of the Material Regions mode.

      Material Regions Finished

      2.7 Seeder Properties

      1. Select the Seeders workflow tab.
      2. Select Seeder > Define Seeder Properties Define seeder properties in the menu. This opens up the Seeder Properties dialog.
      3. In the Seeder Properties dialog, under the Rock Shapes tab, select the Pencil Icon located next to shapes to edit the rock shapes to be used for the Seeder Property 1.
      4. In the Rock Shapes dialog, select the Icosphere (32 faces), Dodecahedron and Icosahedron shapes, and click OK to close the dialog.

      2 rock shapes

      1. Switch to the Number of Rocks tab. For Seeder Property 1, change the Number of Rocks to 150. Use default values for all other parameters, including zero initial velocity, so that all rocks will be free falling from the seeder location.

        Seeder Properties #1

      2. Click on the Add add icon button to add a new seeder property.
      3. For this Seeder Property 2, repeat steps 3 and 4 above to define the rock shapes.
      4. Switch to the Number of Rocks tab and change the Number of Rocks to 50.
      5. Click OK to save the seeder properties and to exit the dialog.

        seeder property 2

      2.8 Add Seeders

      A line seeder and an area seeder are added to this tutorial model.

      2.8.1 Line Seeder

      1. Turn on the visibility of the topographic lines by pressing the eye icon eye icon in the Visibility Tree next to the topographic lines entity.
      2. Select Seeder > Add Line Seeder add line seeder
      3. The Add Line Seeder dialog opens. Make sure Seeder Property 1 with 150 rocks is selected for Property.
      4. Select Height Above Surface for the Elevation (Z Value) dropdown and enter 1 m.

      5. Add Line Seeder

      6. Select Add Points on Viewport. In the viewport showing the model top view, trace (left-click) along the 2100 m topographic line as shown below.
      7. When done drawing, right-click and select Done.
      8. Click OK to save and exit the Add Line Seeder dialog.

      An alternative to drawing the line seeder is to use the exact coordinates as adopted in this tutorial. Import a polyline by selecting Geometry > Draw Polyline, click the Edit Table button, Import the following Tutorial 04 Line Seeder.txt file, right-click and select Done, click on the polyline entity in the Visibility Tree, navigate to Seeder > Add Line Seeder from Polyline, and finally click OK.

      Seeder1

      2.8.2 Area Seeder

      1. Select Edit > Selection Mode > Faces Selection Faces selection
      2. Select Edit > Selection Region Mode > Lasso Region lasso select. Steps 1 and 2 are used to allow the selection of slope faces using lasso selection.
      3. In the viewport showing the model top view, left-click and drag your mouse over the area of interest near the Northeast corner. The lasso selection should appear in orange for the slope faces that are selected.
        lasso
        Lasso selection for area seeder
      4. Select Seeder > Add Area Seeder from Selection Add area seeder
      5. Similar to what was done for the line seeder, select the Height Above Surface from the Elevation (Z Value) dropdown and enter 1 m.
      6. Select Seeder Property 2 from the Property dropdown menu.
      7. Select OK.

      3.0 Compute

      1. When ready to compute, select Analysis > Compute compute

      4.0 Results

      1. Click on the Results workflow tab and observe the path results.

      With the aid of the texture overlay, we can easily see that the rocks from the area seeder on the right would stop after hitting the river, but a small portion of the rocks from the line seeder on the left would hit the highway.

      Results

      Rocscience logo, click here to return to the homepage Portal Account Portal Account Log In Log Out Home Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" Previous Next PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's X page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Click here to visit Rocscience's Reddit page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSlope3 RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge RocTunnel RocSlope2 Commercial License Education License Trial License Shop safe & secure Money-back guarantee