Rocscience International Conference 2023 | April 24-26, 2023 Learn More about RIC2023
 

Search Results

3 - Grouping

1.0 Introduction

This tutorial is a simple introductory tutorial that helps you become familiar with the Grouping feature of EX3.

Topics Covered in this Tutorial:

  • Segmenter tool
  • Grouping
  • Isosurfaces
  • Stress Ribbons

Finished Product:

The finished product of this tutorial can be found in the Tutorial_03_-_Grouping.examine3 data file. All tutorial files installed with EX3 can be accessed by selecting File > Recent Folders > Tutorials Folder from the EX3 main menu.

2.0 Model Setup

When you open EX3 a new project file will automatically be created.

2.1 Project Settings

Begin the tutorial by opening the Project Settings. To do so:

  1. Select Analysis > Project Settings (CTRL + J) from the menu or click on the Project Settings Project Settings icon in the toolbar.
  2. Select the Units tab and ensure the units are set to Metric, stress as MPa.
    Project Settings - Units
    Project Settings - Units
  3. Select the Stages tab and set the number of stages to 5.
    Project Settings - Stages
    Project Settings - Stages

  4. Name the stages as follows:
  5. #

    Name

    1

    Initial Geometry

    2

    Excavating Group 1

    3

    Excavating Group 2

    4

    Excavating Group 3

    5

    Excavating Group 4

  6. Click OK to close the dialog.

2.2 Material Properties

  1. Select Materials > Define Materials in the menu or click on the Define Materials Define materials icon in the toolbar.
  2. Material properties dialog
    Material properties dialog
  3. By default, the first material is listed as Host Rock. Click on the Add Add button button to add two more materials.
  4. Enter the following properties:
  5. Material

    Poisson's Ratio

    Young's Modulus (MPa)

    Host Rock

    0.3

    2000

    Ore

    0.3

    500

  6. Click OK to close the dialog.

3.0 Geometry

Geometry

3.1 Create Boxes

  1. Select Geometry > 3D Primitive Geometry > Box from the menu or click on the Add 3D Primitives 3D Primitives icon in the tool bar.
  2. Enter the following properties for the First Ore section:
    • Defined by = 2 Corners
    • Role = Excavation
    • First Corner:
      • X = 0
      • Y = 0
      • Z = 0
    • Second Corner:
      • X = 10
      • Y = 70
      • Z = 20
    Create Box
    Create Box - First Ore Section
  3. Click OK.
  4. Repeat Step 1 to create a second box.
  5. Enter the following properties for the Second Ore section:
  • Defined by = 2 Corners
  • Role = Excavation
  • First Corner:
    • X = 0
    • Y = 0
    • Z = -20
  • Second Corner:
    • X = 10
    • Y = 70
    • Z = -40
Create box dialog
Create box - Second Ore Section

Your model should now look like this:

2 boxes
Model: 2 Ore Sections

3.2 Material Assignment

We will now assign the material to each box. This can be done in more than one way.

Option 1: Properties Control

  1. Use your mouse to select the box you wish to assign a material to. You can either select the Entity using the Visibility Tree or you can click directly on the section of the model.
  2. Visibility Tree
    Visibility Tree

    Notice the Properties pane in the bottom left of the screen. Here you can see the current properties of the selected entity.

    Properties Pane
    Properties Pane
  3. Change the Applied Property to Ore.
  4. Repeat this for both boxes.

Option 2: Materials Menu

You can quickly apply a property to an entity using the Assign Material dialog.

  1. Select Material > Assign Materials in the menu. The dialog will appear.
  2. Assign Properties
    Assign Properties
  3. Select Ore as the material.
  4. Click on the entity you wish to apply that material to (either by selecting it in the Visibility Tree or by clicking directing on the model).
  5. Click Apply.
  6. Repeat this step for both boxes then close the dialog.
Material Assignment Figure
Model: Material Assignment

3.3 Dividing Boxes Into 7 Pieces – Segmenter Tool

We will now divide the two ore sections in 7 pieces using the Segmenter Tool.

  1. Begin by selecting one of the boxes.
  2. Select Geometry > 3D Boolean > Segmenter in the menu or click on the Segmenter Segmenter button icon in the tool bar.
  3. Segmenter dialog
    Segmenter
  4. Change the Path to Y Axis.
  5. Set the Number of Segments to 7.
  6. Click Segment.
  7. Repeat the above steps for the second box.

Your model should now look like this:

Segmented box figure
Model: Segmented boxes

3.4 Group Assignment

We will now assign the segmented boxes into 4 groups.

  1. Hold the CTRL key on your keyboard and use your mouse to select the entities you wish to group, either by clicking on the model or selecting them in the Visibility Tree.
  2. Go to the Properties Pane in bottom left of the screen. The number of Entities selected is displayed at the bottom of the controls.
    Propertie pane
    Properties Pane
  3. Select the Group you wish to assign the entities to in the Grouping drop down menu.
  4. Repeat the above steps for all 4 groups.
  5. Assign the 4 groups as follows:

GROUP 1

Group 1

GROUP 2

Group 2

GROUP 3

Group 3

GROUP 4

Group 4

4.0 Loads

Loads

The Loading menu allow you to define all of the various types of loads which can be applied to an EX3 model. For this model, we will be defining Field Stress.

4.1 Adding Stress Loading

  1. Select Loading > Field Stress from the menu or click on the Field Stress Field Stress icon in the tool bar.
  2. Enter the following properties:
    • Field Stress Type = Constant
      • Sigma 1 (MPa) = 10
      • Sigma 2 (MPa) = 10
      • Sigma 3 (MPa) = 10
    • Orientation
      • Defined by = Trend/Plunge
        • Sigma 1: Trend =0, Plunge = -90
        • Sigma 3: Trend = 90, Plunge = 0
    Field stress dialog
    Field Stress
  3. Click OK.

4.2 Divide All Geometry

  1. Select Geometry > Divide All Geometry from the menu or click on the Divide All Divide All icon icon in the tool bar.
  2. Divide All
    Divide All Parameters
  3. Leave the Quality as Default.
  4. Click OK.
EX3 creates the mesh in the background.

5.0 Mesh

Mesh

5.1 Modifying the Mesh

In EX3, you can easily change the density of mesh. To do so:

  1. Select Mesh > Mesh Settings in the menu or click on the Mesh Settings Mesh Settings icon in the tool bar.
  2. Change the Mesh Density to High.
    Mesh Settings
    Mesh Settings
  3. Click OK.

You should now see the following:

Mesh figure
Model with Mesh

6.0 Stage Modification

In each stage, the associated group will be excavated. To model the excavation:

  1. Select Stage 2: Excavating Group 1 in the stages tabs at the bottom of the screen.
  2. Go to the Visibility Control on the left and select the Groups tab.
  3. Select Group 1.
  4. Go the Properties Controls and change the Applied Property of the selected zone to No Material.
  5. Stages figure
    Stages Modification
  6. Repeat this process for each stages as follows:
  • Stage 2 (Excavating Group 1) = Group 1 Excavated
  • Stage 3 (Excavating Group 2) = Group 2 Excavated
  • Stage 4 (Excavating Group 3) = Group 3 Excavated
  • Stage 5 (Excavating Group 4) = Group 4 Excavated

7.0 Field Points

Field Points

To see the results around the excavation, field points should be defined. Users can define as many field points as they need.

As you move through each stage, the results will update.

7.1 Add Field Points Box

To add a Field Points Box:

  1. Select Field Points > Add Field Point Box from the menu or click on the Field Point Box Field Point Plane icon icon in the toolbar.
  2. Create Field Points Box
    Create Field Points Box
  3. Enter the following details:
  4. X

    Y

    Z

    First Corner

    -40

    -20

    -60

    Second Corner

    50

    90

    40

    Grid Spacing

    • Number of points in X = 37
    • Number of points in Y = 37
    • Number of points in Z = 37
  5. Click OK.
Field Point plane
Field Points Box

8.0 Compute

Compute

It is now time to compute your results.

Select Compute > Compute from the menu or go to the Compute workflow tab and then click on the Compute Compute icon in the tool bar.

If you have not saved your project, you will be prompted to now.

Compute Dialog
EX3 Compute

9.0 Results

Results

9.1 Results Visualization

After computing, you have several options for viewing your results. You can view Displacement (X, Y, Z, Total Displacement) and Stress (Sigma1, Sigma 2, Sigma 3, mean stress, Sx, Sy, Sz, Sxy, Syz, Sxz). Use the drop down in the contour legend (on the right side of the screen) to make your selection.

To see the results on the Field Points Box, you can use the Visibility controls (on the left of the screen) to hide the ore zones. Toggle the eye icons next to an excavation on and off.

Total Displacement - Group 1
Total Displacement - Group 1
Total displacement - Group 2
Total displacement - Group 2
Total displacement - group 3
Total displacement - group 3
Total displacement - Group 4
Total displacement - Group 4

9.2 Isosurfaces

To define the Isosurfaces:

  1. Select Interpret > Isosurfaces in the menu or click on the Isosurfaces Isosurfaces icon in the tool bar. A dialog will appear.
  2. Define Isosurface
    Define Isosurfaces
  3. In the Define Isosurface dialog, users are able to update the Data Type and Value. For this tutorial, enter the following values:
    • Date type = Total Displacement
    • Value = 0.02687
  4. Click OK. As you click through the different stages, the results will update.
Isosurfaces - Stage 5 - Excavating Group 4
EX3 - Isosurfaces - Stage 5 - Excavating Group 4
You can use the Visibility Controls on the left to hide the Field Points Box.

9.3 Stress Ribbon Query

  1. Select Interpret > Add Stress Ribbon Query in the menu or click on the Add Stress Ribbon Query Add Stress Ribbon Queird icon in the tool bar. The Draw Polyline controls will appear.
  2. Draw polyline

  3. Click on Edit Table. A new dialog will appear.
  4. Edit Poly Line

  5. Click on the Insert Row Insert Row button twice to add 2 rows.
  6. Enter the follow coordinates for the polyline:
  7. Row #

    X

    Y

    Z

    1

    10

    0

    35

    2

    10

    70

    35

  8. Click OK to close the dialog.
  9. Then click on the green check mark green checkmark icon in the Draw Polyline dialog.
  10. Stress Ribbon Query Options

  11. The Stress Ribbon Query Options will appear.
  12. The Stress Ribbon Query Options allow you to pick the number of locations on the polyline (defined in the previous step), to calculate the stress ribbons. In this case we will leave the default settings.

  13. Click OK. Stress Ribbons will be calculated at each stage.
Stress Ribbon
Stress Ribbon

This concludes the Grouping tutorial; you may now exit the EX3 program.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee