RocFall Maintenance+ Update History

Tips
Don't know which link corresponds to your Maintenance+ license? Click here to find out.

Version 8.016 - August 13 2021 [Download]

  1. CHANGED Updated Maccaferri barriers.

Version 8.015 - May 12 2021 [Download]

  1. FIXED Fixed Lumped Mass rolling/sliding rocks not detected by Collector snapped on slope.
  2. FIXED Account for affects of Filters for Display Hits option on Collectors and Barriers.
  3. FIXED Added validation check with importing barrier coordinates to ensure one end of barrier is on the slope.
  4. FIXED Fixed bug when extend last segment is selected when there are less than two vertices with custom berm builder.
  5. FIXED Fix to truncated normal distribution in case of very large relative min or max for a probabilistic analysis.

Version 8.014 - March 1 2021 [Download]

  1. FIXED missing .csv files issue with common types material libraries.

Version 8.013 - February 3 2021 [Download]

  1. CHANGED Updated barrier manufacturer data. Added RISP barriers.
  2. CHANGED Updated icons and UI to the latest. Updated splash screen.
  3. FIXED bug of legend incorrectly displayed when plotting multi-values
  4. FIXED bug of unable to open .fal (v4) file
  5. FIXED broken online help links
  6. FIXED rocks missing possible intersection with barrier/berm during the post impact process
  7. FIXED crashing bug with random number generation
  8. CHANGED Updated Technical Support dialog to replace email link with link to support form. Added System Information for Display resolution and scaling.
  9. FIXED bug of End Reason Table edit tools dialog incorrectly initialized
  10. FIXED crashing bug when trying to close manage report views dialog when no view exists (after deleting all views in dialog)
  11. FIXED added Tutorial 3 initial to the install

Version 8.012 - October 15 2020 [Download]

  1. Added separate controls to toggle seeder location in charts independent from show graph markers
  2. Added more descriptive warning messages in the stats helper dialog
  3. A warning message shows up when no layer is selected in the import dxf dialog
  4. fixed bug with unable to import csv files when opened in Excel
  5. fixed bug with collector collision incorrectly reported with long sliding in LM mode
  6. fixed bug with odd behavior when berms overlap/intersect with crest loss
  7. fixed bug with total energy is output instead of translational energy in output path details
  8. fixed bug with incorrect data range checking when applying forest drag in imperial units
  9. fixed bug with errors when importing dxf as polyline

Version 8.011 - September 28 2020 [Download]

  1. Added Seeder Properties dialog under Seeder menu. Users can now update seeder properties without right clicking on each seeder in the view
  2. Added plotting multi values in the envelope graph view. The user can now choose to plot multiple values (max, mean, and 3 different fractiles of choice). When multiple values are selected, the user cannot toggle between different seeder types, rock types, end reasons to avoid crowding the plot.
  3. Previously opened views (view states) are saved if rock paths are saved (set in Project Settings). The views will be opened next time the file is loaded.
  4. Added Report Generator, replacing info viewer. Results are included in the report if in result mode. Views can be added to the end of the report. User can select to rotate the image for better size if desired. Views can be managed by the Manage views dialog. Existing barrier design reports are changed to be initially displayed in the "infoviewer" frame, where the user can choose to export to html or to include in the report generator.

Version 8.010 - June 24 2020 [Download]

  1. Added Show Seeder option to toolbar to plot seeder start location(s) on Endpoints graph and Envelope graph.
  2. Improved Graph Endpoints option with new Graph Endpoints dialog.
    1. Added option to plot Number of Rocks or Percent of Rocks on primary y-axis.
    2. Added option to plot Rock Endpoint Location, Rock Endpoint Distance From, or Runout Distance on x-axis.
    3. Added option to plot All Rock Paths, Currently Filtered Paths, or Paths with Selected Rocks.
  3. Added Display Hits option to right-click menu to display information about Number of Rocks Hit and % Retained and Passing for Barriers and Collectors in Results view.
  4. Added X Translational Velocity and Y Translational Velocity to Graph Barriers and Collectors dialog. Note: Raw data for each rock path can be viewed by selecting Plot in Excel option from the right-click menu in chart view.
  5. Added predefined Materials Library Common Types with common slope materials and material coefficients. Automatically populate material coefficients in Slope Material Library dialog with selected type.
  6. Added predefined Rock Library Density Common Types with common rock types and rock densities. Automatically populate density in Rock Type Library dialog with selected type.
  7. Added Output Path option to right-click menu in Results view. Export event details for selected path to HTML.

Version 8.009 - June 9 2020 [Download]

  1. Added detection of rocks penetrating slope for Rigid Body trajectory cases without Forest Damping. This occurs if an earlier intersection between the rock and the slope was not detected (i.e., missed intersection). The path will be removed from Results.
  2. Increased upper limit of allowable Maximum Time Per Rock to 300 s from Engine Conditions in Project Settings dialog.
  3. Fixed z-order formatting issue with checkbox control in Rigid Body Slope Material Library.

Version 8.008 - May 7 2020 [Download]

  1. Bugfix for drawing Slope polygons.
  2. Bugfix for Import DXF to Slope. Polyline vertex order matters when processing Slope polygons. Polyline points from .DXF file are automatically reordered to ensure a counter-clockwise slope polyline.

Version 8.007 - May 5 2020 [Download]

  1. Bugfix for wrong projectile rock path after hitting a Barrier when using Lumped Mass method.
  2. Bugfix for event type defaulting to Air after hitting a Barrier when using Lumped Mass method. Prior Sliding event type is preserved after hitting Barrier (with the exception where Barrier is placed on a slope vertex and the rock is Sliding off the vertex into Air event). Prior Air event type is preserved after hitting Barrier.
  3. Bugfix for rotational position being reset to 0 after hitting a Barrier. Note: Rotational position and velocity are not affected by Barriers.

Version 8.006 - April 2 2020 [Download]

  1. Bugfix for barrier Elongation not updating when changing Predefined Barrier types
  2. Bugfix for Custom Barrier Capacity not getting saved after closing and opening the Barrier Properties dialog.
  3. Added automatic unit conversions for Predefined Barrier specifications when changing Units in Project Settings.
  4. Reset to default for Custom Barrier Capacity and Elongation when changing Units in Project Settings.
  5. Bugfix for crash when opening files saved with no slope.
  6. Bugfix for detecting intersection with Collector when sliding path segment is very short and acceleration is very high.
  7. Bugfix for incorrectly drawn rock path(s) in Results view. Note that only the rendering of the rock path is affected; the computed rock path is not affected.
  8. Added a warning message when opening a file version newer than the program version. The user has the option to proceed or abort loading the file. No results from newer file versions are read.

Version 8.005 - January 11 2020 [Download]

  1. Added Event option to Filter Results dialog. This allows the user to filter paths results by an event type and location.
  2. Fixed bug with Forest/Vegetation Damping where the Drag Coefficient was being assigned to the wrong extents of the slope.
  3. Fixed bug with closing Browse for Folder dialog from Export Path Details.
  4. Fixed bug with broken radio controls in Graph Data on Slope dialog.
  5. Corrected minor typo in Project Settings dialog.
  6. Updated splash screen.

Version 8.004 - November 22 2019 [Download]

  1. Added Export All Path Details option to Export Path Details dialog. This allows users to export positions, velocities, accelerations, and energies of each rock, at each time-increment, to a comma-delimited .txt file.

Version 8.003 - November 14 2019 [Download]

  1. Fixed bug with Run Geometry Cleanup after import during Import DXF. When this option is checked, imported boundary segments shorter than 0.01 length units will be removed.
  2. Fixed bug with opening files with bad slope geometry. It now allows the model to load with error message.

Version 8.002 - November 1 2019 [Download]

  1. Maintenance+ version released.

Version 2019 7.009 - April 2 2020 [Download]

  1. Bugfix for barrier specifications (i.e., Capacity, Elongation) not updating when changing Predefined Barrier types
  2. Bugfix for Custom Barrier Capacity not getting saved after closing and opening the Barrier Properties dialog.
  3. Added automatic unit conversions for Predefined Barrier specifications when changing Units in Project Settings.
  4. Reset to default for Custom Barrier Capacity and Elongation when changing Units in Project Settings.

Version 2019 7.008 - October 29 2019

  1. Fixed an error when no shapes are selected in a used rock type.
  2. Updated licensing.

Version 2019 7.007 - May 3 2019

  1. Fixed DXF import bug.
  2. Fixed a crashing error when trying to read in results from paths with a bad start marker.

Version 2019 7.006 - April 12 2019

  1. Bug fixes with barrier reports. Corrected mass and density are used for ONR and non-factored methods.
  2. Disabled barrier reports for custom barriers.

Version 2019 7.005 - February 5 2019

  1. Fixed a possible crashing bug when changing geometry with berm(s) on the slope.

Version 2019 7.004 - January 11 2019

  1. Number of steps in the Sensitivity analysis dialog are displayed as integers
  2. Changing sensitivity analysis data automatically removes the results.
  3. Forest hatches don't show over berms
  4. Forest hatches are removed when switching from Rigid Body to Lumped Mass
  5. Program no longer crashes when there is no rock types assigned to the seeder(s). A warning dialog pops up to notify the user.
  6. Dialog doesn't crash when changing berm closing options without any vertices defined.
  7. Slope roughness field is disabled in Lumped Mass to avoid confusion.
  8. Removed slope roughness from Berm Material Properties dialog in Lumped Mass.
  9. Fixed a bug with vertical impact height on collectors. It is now calculated from the lower collector vertex instead of the first vertex.
  10. Fixed a bug with collector intersections. Intersections were falsely detected and recorded when the event steps are very very small.
  11. A vertical cliff at the end of the slope is now allowed instead of BAD SLOPE errors.
  12. Filter works correctly now with custom polygons.
  13. Fixed grid expand issue in custom polygon dialog. Fixed add/edit buttons issue when custom shape is highlighted.
  14. Fixed a bug where concave polygon is reported when not.
  15. Improved select polygon dialog.
  16. Updated custom polygon creation dialog and internal shape validity checks.

Version 2019 7.003 - September 27 2018

  1. Added more user controls to Export Path Details.
  2. Extended Tech Support Dialog to fit Win7 Service Pack info.
  3. Improved infinite berm impacts.
  4. Changing berm assignments will reset results correctly.
  5. Changing barrier properties through Edit Barrier dialog will reset results correctly.
  6. If no results are read due to version inconsistency, will go into Design mode correctly.

Version 2019 7.002 - September 18 2018

  1. Commercial release.

Version 2019 7.001 - August 29 2018

  1. Beta release.

Version 6.011 - January 24 2018 [Download]

  1. Minor UI bug fixes: typo, rock properties table, degree symbol in infoviewer.
  2. Fixed line seeder file read error.
  3. Fixed Tools->Polyline add coordinates in a table feature.
  4. Fixed rock generation per seeder length crashing bug.
  5. Added color hatch pattern for slope materials in Infoviewer.

Version 6.010 - November 24 2017

  1. A fix to the RocFall barrier dialog. It now loads correctly.

Version 6.009 - October 10 2017

  1. Fixed a crashing bug when rock starting point coincided with a slope vertex for polygons.

Version 6.008 - August 24 2017

  1. Can now turn off high dpi setting in the technical support dialog accessed through the Help menu.
  2. Fixed a minor graphical display bug invovled with custom barrier new id.
  3. Corrected min/max length terms to min/max heights in barrier library dialog.
  4. Updated contact address and removed fax number from about dialog.

Version 6.007 - July 11 2017

  1. Now supports high dpi graphics cards.
  2. Fix crash when mouse is over Recent File menu item and recent documents history is disabled with group policy.
  3. Added Windows 10 detection to tech support dialog.
  4. Fixed line seeder unable to insert/delete rows bug.
  5. Crashing bug fixed when running models with forests.
  6. Removed multiple types of tool entities which were causing problems with saving legend tools.
  7. Fix for infinite error message popup when balloon type popups are disabled system-wide.
  8. Fixed material type legend bug with lumped mass friction angle.

Version 6.006 - June 22 2017

  1. Fixed lumped mass run generation bug when specified in Project Settings.

Version 6.005 - May 16 2017

  1. Fixed the energy gain bug in rigid body rock shapes.
  2. Added a check for energy gain in rigid body rock shapes. If gain > 50%, throw out the result.
  3. Clear results when custom shapes are saved or boundary is simplified.

Version 6.004 - April 6 2017

  1. Extents bug fix.
  2. Relative rock/slope size crash bug fix.
  3. V4 files read in crash bug when no seeder was defined in v4.

Version 6.003 - January 19 2017

  1. UI Improvement. Added divider lines between different barrier manufacturers in the Barrier Design Dialog dropdown.
  2. Fix UI bug with the apply CRSP tangential damping option.
  3. More updated Maccaferri barrier data.
  4. Refined contact detection for Fourier descriptors.
  5. Allows concavity for custom polygonal shapes.
  6. Improved contact detection for polygons by moving model to (0,0) internally.
  7. Updated some terminology with barrier report.

Version 6.002 - November 1 2016

  1. Commercial Release.

Version 6.001 - September 26 2016

  1. Beta release

Version 5.017 - February 15 2017 [Download]

  1. Minor impact mechanism bug fix.

Version 5.016 - June 1 2016

  1. Fixed Mirror Slope.
  2. New default material colors for better visibility.
  3. Changed the name of Slope Fill Intensity to Slope Fill Transparency in Display Options.
  4. Changed the default transparency to 50%.
  5. Added "Toggle End Reasons" to the right-click menu on the End Point graphs.

Version 5.015 - May 2 2016

  1. AWhen filtering by seeders, one couldn't select past 5th or 6th seeder as the popup would close. Fixed.

Version 5.014 - July 31 2015

  1. Added CRSP file import.
  2. Hitting Ctrl+P while in print preview could cause loss of menu and toolbars afterwards. Fixed.
  3. Changing settings in Chart Properties no longer fully rebuilds graphs.
  4. Improved handling of seeders placed on slope line - rocks are properly pushed out in normal to slope direction.
  5. Updated critical functions with better epsilon handling.
  6. Added "Show vertices in results".
  7. Added Clear Results to toolbar and moved it to Results menu. Added pop-up asking users about clearing results if results took too long to compute.
  8. Fixed link to update info.
  9. Improved error messages after simulation.
  10. Fixed Zoom All in results mode.
  11. Fixed PNG export for charts.
  12. Added saving of user title as default for endpoints graph (user request).

Version 5.013 - April 13 2015

  1. Bug was introduced in the previous update for barriers. Any vertical or near-vertical barrier or collector with a negative X-coordinate would not register hits on it. Fixed.

Version 5.012 - February 11 2015

  1. Adjusting barrier angle or height in properties window when adding it had no effect until second time window is opened. Fixed.
  2. After adding vertical barrier through command prompt (height, angle), such barrier might not be considered in the analysis until the file is saved and re-opened.
  3. Graphing end-points could crash if slope vertices have standard deviation set and rock paths extend past slope end. Fixed.

Version 5.011 - October 3 2014

  1. Scale image now works properly.
  2. Problem with saving/reading default settings is fixed.

Version 5.010 - May 29 2014

  1. Lumped mass rocks would lose energy when sliding over a vertex. Fixed.

Version 5.009 - February 5 2014

  1. Updated help to include all dialogs.
  2. Updated barrier design and modelling tools to be easier to use.
  3. Added custom barrier type to simplify modelling when full barrier report is not desired.
  4. Updated barrier report output to be easier to use.
  5. Saved barrier report input so report can be generated again easily.
  6. Fixed end point graph scale bug.
  7. Fixed barrier and collector graph bug where no options were available.
  8. Fixed collector vertical height bug in graph output.
  9. Fixed barrier definitions to include tested value units and convert to file unit system.
  10. Added ability to change graph data on current graph.
  11. Added parameter range checking to all engine conditions, slope materials and rock types to ensure valid simulation input.
  12. Updated Info Viewer with additional information.
  13. Added seeder filter type.
  14. Fixed animation scroll bar bug where it wouldn’t advance properly.
  15. Changed rigid body impact algorithm to not apply damping when rolling over vertices.
  16. Added default units for new file preference.
  17. Miscellaneous user interface updates.

Version 5.008 - January 14 2014

  1. Fixed energy unit scaling bug.

Version 5.007 - January 13 2014

  1. Interface and editing improvements.
  2. Added set defaults for new files, import and export for material properties and rock types.
  3. Added warning when importing RocFall 4 files that use a random seed instead of pseudorandom.
  4. Added ability to use filters when graphing data to graph subsets of data.
  5. Added raw output for Export to Excel when in distribution graph.
  6. Fixed path drawing bugs where near vertical paths were not being drawn in some cases.
  7. Fixed bug where scale by velocity and scale by mass labels were reversed.
  8. Fixed energy output values to work with foot pounds.
  9. Fixed bugs in Rigid Body mode to more accurately find block and slope intersection points.

Version 5.006 - December 4 2013

  1. Customer Release.

Version 5.000 - September 9 2013

  1. Beta release.

Version 4.058 - September 2013

  1. Updated Help system to support Google Chrome and IE10.
  2. Updated RN/RT table to include more typical values.

Version 4.057 - May 14 2012

  1. Fixed a bug introduced in version 4.056 for slopes with large coordinates.

Version 4.056 - May 13 2012

  1. Improved the ability of the program to filter out collinear line segments. Many vertices lying on the same line segment are now properly filtered out. If the vertices were ever so slightly off the line segment, a rock sliding down the line segment would experience tiny hops as it passed over the vertex and lose energy as a result.

Version 4.055 - April 20 2012

  1. Online Help would now launch in Internet Explorer if Google Chrome is the default browser. The online help does not properly work in Google Chrome.

Version 4.054 - September 12 2010

  1. Infoviewer would not display over 100 slope segments. Fixed.
  2. Capturing to an image file would sometimes include the background window. Fixed.

Version 4.053 - March 29 2010

  1. Small sliding bug fix when rock slides on the first segment of the rock slope.

Version 4.052 - November 30 2009

  1. Improved CRSP import.
  2. Added documentation for how to duplicate CRSP results.
  3. Can now choose to display Imperial US energy units in ft-lbs.
  4. If three vertices were collinear, and a barrier was on the second vertex, the rock paths were incorrectly calculated.
  5. When Slope roughness was used, the modified slope angle was not being used for the calculation of exit velocities in the x and y direction. The actual slope angle was being used. The modified slope angle is now used for both entrance and exit velocity calculations.
  6. Can now plot height above slope when plotting bounce height through collectors and barriers. Use the right-click option to subtract slope height from Y elevation.
  7. New Help System.

Version 4.051 - July 7 2009

  1. Under rare circumstances the clipboard would be corrupted. Fixed.
  2. Excel charting of multiple datasets would sometimes not work with Excel 2007.
  3. Security system update to allow for educational updates and improve commercial network version.

Version 4.050 - May 4 2009

  1. Rocks sliding along horizontal slope segments could pass under a barrier. Fixed.

Version 4.049

  1. Fixed datatips not showing on Windows XP system. Bug was introduced in version 4.046.
  2. Added "DATATIPS ON", "DATATIPS OFF" indicator to status bar. Clicking on it toggles datatips state.
  3. Reading in files from DXF with a large number of vertices would give different results then when the file was entered manually. This due to near colinear points not being treated properly when reading the DXF file.

Version 4.048

  1. Fixed a bug which altered the energy of a rock incorrectly after it slid into a barrier and exceeded the barrier’s capacity.
  2. Changed the drawing code so that rock paths aren’t updated every time a rock is thrown, only after ALL rocks are thrown, greatly increasing computation time.

Version 4.047

  1. Fixed a bug which caused the program to crash if the user hit File...Close after reading in a file.
  2. Fixed a bug which caused barriers and data collectors to move incorrectly when std. deviation was applied to the slope.

Version 4.046

  1. Converted help system from winhelp to webhelp to be compatible with Windows Vista.
  2. Re-organized start menu folders and links.
  3. If a linear portion of a slope was divided into smaller segments by adding extra vertices, rocks which were in sliding mode would slow down at each vertex, even if the line segments had the same material properties. This has been fixed so that rocks in sliding mode do not lose velocity when crossing a vertex of co-linear line segments with the same properties.
  4. Adding barriers or data collectors no longer affects the pseudo-random results.
  5. Updated technical support dialog.
  6. Improved User Interface look under Windows XP and Vista.
  7. Toolbars no longer split into two rows.

Version 4.045

  1. Fixed a bug which caused rocks to register multiple hits on barriers instead of sliding down them. This caused errors in the data charts.

Version 4.044

  1. Barriers did not use the capacity with sliding rocks (they had infinite capacity). This bug was introduced in version 4.043. Fixed.

Version 4.043

  1. Fixed a bug which caused the program to time-out when a sliding rock with downslope velocity intercepted but did not break a barrier.
  2. Improved printing code. On certain printers (or with certain outdated printer drivers), the program would crash when trying to print.

Version 4.042

  1. Now supports multiple HASPHL locks on the same USB hub.

Version 4.041

  1. Fixed a bug where a slow moving rock could pass under a barrier and be recorded improperly on a data collector.
  2. Menu checkmarks would sometimes not be rendered correctly.

Version 4.040

  1. New Hasp-HL hardlock support. Removed support for old beige hardlocks.

Version 4.039

  1. Support for new Educational system. Also update dll's to latest microsoft versions.

Version 4.038

  1. Additional Documentation "Determining Input Parameters for a RocFall Analysis" tutorial is now installed with RocFall. It is available in the program (RocFall->Slope->Material Editor->Tutorial) or (RocFall->Help->Manuals->Determining Input Parameters), and from the Windows Start menu.

Version 4.037

  1. In certain cases, rocks that were sliding uphill AND off the end of a segment, would cause problems. (e.g. if a rock bounced off a barrier, and traveled up slope). This is fixed. (rocks sliding downhill were not effected).

Version 4.036

  1. Improved import of CRSP files that have many adjacent cells with the same properties.
  2. Improved printing
  3. Hardlock and Nodelock software upgrade.
  4. Exit velocity of the rock was not calculated correctly when rocks broke through barriers. The error only effects rocks after they have broken through barriers.

Version 4.034

  1. Improved performance for beige hardlocks.
  2. Update to auto-update code and nodelock code.
  3. Bug fix for network version and path path dialog.

Version 4.033

  1. EMF/WMF image files now export correctly.
  2. Improved license management for network versions.
  3. Improved look under WinXP.
  4. Bounce Height Envelope did not always load correctly, after a file was saved, and re-loaded. This is fixed.

Version 4.032

  1. Data Tips were inadvertently turned off with no way of turning them on. This has been fixed.

Version 4.031

  1. Printer logic has been changed. Printers are now set up just before printing. This isolates a problem with printing to some HP printers due to a HP driver bug.

Version 4.03

  1. Automatic update technology added. Customers with a web connection will automatically be notified and allowed to update when a new minor version is released.
  2. A new splash screen.
  3. Nodelocking now possible.

Version 4.02

  1. Printing without print-preview could cause the slope to be offset to the side of the page.
  2. Large standard deviations could cause negative values for the mass of the rock. There is now a check to prevent this from happening.
  3. Double-click on seeders and barriers to edit their properties.
  4. Barrier Editor dialog now has cancel.

Version 4.01

  1. Some version 3 files would not open if they contained rock paths.
  2. Added an Invert Filter option to the Rocks menu. The option sets unfiltered paths to be filtered and filtered paths to be unfiltered. This is useful for locating paths that did NOT impact a barrier.
Have a technical support question?
Use our Technical Support Form to ask about installation, licensing, program functionality and more.
Get Support