The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Report Generator

1.0 Introduction

This tutorial is a simple introductory to help you become familiar with the features of the Report Generator (formerly the Info Viewer). The Reporter Generator is a dynamic tool to help organize and present the results of your analysis in a sleek and customized report.

Topics Covered in this Tutorial:

  • Navigating your Report
  • Adding Views to your Report
  • Adding Images and Comments
  • Cover Page Options
  • Editing Headers and Footers
  • Export Options

Tutorial Files:

All tutorial files installed with Slide2 can be accessed by selecting File > Recent Folders > Tutorials Folder from the Slide2 main menu.

2.0 Model

The Report Generator can be used with any completed model. For this tutorial we will use the Tutorial 24 Multi Scenario Modeling finished model.

  1. From the Slide2 main menu, select File > Recent Folders > Tutorials
  2. Open Tutorial_24_Multi_Scenario_Modeling.slmd.

3.0 Adding Views to your Report

With the Add Views feature, you can add specific views of your computed model to your report.

3.1 ADD VIEW TO REPORT

Begin by opening the Interpret view:

  1. Computer your model by clicking on the Compute icon in the tool bar.
  2. Select Analysis > Interpret from the menu to open the Interpret view.
  3. Select View > Add View to Report from the menu. The current view of the model will be added to your report and can be seen when we later open the Report Generator.
  4. Set View Name dialog

  5. Enter a name for your view.
  6. Click OK.

Repeat these steps to add as many views as you need to your report. They will be added to the end of the report.

3.2 MANAGE REPORT VIEWS

The Manage Report Views dialog allows you to review the views you have added to your report, add further details, and arrange the order of the views. To open the dialog:

  1. Select View > Manage Report Views from the menu. A new dialog will appear.
  2. Report Views dialog

  3. Use the check boxes to select what views to add to your report.
  4. Use the Up and Down arrows to change the order of the views.
  5. To add a description to your view, select the view in the list of views and enter the description in the Description box.
  6. Click OK to close the dialog.

4.0 Launching the Report Generator

Once you have added your views, it is now time to open the Report Generator. To launch the Report Generator:

  1. Select Analysis > Report Generator from the menu or click on the Report Generator icon Report Generator icon in the tool bar.

A new window will open. Here is where you will see all the various options for customizing your report.

report generator dialog

Note: When using the Multi-Scenario modelling feature, the report will generate information for all OPEN scenarios only. Any scenarios that are currently ‘closed’ will not be included in the report.

5.0 Navigating the Report

When you launch the Report Generator, the details of your project are automatically populated into the report. A table of contents and cover page are automatically created as well.

5.1 NAVIGATION BAR

Use the Navigation Bar on the left of the screen to quickly navigate to the different sections of the report. You will note that the added Views have been added to the end of your report.

Navigation Bar

  • Use the Document Map tab to find specific sections.
  • Use the Pages tab to navigate to specific pages.
  • You can also use the Search Field to search for specific sections of your report.

Note: Clicking on a section in the Table of Contents will also take you to that section of the report.

5.2 SECTION VISIBILITY

The Report Generator allows you to select which sections you wish to include in the report. By default, all sections are included. To add or remove a section from your report:

  1. Click on the Section Visibility button in the tool bar (or the popout menu on the rigth of the screen). The list of sections will appear.
  2. Section visibility Icon

  3. Un-check the boxes next to sections you do not want included in the report.
  4. Section Visibility menu

  5. When you’re done, click on the Section Visibility button again to close the menu.

6.0 Adding Images and Comments

The Report Generator lets you add images and comments to any section of the report.

6.1 IMAGES

To add an image to your report:

Images button

  1. Click the Images button in the tool bar. A new dialog will appear.
  2. Images dialog

  3. Click the +Add button to begin adding images.
  4. Use the Section drop down to select the section where you want to add the image.
  5. Click Insert to select file to add.
  6. Repeat the above steps to add more images.
  7. If you wish to remove an image, click on the line you wish to remove and then click Delete.
  8. Click OK to close the dialog.

6.2 COMMENTS

To add comments to your report:

Comments button

  1. Click on the Comments button in the tool bar.
  2. Comments dialog

  3. Click the +Add button to begin adding comments.
  4. Use the Section drop down to select the section where you want to add the comment.
  5. Click Insert. A window will appear where you can enter your comment.
  6. Click OK.
  7. Repeat the above steps to add more comments.
  8. If you wish to remove a comment, click on the line you wish to remove and then click Delete.
  9. Click OK to close the dialog.

7.0 Page Breaks

The Page Breaks button allows you add page breaks between all major sections in the report.

Page breaks button

Toggle the Page Breaks button on or off to add or remove the page breaks between each section.

8.0 Header & Footer

A Header and Footer are automatically added to your report with relevant content including the Date, Project Name and other details.

To customize the content in your header and footer:

Header and footer icon

  1. Click on the Header & Footer icon. A dialog will appear.
  2. Header and footer dialog

  3. Use click on Header or Footer tab to select what section edit.
  4. Use the radio buttons to decide the number of columns you wish to include in your header or footer.
  5. Use the drop down menus to change what content appears.
  6. Click Apply to apply the changes to your report.
  7. Click Reset to Default to reset the header and footer to the default options.

9.0 Cover Page options

When you launch the Report Generator a Cover Page is automatically created for your report.

To edit the contents of the Cover Page:

Cover page button

  1. Click on the Cover Page button in the tool bar. A new dialog will appear.
  2. Cover page dialog

  3. Use the check boxes on the left to select what elements to include on the cover page.
  4. Use the drop down menus to select the location and alignment of images.
  5. Click the Choose File button to change the logo and/or cover image and select your own image file.
  6. You can edit the text in any of the three text boxes.
  7. Once you have made the necessary changes, click OK to close the dialog and apply your changes.

10.0 Export Options

When you have completed customizing your report, you have the option to export a digital copy of your report.

To export your report:

  1. Click on the Export button in the tool bar.
  2. Export button

  3. Select PDF. A new dialog will appear.
  4. Export dialog

  5. Select the File path for your report.
  6. Enter any additional details you wish to include by clicking More Options.
  7. Click OK to finish exporting the file.

10.0 Saving your current display settings for future reports

You can save the current display settings for use on future reports. This includes Cover Page images and Header and Footer preferences.

To save your current display settings:

Click the Save button in the tool bar. Your settings will be saved and will be the default when you next open the program.


Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee