The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Non-Circular Surfaces Tutorial

1. Introduction

This tutorial will use the same model as Tutorial 2 - Materials and Loading to demonstrate how an analysis can be performed using non-circular (piece-wise linear) slip surfaces. The finished product of this tutorial can be found in the Tutorial 03 Non-Circular Surfaces.slmd data file. All tutorial files installed with Slide2 can be accessed by selecting File > Recent > Tutorials folder from the Slide2 main menu.

2. Model Setup

Since we are using exactly the same model from the previous tutorial, we will not repeat the modeling procedure, but simply read in a file.

Select: File > Open

If you completed the previous tutorial, and saved the file, you can use this file (tutorial02.slmd). If you did not do the previous tutorial, or did not save the file, then the required file is also available in the Slide2 Tutorials folder, which can be accessed by selecting File > Recent Folders > Tutorials Folder from the Slide2 main menu (file: Tutorial 02 Materials and Loading.slmd).

Open whichever file is most convenient. For our purposes, we have opened the finished model from Tutorial 2 as shown below:

Model Setup tutorial

MULTI SCENARIO DOCUMENT VIEWER

Notice the Document Viewer pane in the sidebar.

Master Scenario Document Viewer

The Document Viewer allows you to create, name and organize the various models that you will be analyzing in Multi Scenario mode.

By default, one Group containing one Master Scenario will automatically be created. The definition of Group and Scenario is as follows:

  • Group – by definition, all Scenarios within a Group have the same boundaries (e.g. External and Material boundaries). If you edit the boundaries for one scenario, the edits will automatically propagate to all scenarios in the same Group.
  • Master Scenario – the Master Scenario is a general template for the scenarios in a group. Any changes you apply to the Master Scenario (e.g. add load, support, etc.) will propagate to the scenarios in the group.
  • Scenario – scenarios allow you to change any other input parameters (except boundaries). Each scenario can have different input parameters.

For more information please refer to the Groups and Scenarios page.

Save the model before proceeding. Now, let’s rename the Group and set up the scenarios as follows:

  1. Right-click on “Group 1” and select Add Scenario from the popup menu.
  2. Right-click on “Scenario 2” and select Rename from the popup menu. Rename the Scenario “Block Search”.

Note that in the “Group & Scenario Properties” dialog, in addition to renaming scenarios you can also change the display order of scenarios and add scenario descriptions.

  1. Click Save and Close.

SURFACE OPTIONS

The first thing we need to do, is change the Surface Type to Non-Circular, in the Surface Options dialog. Select the Surfaces workflow tab, and select Surface Options from the toolbar or the Surfaces menu.

Select: Surfaces > Surface Options

In the Surface Options dialog, change the Surface Type to Non-Circular, and select Block Search.

We will be using all of the default Block Search Options for now, so just select OK.

BLOCK SEARCH

The term “Block Search” is used in Slide2, since a typical non-circular sliding mass, with only a few sliding planes, can be considered as consisting of active, passive and central blocks of material, as shown below.

Block Search slide2

In order to carry out a Block Search with Slide2, the user must create one or more Block Search objects (window, line, point or polyline). The Block Search objects are used to randomly generate the locations of slip surface vertices.

For a model with a narrow weak layer, the best way to perform a Block Search is to use the Block Search Polyline option. This option works as follows:

  1. TWO points are first generated on the polyline, according to user-definable selections.
  2. The slip surface is constrained to follow the polyline, between the two points.
  3. The projection angles are used to project the surface up to the ground surface, from the two points.
  4. Steps 1 to 3 are repeated for the required number of slip surfaces.

Let’s add the polyline to the model.

Select the Add Block Search Polyline option from the toolbar, or from the Block Search submenu in the Surfaces menu. (Notice that the options in the toolbar and Surfaces menu are now applicable to non-circular surfaces, since we changed the Surface Type from Circular to Non-Circular in the Surface Options dialog).

Select: Surfaces > Block Search > Add Polyline

You will see a new dialog. This dialog allows you to specify how the two points will be generated on the polyline. The points can be randomly generated at any location (the Any Line Segment option), or randomly generated on the first or last line segments, or fixed at the endpoints of the polyline.

In most cases, it is best to start with the Any Line Segment option, to maximize the coverage of the search along the polyline. This is already the default selection for both points, so just select OK in the dialog.

Now enter the points defining the polyline. The points can be entered graphically with the mouse, but we will enter the following points in the prompt line:

(39,23); (81,31)

Hit Enter to complete the polyline. Your model should now look like this:

Any Line Segment

The Block Search Polyline search object is now added to the model, within the weak layer. Notice the arrows displayed on either side of the line. The arrows represent the left and right projection angles which will be used for projecting the slip surface to the ground surface. The projection angles can be customized by the user in the Surface Options dialog, which we will be doing later in this tutorial. For now, we are using the default angles.

More About Block Search Objects

At this point you may be wondering – why did we use the Block Search Polyline option, when we only defined a single line segment? There is a very good reason:

  • A Block Search Polyline always generates TWO points along the line. The slip surface is then constrained to follow the polyline, between the two points.
  • In the general case, when a Block Search Polyline consists of multiple line segments, this makes it very easy to define a Block Search, along an irregular (non-linear) weak layer.
  • A Block Search Polyline may consist of only a single line segment. Two points are still generated on the single line segment, which makes it easy to define a Block Search along a linear weak layer.

The Block Search Polyline option was specially developed for the purpose of easily searching along linear or non-linear weak layers.

In contrast the other Block Search objects in Slide2 – Window, Line or Point – only generate a SINGLE slip surface vertex, for each object. For a Block Search LINE object, the slip surface does not “follow” the line; you are only guaranteed to have a single vertex ON the line.

In order to create the same search with Block Search Line objects, you would have to define TWO Block Search Lines, which are co-linear. To define a Block Search along an irregular (non-linear) weak layer is much more difficult (although it can be done, using a combination of Block Search Line objects, and Block Search Point objects, at each “bend” in the weak layer.)

In general, any number of Block Search Objects can be defined, and used in any combination. In fact, you may even use a Block Search Polyline object in combination with Window, Line and Point objects, or even another Polyline object (as long as no other search objects overlap a Polyline object).

For more information about Block Search objects, please see the Slide2 Help topic.

3. Compute

Save the file and click on Compute. The “Select scenarios to compute” dialog will appear. Click OK.

Select scenarios to compute dialog

For this simple model, all slip surfaces generated by the search will consist of three line segments – a line segment along the Block Search Polyline, and the left and right projected segments.

4. Interpret

To view the results of the analysis:

Select: Analysis > Interpret

interpret analysis

By default, the Global Minimum slip surface for a Bishop analysis will be displayed.

On the sidebar, go to Display Options and toggle the checkbox for the "Centers of Rotations" to Yes.

You will also notice a cluster of points above the slope. For a non-circular analysis, these points are automatically generated by Slide2, and are the axis points used for moment equilibrium calculations. An axis point is generated for EACH non-circular slip surface, by using the coordinates of the slip surface to determine a best-fit circle. The center of the best-fit circle is used as the axis point for the non-circular surface.

The Global Minimum safety factor for a Bishop analysis is 0.763. Compare this with the results of the circular search in the previous tutorial (0.798).

As might be expected for this model, the Block Search has found a lower safety factor surface. A non-circular (piece-wise linear) surface is much better suited to finding slip surfaces along a weak layer, such as we have modeled here, than a circular surface.

Select the Janbu Simplified analysis method in the toolbar and observe the safety factor and slip surface. In this case, the Bishop and Janbu methods have located the same Global Minimum surface.

Now select the All Surfaces option.

Select: Data > All Surfaces

NOTE: the Minimum Surfaces option, used in previous tutorials, is not available for non- circular surfaces. The Minimum Surfaces option only applies to slip center grids used for a circular surface Grid Search.

Let’s use the Filter Surfaces option, to display only surfaces with a factor of safety less than 1.

Select: Data > Filter Surfaces

In the Filter Surfaces dialog, select the “Surfaces with a factor of safety below” option, enter a value of 1, and select Done.

As you can see in the next figure, there are many unstable surfaces for this model, other than the Global Minimum, with a Factor of Safety < 1. This model would definitely require support or design modifications, in order to be made stable.

Filter Surfaces

Turn off the All Surfaces display, by re-selecting All Surfaces.

Select: Data > All Surfaces

5. Graph Query

Adding and graphing Queries for non-circular surfaces is the same as described in the previous tutorial for circular surfaces. For example, a convenient shortcut is the following:

  • Select Graph Query from the toolbar. Slide2 will automatically create a Query for the Global Minimum, and display the Graph Slice Data dialog.

Graph Query base cohesion

Select Base Cohesion from the Primary Data drop-list. Select Create Plot. The graph will be created. As you can see, the graph shows the cohesive strengths (28.5 and 0) of the two materials we defined. Along most of this slip surface, the zero cohesion of the weak layer is in effect.

Base Cohesion create plot

Now right-click on the graph, and select Change Plot Data from the popup menu. You will see the Graph Slice Data dialog again.

Select Base Friction Angle from the Primary Data drop-list. Select Create Plot.

The graph now displays the friction angle of the two materials we defined (20 and 10 degrees). Along most of this slip surface, the 10 degree friction angle of the weak layer is in effect.

We will now go back to the Slide2 modeler, and enter a range of projection angles in the Surface Options dialog, and re-run the analysis.

Switch back to the Interpret Window by clicking on the "Group 1 - Block Search:1* - bishop simplified method*" tab on the bottom of the window.

Select the Modeler option from the toolbar or the Analysis menu.

Select: Analysis > Modeler

Right-click on the “Non Circular” Scenario and select Duplicate Scenario. Rename the new scenario to be “Block Search - Angles”.

Select Surface Options from the Surfaces menu (or as a shortcut, you can right-click the mouse anywhere in the view, and select Surface Options from the popup menu).

Select: Surfaces > Surface Options

In the Surface Options dialog, set the Left Projection Angle range to Start = 125 , End = 155 and the Right Projection Angle range to Start = 25 and End = 55. Select OK.

Notice that there are now two Left Projection Angle arrows and two Right Projection Angle arrows on the model, indicating the start / end angular limits you just entered in the Surface Options dialog.

TIP: the Projection Angles are measured COUNTER-CLOCKWISE from the positive X-axis. If you are unsure about the appropriate values to enter, you can use the Apply button to view the Projection Angles on the model, without closing the dialog.

6. Compute

Save and Compute the file. The “Select scenarios to compute” dialog will reappear. Click OK.

Select scenarios to compute dialog

7. Interpret

To view the results of the analysis:

Select: Analysis > Interpret

This will load the latest analysis results into the Slide2 Interpret program.

slide2 analysis interpret

The Global Minimum slip surface, for a Bishop analysis, now has a safety factor = 0.706.

By providing a range of projection angles, a slip surface with a lower factor of safety than the previous analysis, has been located.

Display all surfaces analyzed.

Select: Data > All Surfaces

Note that the colours of the slip surfaces and axis points correspond to the safety factor colours displayed in the Legend.

Also notice the range of projection angles used to generate the first and last segments of each slip surface, since we specified ranges for the left and right projection angles in the Surface Options dialog.

We will now demonstrate one more searching option in Slide2, the Optimize Surfaces option. Return to the Slide2 Model program.

Select: Analysis > Modeler

8. Optimize Surfaces

The Optimize Surfaces option is another very useful searching tool in Slide2. It allows you to continue searching for a lower factor of safety Global Minimum, using the results of the Block Search as a starting point.

Duplicate the “Block Search – Angles” scenario and rename the new one “Block Search – Optimization”. Make all edits to this new scenario.

  1. In the Surface Options dialog, select the Optimize Surfaces checkbox.
  2. Re-run the analysis.
  3. You will find that the Optimize Surfaces option, has located a significantly lower factor of safety Global Minimum slip surface. The Bishop global minimum factor of safety = 0.674.
  4. Notice that the optimized global minimum travels along the bottom of the weak layer, and includes extra line segments due to the insertion of vertices during the optimization process.

If you zoom in and select the Show Slices option, you can get a better view of the optimized surface as shown below.

Optimize Surfaces Show Slices

For more information about the Optimize Surfaces option, see the Slide2 Help system. You can easily compare results of all different methods examined in this tutorial by going through the different scenarios.

9. Random Surface Generation

It is important to remember that the Block Search is dependent on the generation of random numbers, in order to generate slip surfaces:

  • by randomly generating the slip surface vertex locations using the Block Search Objects, and
  • by randomly generating the Projection Angles (if a range of angles is specified).

However, if you re-compute the analyses in this tutorial, you will always get exactly the same results. The reason for this, is that we have been using the Pseudo-Random option (in Project Settings > Random Numbers)

Project Settings Random Numbers

Pseudo-random analysis means that, although random numbers are used to generate the slip surfaces, THE SAME SURFACES WILL BE GENERATED EACH TIME THE ANALYSIS IS RERUN, since the same “seed” is used in each case, to generate the random numbers. This allows you to obtain reproducible results, for a non-circular slip surface search, even though random surfaces are being generated. By default, the Pseudo-Random option is selected in Project Settings.

However, you may also use the Random option in Project Settings > Random Numbers. In this case a different “seed” will be used each time the analysis is re-run. Each analysis will therefore produce different slip surfaces, and you may obtain different Global Minimum safety factors, and surfaces, with each analysis.

It is left as an optional exercise, to experiment with the Random Number generation option. Re-run the analysis several times, using the Random Number Generation option in Project Settings, and observe the results. TIP: in order to more clearly see the effects of true random sampling, you can enter a lower Number of Surfaces (e.g. 200) in the Surface Options dialog.

That concludes this tutorial.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee