The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Analysis of Embankment using multi-modal optimization (MMO)

1.0 Introduction

This tutorial will look at multi-modal optimization, or the ability to search for multiple minima at the same time.

Finished Product:

The finished product of this tutorial can be found in the Tutorial 38 MMO.slmd data file. All tutorial files installed with Slide2 can be accessed by selecting File > Recent Folders > Tutorials Folder from the Slide2 main menu.

2.0 Getting Started

After opening Slide2:

  1. Select File > Recent > Tutorials folder from the Slide2 main menu.
  2. Open Tutorial 38 MMO – starting file.
  3. You should see the following:

    Tutorials MMO slide2

    You can click on Analysis > Project Settings to see that the Spencer method is selected. You can also click on Surfaces > Surface Options to see that Particle Swarm non-circular search is selected.

  4. Select Analysis > Compute.
  5. Once computed, select Analysis > Interpret to view the results.
  6. You will notice a minimum surface towards the top of the embankment.

    Particle Swarm non-circular

  7. Select Data > All Surfaces.

These are all the surfaces that were checked to find that critical surface. You will notice that there seem to be two distinct low FS regions:

Particle Swarm all surfaces

While slope stability analysis generally seeks to find the most critical failure surface, for many models there may be multiple critical regions. It is important that the engineer is aware of all potential failures.

3.0 Search Limits

Select Query > Add Query and hover over the second orange region.

We see that the FS seems to be in the 1.5 range. However, the search is geared towards finding the global minimum, so it may not have found the lowest FS at this region; further only the global minimum is optimized with Surface Altering.

global minimum Surface Altering

We will get the FS value for the second region by modifying the slope limits.

  1. Return to the Modeler and right click on the “Start” group in the Document Viewer and select “Add Scenario.” Do this twice.
  2. Right-click on one of the scenarios and click “Rename.”
  3. In the dialog name the first scenario “slope limits” and the second scenario “MMO.”
  4. Click “Save and Close.
  5. Click on the “slope limits” scenario in the Document Viewer.
  6. Right-click on the slope limits and select “Define Limits” or do this from Surfaces > Slope Limits.
  7. Change the right slope limit to 100.
  8. Click OK and then Compute.
  9. In the dialog, only select the “slope limits” scenario and click OK.
  10. Open up Interpret to view the results.

We now see the FS=1.35 value for this region:

Add Scenario define limits

Close Interpret and return to the Modeler.

4.0 MMO

Click on the MMO scenario.

This time we will use MMO to allow our search algorithm to scan the slope for all minima instead of making it zero in on the single most critical minimum. To do this:

  1. Select Surfaces > Surface Options.
  2. Click on the Options button to expand the additional options.
  3. Now switch the Number of Failures from One to Multiple.
  4. This means we are allowing the algorithm to find multiple failure modes. The algorithm will determine the number of modes present in each model. However, the user has the option to cap the number of modes they would like to see, or the highest FS value they would like to see. Keep in mind both of these options only apply to the secondary modes (the lowest FS mode is always displayed). By default, at most 4 modes are shown, with FS values up to 3.

  5. Click OK.
  6. Surface Options MMO

  7. Compute the model and open Interpret.

We see that the search was able to find the two main modes, along with an additional third mode as shown. Note as well that all of these minima were optimized using Surface Altering.

Select Data > All Surfaces. The results will look as follows:

All Surfaces result

Notice that the surfaces shown are different from the ones we saw in the first part of the tutorial – particularly the FS=1.395 mode was not visible before. This is because the MMO algorithm does not zero in on the global minimum but searches the entire slope for all minima.

Select: Query > Show Slices.

You will notice that the slices are only shown for the lowest FS surface. To view the slices for the 1.353 surface, first right-click on it and select Add Query. Values along the surface can be viewed in the same way for the different minima.

An MMO analysis is a recommended additional scenario to compute along with your regular analyses. It can bring to light failure modes that were not at first evident.


Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee