The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

RS3 Quick Start

1.0 Introduction

This tutorial introduces some of the basic features of RS3. The model analyzes the effect of foundation loading near a sloped underground tunnel. In the model, the tunnel is excavated first. Then, a shallow foundation is excavated, followed by the foundation filled with concrete. The last stage involves loading the foundation.

All tutorial files installed with RS3 can be accessed by selecting File > Recent > Tutorials folder from the RS3 main menu. The finished product of this tutorial can be found in the Quick Start.rs3dmodel file.

2.0 Starting the Model

Start RS3. You will see a blank page workspace with drop down menu and toolbars on the top.

Go to Project Settings by following the steps:

Project Settings icon Select: Analysis > Project Settings.

The Project Settings dialog is used to configure the main analysis parameters for your RS3 model. Under the tab [Units], set Units as Metric, stress as kPa. The dialog should look as shown below:

Project Settings dialog box

Select the [Stages] tab. Enter Number of Stages = 5, with names as shown below. We will be applying different procedures at each stages, so it is important to keep track of the stages by labeling them with relevant names.

Stages

Stage Name

1

Initial

2

Excavate tunnel

3

Excavate foundation

4

Pour concrete foundation

5

Loading foundation

After inputting the stages, the dialogue should look as followed:

Project Settings dialog

Next, select the [Groundwater] tab. Enter Method as None, as the model we will be creating does not contain any groundwater. More details on this feature are provided in Online Help (Keyword search: Project Settings / Groundwater). We will be covering this topic later in the other tutorial (Transient Dam). For now, make sure the Pore Fluid Unit Weight is set to default value (9.81 kN/m3).

Project Settings Groundwater tab dialog box

Select OK to close the dialog.

Now, we will check the display option to use old contour rendering method. This method is suggested for faster rendering speed.

Select: View > Display Options.

Display Options dialog box

Check that all three graphics options of Enable Hardware Accelation, Use Simple Transparency Rendering and Use Old Contour Rendering Method are checked. More explanation of these features are explained in Display Options.

3.0 Defining the Materials

Geology workflow tab

Under the same tab (Geology or Excavations) you can assign the materials and properties of the model through materials setting.

Materials icon Select: Materials > Define Materials.

Note: By default, RS3 assigns all created geology (not excavations) the material “Material 1”, so if you define Material 1 as the material you want the majority of the geology to be, you can save some time in assigning properties later.

Enter the following properties for “Material 1” and “Material 2” in the [Stiffness] tab. Leave the other options with Default Settings.

Name

Initial Loading

Unit Weight (kN/m3)

Young's Modulus (kPa)

Poisson's Ratio

Material 1

Soil

Field Stress & Body Force

20

20000

0.3

Material 2

Concrete

Body Force Only

27

280000

0.3

The Material Properties dialog for Soil should look as the following:

Material Properties dialog box

The material properties dialogue for concrete should look as the following:

Material Properties dialog box

Select OK to close the dialog.

Note: For more explanation on initial element loading, refer to RS2 Help > RS2 Model > Material Properties > Initial Element Loading.

4.0 Creating Geometry

Geology workflow tab

Ensure the Geology tab is selected from the workflow at the top of the screen.

Note:
- RS3 is designed with an intuitive workflow to help guide the user through the required steps in creating a model. Under each tab, the toolbars and menus are customized to provide the user with the functions they will need in each step of creating their model.
- RS3 uses the Z direction as the default for the direction of gravity, so when creating geometry, it’s important to keep this in mind to orient your model.
- RS3 uses an external box to act as the scope of the model, meaning only objects contained within or a part of the external box will be considered in the calculations. As such, when creating a model, it is important to realize the model’s bounds before setting up the external box

Create External Box icon Select: Geometry > Create External Box.

A Create External dialog will open, enter First Corner (x, y, z) = (0, 0, 0), Second Corner (x, y, z) = (30, 30, -20), then press OK.

Create External dialog box

After geometry has been created, under the visibility pane on the left, select the 'External' volume and re-name it to 'Soil' using properties pane below.

5.0 Excavating

Excavations workflow tab

5.1 CREATING A CYLINDER FOR THE UNDERGROUND TUNNEL

Select the Excavations tab from the workflow at the top of the screen.

We will now design the excavation bodies. We need to define a cylinder for our underground tunnel.

Cylinder icon Select: Geometry > 3D Primitive Geometry > Cylinder.

Enter the following axis and properties:

Axis Start Point (x, y, z) = (10, 0, -10),

Axis End Point (x, y, z) = (10, 30, -10),

Radius = 1, Subdivisions = 25,

then press OK.

Create Cylinder dialog box

The model should look as the following:

image of model

5.2 EXTRUDING A CIRCLE FOR THE FOUNDATION

Next, we are going to create an extruded circle for the foundation.

Note: We could easily create the foundation through defining another cylinder as we did above for the tunnel, but for the purpose of demonstrating other features of RS3, this cylinder will be created through a different (more lengthy) process.

Draw Ployline icon Select: Geometry > Polyline Tools > Draw Polyline.

A Draw Polyline panel will open on the left.

Select Plane Orientation = XY

XY Origin (x, y, z) = (17.5, 15, 0),

Path Definition = Circle, Circle Definition = Center and Radius,

Radius = 5,

Coordinate Input U, V = 0 0 [Enter] (make sure to press enter), then press the blue checkmark Blue Checkmark icon to close the pane.

Note: You can press on the grey arrow beside Discretization Settings to define the number of straight line segments that define the circle (or the approximate segment length), but here, the default is fine.

The model should look as shown below:

Image of model

Note: If you want to rotate the model, press the wheel on top right window or select the box with labels and rotate the box to your liking.

Select Polyline in the visibility pane (top left section),

Extrude icon Select: Geometry > Extrude/Sweep/Loft Tools > Extrude or select Extrude icon in the toolbar. Extrude icon

An Extrude Geometry dialog will appear as shown below. Keep Direction (x, y, z) = (0, 0, 1), and change Depth = -0.5, then press OK.

Extrude dialog box

Notice only the external layer is locked from the visibility tree. This is because the layer is defined as an external volume and the geometry cannot be modified. The other entities (Cylinder and Polyline_extruded) are geometry objects that are not interacting with the external volume. In order to proceed with the model, you have to use Divide All Geometry function to convert the geometry objects to sub volumes in the main model.

Visability dialog box

5.2.1 Divide All Geometry

Now that we’ve completed defining the external box, and the objects to be cut into it, we can divide our model according to the objects we defined:

Note: Make sure that none of the geometries are selected in the visibility pane so the Divide All function can be applied throughout the whole model. If you want to divide specific geometry separately, select the geometry of interest from the visibility pane and apply the Divide All function.

Divide All Geometry icon Select: Geometry > 3D Boolean > Divide All Geometry.

Divide All Parameters dialog helps users to fine tune the behavior of the Divide All function. Setting Quality to Default option is suitable for a wide range of models in general, however, there are cases where changing the setting is required to successfully intersect every geometry with external boundary. For more detail about each option under Divide All Parameters, please refer to Divide / Un-Divide All Geometry. Select OK to begin dividing.

Divide All Parameters dialog box

Your 3D model should look similar to the one below.

Image of a 3D model

Note: Notice that the excess portion of the cylinder outside the external boundary has been truncated after clicking 'Divide All Geometry' because it extended past the boundary outside the external box.

Also, notice that the name of each item in the visibility pane are labelled with numbers on the side. Remove the numbers by simply changing the names in the properties pane. In this tutorial, we will refer to the name of the items without numbers.

6.0 Staging

6.1 STAGING THE TUNNEL EXCAVATION

The underground tunnel is excavated at stage 2, meaning in stage 1 it should still be “Soil”.

Note: RS3 separates stages through tabs at the bottom of the window. The screens will update loads, materials, and other staged elements as you make them active. This feature makes it easy to view the different states of the model at each stage.

Starting with the underground tunnel, make sure the model is currently active on stage 2 Excavate tunnel (bottom pane of tabs). Now select the underground tunnel in the visibility pane (the name should of the layer should be 'Underground Tunnel'), and in the properties pane, change the Applied Property = No Material.

Note: Once changing the property of a body, RS3 will automatically make the following stages to have the same property (e.g. if a body was excavated in stage 1, indicated through property being No Material, it will change from the original material to No Material in all subsequent stages as well).

6.2 STAGING THE FOUNDATION

The foundation is excavated at stage 3, and the concrete is poured in stage 4. Now we do the same excavation for the foundation as we completed for the tunnel, but starting from stage 3. Select the stage tab Excavate foundation.

Select the foundation volume from the visibility pane (the name of the layer should be 'Foundation'), then in the properties pane, change Applied Property = No Material.

Now select Stage tab Pour concrete foundation, and in the Foundation properties pane, change the Applied Property = Concrete.

Note: RS3 also provides a quick visual summary of the currently selected object’s state in each stage. For example, if you select the foundation in the visibility pane, on top of the stage tabs, you’ll notice stage 1 and 2 have a purple line (indicating it is material 1), stage 3 is clear (indicating it is defined as no material), and stage 4 and 5 are light green (concrete).
Quick Visual Summary

7.0 Adding Stress Loading

Loads workflow tab

7.1 APPLYING A SURFACE LOAD TO THE MODEL

Select the Loads tab. This tab allows you to edit the loading conditions for model. Select the foundation surface with Faces Selection Faces Selection icon mode active in toolbar.

Image of applying surface load to a model

Select: Loading > Add Loads to Selected.

Enter Magnitude = 200 (kN/m2), and Install at Stage = Loading foundation, the rest should be the initial Default Values then press OK.

This will allow the users to apply uniformly distributed load on the area of interest.

Add Load dialog box

7.2 APPLYING A FIELD STRESS

This option allows you to edit the field stress loading conditions.

Select: Loading > Field Stress.

Leave Settings as defaults. Field Stress Type is set to gravity. Select OK.

Field Stress dialog box

Note: Field stress is applied to elements where initial element loads are defined with field stress. If the elements do not have field stress assigned (i.e. initial element loading set to Body Force Only) this stress will NOT be used at all. Since we have soil with initial element load as Field stress & Body Force, this load will be applied in our model. Please refer to RS2 online help for more information about initial element loading.

8.0 Setting Boundary Conditions

Restraints workflow tab

8.1 ADDING MODEL RESTRAINTS

Move to the Restraints tab to assign restraints to the external boundary of the model.

RS3 has a built in "Auto Restrain" tool for use on underground models.

Auto Restrain (Surface) icon Select: Restraints > Auto Restrain (Surface). The model should look as the following:

Completed model

This completes the construction of the model (in terms of geometry).

9.0 Meshing

9.1 CONFIGURING AND CALCULATING MESH

Next we move to the Mesh tab. Here we may specify the mesh type and discretization density for our model. For this tutorial, we will use a default setting, 4-node finite element mesh type.

Mesh icon Select: Mesh > Mesh Settings

Mesh Settings dialog box

Enter Element Type = 4-Noded Tetrahedra, Mesh Gradation = Graded

Note: the mesh option can be modified by the user - element type and mesh gradation. For element type, there are two types available (4 noded tetrahedra and 10 noded tetrahedra). 10 noded tetrahedra has mid-side nodes, and has more computational points. Using 10 noded tetrahedra generally yields more accurate result at the cost of computation time. For better results it is recommended to use 10 noded tetrahedron type, and 4 noded tetrahedra if computational efficiency is a priority.

Select Mesh to mesh the model. Select OK

Note: In case if you have selected OK instead of Mesh, then simply select under to drop down menu: Mesh > Mesh to mesh the model.

10.0 Computing Results

Compute workflow tab

10.1 COMPUTING THE MODEL

Next we move to Compute tab.

From this tab we can compute the results of our model. First, save your model: File > Save As.

Use the Save As dialog to save the file, and next you need to save the compute file: File > Save Compute File. You are now ready to compute the results.

Compute icon Select: Compute > Compute.

Note: The RS3 Compute engine will perform the required finite element calculations. This computation may take a few minutes; however, more complex models may take a much longer time to compute. Once computation is complete, the dialog closes.

RS3 Compute engine

11.0 Interpreting Results

Results workflow tab

11.1 DISPLAYING THE RESULTS

Next we move to Results tab.

From this From this tab we can analyze the results of our model. First, refresh the results:

Refresh All Results icon Select: Interpret > Refresh All Results.

Refreshing the result allow us to plot new results of the model. Although we did not have any previous results from this model, it is good practice to refresh result before we view new contour plots.

On the top right corner of the Results tab, you should see two drop down menus:

Results tab drop down menu

Note: The “Element” drop down menu allows you to view the results for solids, bolts, and liners. For this tutorial we can only view results for Solids.

We will analyze a number of different “Data Type” results. Let’s turn on the exterior contours so we can see some results.

Show Excavation Contour icon Select: Interpret > Show Excavation Contour.

Show Data on Plane icon Also, select: Interpret > Show Data on Plane > XZ Plane (with x,y,z = 18,15,-10 as shown below),

Create Plan dialog box

Select OK to close the dialog.

11.2 DISPLAYING THE PRINCIPAL STRESS RESULTS

In the top right corner of the Results tab, in the legends window, ensure Element = Solids, and keep the data type as default: Sigma 1 Effective:

Results drop down menu

In order to compare each stage against each other visually, the contour color scheme was standardized across all stages,

Contour Options icon Select: Interpret > Contour Legend > Contour Options.and select the checkbox Auto Range (All Stages) as also shown below. Select OK

Contour Options dialog box

The Sigma 1 Effective results at stage 4 and 5 are shown below.

Sigma 1 effective at Pour concrete foundation (Stage 4)

Sigma 1 effective at Loading foundation (Stage 5)

2D view

2D View

2D View

3D view

3D View

3D View

Legend

Legend

Legend

As shown in the contour plot, we can see the changes in the stress distribution across the soil model as the load of foundation is applied at stage 5. Next we will investigate the change in the displacement across the stages 2 to 5.

11.3 DISPLAYING THE DISPLACEMENT RESULTS

In the top right corner of the Results tab, ensure Element = Solids, and change Data Type = Total Displacement

Results drop down menu

Similar to principal stress result comparison, we will also use auto range across each stages for contour options.

Contour Options icon Select: Interpret > Contour Legend > Contour Options. The default setting is set for Auto range at a specific stage. So make sure to select the check box Auto Range (All Stages).

Contour Options dialog box

The Total Displacement results at stage 2-5 are shown below.

Excavate Tunnel (Stage 2)Excavate Tunnel (Stage 2) Legend
Excavate foundation (Stage 3)Excavate foundation (Stage 3)
Pour concrete foundation (Stage 4)Pour concrete foundation (Stage 4)
Loading foundation (Stage 5)Loading foundation (Stage 5) Legend

Other results are available to view as well.

This concludes the Introduction: RS3 Tutorial1 Quick Start tutorial.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee