The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Transient Dam

1.0 Introduction

This tutorial demonstrates some of the transient groundwater features of RS3. Here we create a dam with a changing head to examine the pressure head with time.

All tutorial files installed with RS3 can be accessed by selecting File > Recent > Tutorials folder from the RS3 main menu. The starting file of this tutorial can be found in the Transient Dam - starting file.rs3dmodel file and the finished product of this tutorial can be found in the Transient Dam.rs3dmodel file.

2.0 Starting the Model

Open the starting file from File > Recent > Tutorials > Transient Dam - starting file.rs3dmodel

The model should have initial project settings already defined for the user. Please check the following inputs:

Select: File > Save to save the project as Transient Dam.rs3dmodel.

Go to Project Setting.

Project Settings icon Select: Analysis > Project Settings.

The Project Settings dialog is used to configure the main analysis parameters for your RS3 model.

Project Settings dialog box

Next, select the [Groundwater] tab.

Project Settings dialog box (Groundwater tab)

Check that Method = Transient, and make Define pwp method by stage = activated, then Select the [Stages] tab.

Check: Number of Stages = 6, check the change in PWP method for Stages 2- 6 = Transient, with time = 2, 4, 6, 10, 50 (also see below).

Project Settings dialog box (Stages tab)

Select OK to close the dialog.

3.0 Defining the Materials

Under the same tab (Geology or Excavations) you can assign the materials and properties of the model through materials setting.

The model should have the materials already defined for the user. Please check the following inputs:

Select: Materials > Define Materials.

In the [Strength] and [Hydraulics] tab respectively, check the strength parameters and hydraulics parameters.

Material 1 [Strength]:

Materials Properties dialog box

then select [Hydraulics].

Material Properties dialog box (Hydrolics tab)

Do similarly for Material 2:

Material 2 [Initial Conditions]:

Material Properties dialog box

Material 2 [Strength]:

Material Properties dialog box

then select [Hydraulics].

Material Properties dialog box

Select OK to close the dialog.

4.0 Creating Geometry

Geology workflow tab

Ensure the Geology tab is selected from the workflow at the top of the screen.

4.1 CREATING THE DAM PROFILE

Draw Polyline icon Select: Geometry > Polyline Tools > Draw Polyline.

On the left of the screen a Draw Polyline dialog will open.

Draw Polyline dialog box

Select Plane Orientation = XZ,

Then enter the following U,V Coordinates (press [Enter] between each pair) =

(0, 0) [Enter]

(100, 0) [Enter]

(100, 10) [Enter]

(75, 10) [Enter]

(51, 22) [Enter]

(44, 22) [Enter]

(20, 10) [Enter]

(0, 10) [Enter]

(0, 0) [Enter]

Select the blue check mark to finish the polyline.

Select “PolyLine” in the visibility pane, then

Extrude icon Select: Geometry > Extrude/Sweep/Loft Tools > Extrude or select Extrude icon in the toolbar. Extrude icon

Enter Direction (x, y, z) = (0, 1, 0), Depth = 30, and click preview to see the geometry. Select OK.

Extrude dialog box

Select "Polyline_extruded” in the visibility pane,
Select: Geometry > Set as External.

4.2 SEPARATING THE DAM LAYERS

In this model we will have a foundation with a different dam material on top. We need to draw the line that will be used to separate the materials.

Plane icon Select: Geometry > 3D Primitive Geometry > Plane.

Select Plane Definition = XY Plane. Under the Plane Definition, set Plane Origin (x, y, z) = (50, 15, 10), and Plane Normal (x, y, z) = (0, 0, 1). Leave the Rotation Around Normal to 0, then press OK.

Create Plane dialog

Next we need to create two closed shapes from the plane:

Divide All Geometry icon Select: Geometry > 3D Boolean > Divide All Geometry.

Divide All Parameters dialog box

Select OK.

After doing so, you’ll find there are two volumes, one defining the top dam, the second the base.

Select the top volume from visibility pane and select Applied Property > Dam, and change the name to Dam.

Select the bottom volume from visibility pane and select Applied Property > Foundation, and change the name to Foundation.

5.0 Defining Groundwater

Groundwater workflow tab

5.1 STEADY STATE GROUNDWATER BOUNDARY CONDITIONS

Select the Groundwater tab from the workflow at the top of the screen.

We will now define the groundwater boundary conditions.

Make sure that Stage 1 is active in the bottom stage tabs, then select from the toolbar: Faces Selection Faces Selection icon .

While holding down the [Ctrl] key, select the faces highlighted in the following image in order to apply groundwater boundary conditions (Top two surfaces of the dam, and top surface of the foundation):

Screenshot of higlighting faces to apply goroundwater boundray conditions

Add Goundwater Boundary Conditons icon Select: Groundwater > Add Groundwater Boundary Conditions

Add Groundwater Boundary Conditions dialog box

Select the pencil beside the dropdown to edit the groundwater boundary conditions to open the Groundwater Properties dialog.

Define Groundwater Boundary Conditions dialog box

Enter Name = Unknown, Type = Unknown (P=0 or Q=0), then select OK, then OK to add the BC, ensuring it is installed at Stage 1 and never removed.

While holding down the [Ctrl] key, select the faces highlighted in the following image (other two top sides of the model)

Image of highlighting faces

Add Gorundwater Boundray Conditions icon Select: Groundwater > Add Groundwater Boundary Conditions

Select the pencil beside the dropdown to edit the groundwater boundary conditions to open the Groundwater Properties dialog

Add a new groundwater boundary condition by pressing the add symbol (+) in the bottom right of the dialog.

Define Groundwater Boundary Conditions dialog box

Enter Name = TH20, Type = Total Head (H), Total Head Value = 20, then press OK to return to the Add GWBC dialog.

For the first stage, the pwp method is steady state so we will simply add a total head to be removed at Stage 2, then select OK.

Add Groundwater Boundary Conditions dialog box

5.1.1 Transient Groundwater Boundary Condition

Select the Stage 2 [2] tab at the bottom of the RS3 window.

Select from the toolbar: Faces Selection Faces Selection icon .

While holding down the [Ctrl] key, select the faces highlighted in the following image in order to apply groundwater boundary conditions.

Image of selecting faces to apply groundwater boundary conditions

Add Groundwater Boundary Conditions icon Select: Groundwater > Add Groundwater Boundary Conditions

Select the pencil beside the dropdown to edit the groundwater boundary conditions to open the Groundwater Properties dialog.

We need to create a whole new transient groundwater property, add a new groundwater boundary condition by pressing the add symbol in the bottom right of the dialog. Set it up as shown and press OK

Define Groundwater Boundary Conditions dialog box

Enter Name = Transient, Select Transient, Type = Total Head (H), type in Time = (0, 2, 4, 6), and Total Head = (20, 18, 16, 14), then select OK to return to the Add GWBC dialog.

We want to apply the transient condition at Stage 2 [Install at Stage Condition to Enter] until the end of analysis. Once the settings match the screenshot below, then select OK.

Add Groundwater Boundary Conditions dialog box

Image of selecting faces

6.0 Adding Field Stress

Loads workflow tab

Next we go to the Loads tab. This tab allows you to edit the loading conditions.

Select: Loading > Field Stress.

Leave Settings as default. Field Stress Type is set to Gravity. Select OK.

Field Stress dialog box

7.0 Setting Boundary Conditions

Restraints workflow tab

7.1 ADDING MODEL RESTRAINS

Move to the Restraints tab to assign restraints to the external boundary of the model.

RS3 has a built in “Auto Restrain” tool for use on underground models but we can’t utilize for this tutorial because of the inclined free surface.

For custom restrain definition, select the following faces in the model (using Face Selection Face Selection icon in the toolbar):

Image of selecting faces in the model

Select: Restraints > Add Restraints/Displacements > Restrain XY, then press OK.

Next we will select the bottom face to restrain.

Image of selecting the bottom face to restrain

Select: Restraints > Add Restraints/Displacements > Restrain XYZ, then press OK.

8.0 Meshing

Mesh workflow tab

8.1 CONFIGURING AND CALCULATING MESH

Next we move to the Mesh tab. Here we may specify the mesh type and discretization density for our model.

Mesh icon Select: Mesh > Mesh Settings

Use the default options:

Element Type = 4-Noded Tetrahedra, Mesh Gradation = Graded.

Select Mesh to mesh the model.

Mesh Settings dialog

9.0 Computing Results

Compute workflow tab

Next we move to Compute tab. From this tab we can compute the results of our model. First, save your model: File > Save As.

Use the Save As dialog to save the file, and next you need to save the compute file: File > Save Compute File. You are now ready to compute the results.

Compute icon Select: Compute > Compute Groundwater Only.

RS3 3.0 dialog box

10.0 Interpreting Results

Results workflow tab

10.1 DISPLAYING THE RESULTS

Next we move to Results tab. From this tab we can analyze the results of our model. First, refresh the results:

Refresh All Results icon Select: Interpret > Refresh All Results.

Refreshing the result allow us to plot new results of the model. Although we did not have any previous results from this model, it is good practice to refresh result before we view new contour plots.

On the top right corner of the Results tab, you should see two drop down menus:

Results tab drop down menu

Ensure [Solids] is selected from the Element drop down menu

We will analyze a number of different “Data Type” results. Let’s turn on the exterior contours so we can see some results:

Show Exterior Contour icon Select: Interpret > Show Exterior Contour.

Note: Under any non-groundwater calculations, the exterior contour will not appear, as only groundwater results were computed

Pressure Head

In the top right corner of the Results tab, change data type to Pressure head. Select: Seepage > Pressure Head:

Results drop down menu

Then Select : Interpret > Contour Legend > Contour Options, to select the Custom Range, from -0.05 to 22.5, then press OK.

Custom Range dialog box

The pressure head results at Stage 1, 2, 3, 4, 5, and 6 are shown below respectively.

Stage 1

Stage 1 Stage 1Legend

Stage 2

Stage 2Stage 2

Legend

Stage 3

Stage 3Stage 3

Legend

Stage 4

Stage 4Stage 4

Legend

Stage 5

Stage 5 Stage 5

Legend

Stage 6

Stage 6Stage 6

Legend

Other results such as total and excess pore pressure are available to view. This concludes the tutorial.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee