The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Geometry Cleaning Overview

1.0 Introduction

This tutorial will demonstrate how to use the automatic functionality in the Geometry Repair tool included with RS3, in addition to some other useful Surface Triangulation Tools. Previous versions of RS3 required that users repair defective geometry using third-party software prior to importing in to RS3. Now, the inclusion of geometry cleaning tools allows the geometry to be repaired within RS3 itself. This tutorial uses an open pit model with a pit surface and a vertical geological surface. We will use the Geometry Repair tool and some Surface Triangulation Tools on the individual entities to prepare them for the Divide All Geometry operation.

2.0 Open the Model

Select: File > Recent > Tutorials and read in the file Geometry Cleaning – Overview – starting file from the installation folder. The project includes a pit surface, a polyline to define the extents in the X and Y directions, and a polyline that will be used to define a vertical geological surface.

Opening Geometry Cleaning Overview

In the following we will use the Geometry Repair tool on the pit surface, and some Surface Triangulation Tools on the polyline and vertical geological surface.

3.0 Geometry Repair Tool

Click on the pit surface under the Visibility pane on the top left side of the program.

Note: you can select multiple entities to repair in the same operation.

Select: Geometry > Repair Tools > Repair.

You should be able to see the Repair Geometry dialog.

Repair Geometry dialog

The tool will search the geometry for defects. The more complicated the geometry, the longer this will take. This geometry is a bit complicated so you'll be expected to see the result after a minute or so. The tool then presents four panels.

Repair Geometry dialog

The main view shows a 3D view of the geometry, and its color-coded defects. The colors correspond to those in the Filtered Results panel. The magenta boxes group the defects into clusters. They can highlight defects that might otherwise be too small to see. For example: there is one Self-Intersection near the South edge of the pit that might be difficult to see.

The Filtered Results panel contains: a list of defect categories; the number of defects in each category; the color of the defects drawn in the 3D view; and the option to exclude a defect category from the Repair operation.

The list of individual items groups the defects by entity, then cluster. Click the Eye Eye icon icon to hide or show a given entity, cluster, or defect, in the 3D view. You can search for entities, clusters, or defects using the Search bar above this list. For example, type “intersect”, then click the Find button (or type ) to search for items containing that text. Click the X in the Search bar (or type ) to clear the search.

The repair panel contains Repair Options, the Repair button, and an optional Settings area.

The default Repair Option is Repair All. This is the most automatic way to repair geometry. For more information on Repair settings option, please refer to Geometry Repair Tool tutorial which describes the repair selection options.

Repair All option first invokes the Re-Triangulate tool (Geometry > Surface Triangulation Tools > Re-Triangulate) on the entirety of each entity; this is a global operation that often fixes many defects just by itself. Then it iteratively fixes the remaining defects, up to a maximum number of iterations.

Click the Repair button now to automatically fix the geometry. The more complicated the geometry, and the more defects there are, the longer this will take. Once complete, the tool presents you with an updated look at the geometry. The tool was able to automatically fix all defects on this particular pit surface.

Note: The repair tool stops after a maximum number of iterations to avoid modifying the geometry too much. If defects are still present, you can continue repairing the geometry. If you don’t mind further modifying the geometry, you can use the Repair button again. Otherwise, you can select the Repair Selected option to address individual defects, without modifying the rest of the geometry.

The Repair tool has added the repaired geometry to the model; the Name of the entity has been appended with “_repaired” as shown below. Click the Close button to dismiss the tool.

Repair Geometry dialog

4.0 The External Volume

The pit surface’s boundary is still overly detailed in some areas, so we will define a volume that excludes the boundary. This is another way to deal with bad geometry: leave it outside of your External volume.

Click the external_outline under the Visibility pane.

Extrude icon Select: Geometry > Extrude / Sweep / Loft Tools > Extrude or select Extrude Extrude icon from toolbar..

We will extrude the geometry by a Depth of -200, and ensure the Close Volume(s) checkbox is enabled.

Extrude dialog box

Click OK to create the volume. Ensure the Role of the new volume is set to Geology (Select extrnal_outline_extruded under the Visibility pane, change its Role from Construction to Geology under the Properties pane bottom left)

We will now use the pit surface to cut away the top of the extruded volume. Click the pit_surface_repaired and external_outline_extruded under the Visibility pane to select them both.

Select: Geometry > 3D Boolean > Split. The tool should have automatically identified the external_outline_extruded volume as the Volume to Split, and the pit_surface_repaired as the Splitter.

Split dialog

Click OK to perform the Boolean operation.

You will see the following volume has been split into two layers. Select the top layer of the open pit model and change the role to construction in the visibility tree.

Image of volume being split into two layers

While the top layer is still selected,

Select: Geometry > Delete Selected Construction Geometry Delete icon .

Then, you will see the following geometry as shown below. Image of Geometry

Note: Since the intersection of the extruded volume and the pit surface created new (potentially bad-quality) triangles, you should repair, or at least inspect, the subtracted volume before setting it as the External. Try it now before continuing (To do so go to Geometry > Repair Tools > Repair

The volume that defines the model’s extents has now been prepared, so we will set it as the External. Click on the split volume to select it.

Select: Geometry > Set as External.

5.0 Surface Triangulation Tools

RS3 includes several other tools to help improve or otherwise manipulate geometry. We will use Create Triangulation From Closed Polyline, Merge, and Re-Triangulate, to create a vertical geological surface from a closed polyline. First, we will fill the interior of a closed polyline to create a surface.

Click on the geological_surface_outline polyline entity.

Note: you can select multiple polylines to fill in the same operation.

Select: Geometry > Surface Triangulation Tools > Create Triangulation From Closed Polyline Polyline icon .

Create Polyline dialog

Click on Create Polygons to fill the polyline. This creates the simplest triangulation inside the polyline, without modifying the actual polyline, or adding any vertices in the surface interior. Zooming in to the top of the surface shows several unnecessary protrusions. Image showing several unnecessary protrusions

Select: View > Show All Edges. Show All Edges allows you to see the triangulation on all surfaces. In this case, there are several large and narrow triangles. Image showing all triangulatioons on all surfaces

We will use more Surface Triangulation Tools to generate a better surface. Turn off the edge rendering by selecting the menu item again.

Click on the Polygon 1 under the Visibility pane.

Select: Geometry > Surface Triangulation Tools > Merge. We will use the Merge tool to collapse clumps of vertices within a given tolerance. Change the Tolerance Options to Custom. Enter an Intersect Tolerance of 5 (m).

Merge dialog box

Click OK to merge the geometry. This produces a much neater boundary.

Image of a neater boundary

Note: if you select multiple surfaces for the same Merge operation, the tool first connects the surfaces into one (potentially non-manifold) surface. This can be useful for composing a single surface from multiple pieces.

Since no vertices were added to the interior of the surface, the Merge tool only improved the quality of the boundary. We will use the Re-Triangulate tool to improve the quality of the interior.

In the Visibility pane, cllick on Merged entity to select it.

Select: Geometry > Surface Triangulation Tools > Re-Triangulate. We can use the default settings for now.

Re-Triangulate dialog box

Click the OK button.

Use View > Show All Edges again to see the effect of Re-Triangulate on the surface interior. Image of 'Re-Triangulate' effect on the surface interior

Turn if off when you are done.

6.0 Divide All Geometry

Divide All Parameters dialog box Now that the individual entities have been prepared, we can combine them in the Divide All Geometry operation.

Note: Make sure 'Subtracted' layer (pit layer) is set as external, otherwise you may not be able to use Divide All Geometry option, since there is no external volume.

Select: Geometry > 3D Boolean > Divide All Geometry.

Use the default settings, and click the OK button.

You can now assign geological materials, and continue with the non-geometric steps of the modelling process. Image of assigning geological materials to the modeling process


Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee