The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Dynamic Analysis of Foundation

1.0 Introduction

This tutorial will demonstrate some of the dynamic analysis features of RS3. Here we simulate a foundation experiencing cyclic machine loading

All tutorial files installed with RS3 can be accessed by selecting File > Recent > Tutorials folder from the RS3 main menu. The finished product of this tutorial can be found in the Dynamic Analysis of Foundation.rs3dmodel file. The starting file can be found in Dynamic Analysis of Foundation - starting file.rs3dmodel file.

2.0 Starting the Model

Open the starting file from File > Recent > Tutorials > Underground Tunnels - starting file.rs3dmodel

All the project settings and material definition are predefined in the starting file. Read through these two sections to make sure the inputs in the model are consistent with this tutorial.

Project Settings icon Select: Analysis > Project Settings.

In [Units] tab, set Units = Metric, stress as kPa.

Project Settings dialog- Units

Next, select the [Dynamic] tab.

Project Settings dialog- Dynamic

Check: Dynamic Analysis = Active, Alpha M = 0.898, Beta K = 0.002, Num Time Steps = Auto, then select the [Stages] tab.

When you switch to Stages in tab in the Project Settings dialog, a warning may pop up as below

Units Conversion dialog

Select Yes.

Project Settings dialog- Stages

Check: Number of stages = 5, Dynamic (Stages 2- 5) = Active, with time = 0.7, 0.73, 0.75, 1.5 seconds, and names as also shown above. Do not change any other settings. Select OK to close the dialog.

3.0 Defining the Materials

Defining Materials Properties

Under the same tab (Geology or Excavations) you can assign the materials and properties of the model through materials setting.

The starting file should already have these values provided for the user. Just make sure the values in this tutorials are consistent with the model.

Select: Materials > Define Materials.

Properties for “Material 1” and “Material 2” in the [Stiffness] tabs are shown below respectively.

Material 1 [Stiffness]:

Properties for Material 1 in Stiffness tab

Unit weight = 27 kN/m3.

Properties for Materials 2 in Stiffness tab

Material 2 [Stiffness]:

Properties for Material 2

4.0 Creating the Geometry

Geology workflow tab

4.1 CREATING THE GROUND

In order to create the ground, we will draw a rectangular prism,

3D Primitive Geometry icon Select: Geometry > 3D Primitive Geometry > Box

Create Box dialog bos

A Create Box dialog will open, enter First Corner (x, y, z) = (0, 0, 0), Second Corner (x, y, z) = (140, 70, 70), then OK.

3D Primitive Geometry Box Select: Geometry > 3D Primitive Geometry > Box

Create Box dialog box

A Create Box dialog will open, enter First Corner (x, y, z) = (66, 31, 69), Second Corner (x, y, z) = (74, 39, 70.4), then OK.

4.2 PREPPING THE EXTERNAL BOUNDARIES

Now to capture the extents of the model as the external boundary, the foundation must be merged with the ground. But as they are made of different materials, we also need to create a cutting plane between the merged bodies. Select both bodies in the visibility pane,

Divide All Geometry icon Select: Geometry > 3D Boolean > Union.

Select OK. Then, select the “Union” body in the visibility pane, and

Select: Geometry > Set as External.

Now to define the cutting plane,

3D Primitive Geometry icon Select: Geometry > 3D Primitive Geometry > Plane.

Select XY Plane, and under Plane Definition, set Origin (x, y, z) = (70, 35, 70), [Create Plane], [Done].

Create Plane dialog box

4.3 DIVIDING THE MODEL

Now to finish the model,

Divide All Geometry icon Select: Geometry > 3D Boolean > Divide All Geometry. Select OK with default quality.

Now ensure all bodies have Role = Geology, (can do so by seeing if all bodies have the geology icon in the visibility pane). Change the foundation body to Concrete by selecting “Union_2” in the visibility pane, and in the properties pane change Applied Property = Concrete. After doing so, the model should look like:

Image of Model after 'Applied Property= Concrete'

5.0 Setting Boundary Conditions

Restraints workflow tab

Because the model already has dynamic boundary, you do not need to add restraints to the model. You can skip the restraints, and when the model asks for compute without restraints later, just select OK.

6.0 Adding The Dynamic Condition

Loads workflow tab

6.1 LOADING THE MODEL

Select the top foundation face, then

Add Dynamic Loads icon Select: Dynamic > Add Dynamic Loads.

Press the pencil edit icon beside the Dynamic Property dropdown to edit the loading. A Dynamic Load Properties dialog should appear,

set Name = Dynamic Load, Type = Force, Custom = Active, X: = Active, then press [Define…] next to X.

Dynamic Load Properties dialog

In the new dialog Define Dynamic Load Force By Time, select [Import] Import icon to import the “machine_load.txt” provided in the tutorial folder.

(Import File Instruction: Data Delimiter should be selected as Space/Tab).

When all values have been imported, press OK four times to confirm and close all dialogs. You should now notice that as you flip between Stage 1 and 2, the loading will toggle on and off, as the load begins to be applied at Stage 2 (the first dynamic stage)

Import CSV File dialog

Add Dynamic Load dialog box

6.2 ADDING BOUNDARY CONDITION

Note: RS3 provides a number of dynamic boundary conditions and elements that are utilized only in dynamic analysis. For this model absorbing boundaries will be applied on the lateral and bottom external boundaries of the model in order to absorb incoming shear and pressure waves travelling in the soil. The boundaries must be absorbing since the dynamic load is inside the domain and the model should not have any excess reflecting back from the model

Select all four side faces, and the bottom face of the ground (five faces total), then,

Image of model absorbing boundaries

Add Dynamic Boundary Conditions icon Select: Dynamic > Add Dynamic Boundary Conditions.

Press the pencil edit icon beside the Dynamic Property dropdown to edit the boundary condition. A Dynamic BC Properties dialog should appear, set Name = Absorb, Type = Absorb, then press OK

Dynamic BC Properties dialog

You should now notice that as you flip between Stage 1 and 2, the Absorb BC will toggle on and off, as the load begins to be applied at Stage 2 (the first dynamic stage).

6.3 ADDING A DYNAMIC QUERY LINE

Add Time Query icon Select: Dynamic > Add Time Query.

In the Draw Polyline pane that appears to the left of the viewport,

Select Plane Orientation = XZ, XZ Origin = (70, 35, 70), then enter U,V Coord (press [Enter] between each pair) =

(0,0) [Enter]

(0 -70) [Enter]

Then press the blue checkmark to finish entering coordinates.

Draw Polyline dialog box

A Query options dialog will open, keep the defaults, OK.

Query Optiions dialog box

8.0 Meshing

Mesh workflow tab

Configuring and Calculating Mesh

Next we move to the Mesh tab.

Mesh Settings icon Select: Mesh > Mesh Settings

Enter Element Type = 4-Noded Tetrahedra, Mesh Gradation = Graded,

Select Mesh to mesh the model.

Mesh Settings dialog box

The mesh is now generated, your model should look like the one below.

Model after the mesh was created

10.0 Computing Results

Compute workflow tab

Next we move to Compute tab. From this tab we can compute the results of our model. First, save your model: File > Save As.

Use the Save As dialog to save the file, and next you need to save the compute file: File > Save Compute File. You are now ready to compute the results.

Compute icon Select: Compute > Compute

Compute dialog box

11.0 Interpreting Results

Results workflow tab

11.1 DISPLAYING THE X DISPLACEMENT RESULTS

On the top right corner of the Results tab, you should see two drop down menus:

Results drop down menu

Ensure [Solids] is selected from the Element drop down menu.

We will analyze the X Displacement results, so

Select Data Type > Solid displacement > X Displacement. Let’s add a plane contour so we can see some results:

Create Plane icon Select: Interpret > Show data on plane > XZ Plane,

Center (x, y, z) = (70, 35, 35.2), Normal (x, y, z) = (0, 1, 0), then press OK. Then

Create Plane dialog box

Countour Options icon Select: Interpret > Contour Legend > Contour Options.

Select Auto Range (All Stages) for Contour Range.

Contour Options dialog box

Note: you can try the Custom Range option to see the contour plots across each stage with custom range. Note that there may be blank spots when data is out of the custom range. Also, press Refresh All Results in case the contour plots are not updated for each stages.

If exterior contour option is on, then simply select the eye icon to turn off the Exterior Contour layer in visibility tree.

Toggling through the Intermediate stages one can observe the progression of the shear wave as it travels down and the formation of a new negative displacement zone at the surface as the foundation translates left. You can also see the propagation of the shear waves outwards laterally. The x displacement results should look like the following (showing shear waves propagating through the ground):

X Displacement Results

X Displacement Results

X Displacement Results

x Displacement Results

If your model does not look like the ones shown above try toggling off the Exterior Contour layer from the Visibility pane.

Show Exterior Contour icon Select: Interpret > Show Exterior Contour.

The results are shown with auto-range with exterior contour plot to better illustrate wave propagation from foundation to soil at each stages. The results through the stages should look like the below:

Image of results through the stages

Image of results through the stages

Image of results through the stages

Image of results through the stages

11.2 GRAPHING THE QUERY LINE RESULTS

The results along a query line can be plotted, select “Polyline_dynamic” in the visibility pane. Make sure you're in last stage of the analysis. Then in the properties pane press [ Graph Data]. A new tab should open with a graph. The Time Query will create a plot with Time on the horizontal axis and X Displacement on the vertical axis. The Time Query must have Time as an axis plotted against the selected data type (in this case X Displacement was selected in previous steps). If you plot a time query line, the data ranges for each query point is normalized based on the maximum range of all query data being plotted. If you add only a time query point, the graph is plotted with the original data and is not normalized since it is the only data series that is being plotted.

Time vs X Displacement graph

Settings can be adjusted using the pane on the left. Select Change Plot Data to adjust the graph data including time scale. Other results are available to view as well. This concludes the tutorial.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee