Expert Modelling: Hands-on help from Rocscience Engineers. Register Here
 

Search Results

Automate Probabilistic Analysis

This tutorial will familiarize you with the Automate Compute feature of RocPlane by automating a RocPlane Probabilistic analysis.

Topics Covered in this Tutorial:

  • Probabilistic Analysis RocPlane Model
  • Input Excel File Format
  • Pre-processing Input Excel File for Bench Analysis
  • Adding Input Excel File(s) to Automate Compute File Queue
  • Output RocPlane Automate Compute Results File

Finished Product:

The finished products of this tutorial can be found in the Tutorial 10 Automate Compute - Probabilistic Analysis folder, located in the Examples > Tutorials folder in your RocPlane installation folder. Inside, you will find:

  • Tutorial 10 Automate Compute - Probabilistic_base file.pln4 RocPlane model file setup for automation
  • Tutorial 10 Automate Compute - Probabilistic_inputs.xlsx Excel input file
  • Tutorial 10 Automate Compute - Probabilistic_inputs folder containing the computed results files
  • Tutorial 10 Automate Compute - Probabilistic_post-process.xlsx Excel file with all raw combined results data, Excel formula computations, and Excel graph

1.0 Introduction

The Automate Compute option helps users quickly generate results for several RocPlane analysis cases at a time by reading in various model inputs from Excel. In this tutorial, we will automate the computation of 13 Probabilistic cases, each case with 10,000 samples (i.e., 13 x 10,000 = 130,000 wedges).

2.0 Creating a New File

If you have not already done so, run the RocPlane program by double-clicking the RocPlane icon in your installation folder or by selecting Programs > Rocscience > RocPlane > RocPlane in the Windows Start menu.

When the program starts, a default model is automatically created. If you do NOT see a model on your screen:

Select: File > New

Whenever a new file is created, the default input data forms a valid wedge, as shown in the image below.

New File

If the RocPlane application window is not already maximized, maximize it now so that the full screen is available for viewing the model.

Before we are ready to run Automate Compute, we must first set up the model environment in the following dialogs:

  1. Project Settings
  2. Input Data
  3. Scale Wedge

NOTE: This RocPlane model file is meant to be used as a base file for automation. It contains the appropriate settings to be used for all automated cases and the engine for computation. It is not meant to be used for model creation and result viewing, as it does not save the model state for every case.

3.0 Project Settings

First, set the model Units, Analysis Type, and Block Shape.

  1. Select Project Settings option from the Analysis menu to open the Project Settings dialog.
  2. Set the Units = Metric, stress as kPa.
  3. Set the Analysis Type = Probabilistic.
  4.  Project Settings

  5. Set the Number of Samples = 10000.
  6.  Project Settings

  7. Select OK to close the dialog.

NOTE: The above Project Settings will apply to all cases analyzed in Automate Compute. Each case being analyzed is Probabilistic (i.e. 10,000 sample wedges, as defined) in this case.

4.0 Input Data

Next, set the optional input data.

  1. Select Input Data from the Analysis menu to open the Probabilistic Input Data dialog.
  2. Navigate to the Slope tab.
  3. Keep all the Statistical Distributions = None and check box controls in the default state. Keep in mind that the following are required input parameters that have to be specified later on in the Input Excel File:

    • Slope Angle Mean
    • Slope Height Mean
    • Rock Unit Weight Mean

    Probabilistic Input Data

  4. Navigate to the Upper Face tab.
  5. Check the Bench Width check box control.
  6. Keep all the Statistical Distributions = None.
  7. Keep in mind that the following are required input parameters that have to be specified later on in the Input Excel File:

    • Upper Face Angle Mean
    • Bench Width Mean

    Probabilistic Input Data

  8. Navigate to the Failure Plane tab.

Keep Waviness Statistical Distributions = None. Keep in mind that the following are required input parameters that have to be specified later on in the Input Excel File:

  • Failure Plane Angle Mean
  • Failure Plane Waviness Mean

Probabilistic Input Data

  • Navigate to the Strength tab.
  • Set the Shear Strength Model = Mohr-Coulomb.
  • Set the Random Variables = Parameters.
  • Set the Cohesion Statistical Distribution = Normal.
  • Keep the Friction Angle Statistical Distribution = None.
  • Keep in mind that the following are required input parameters that have to be specified later on in the Input Excel File:

    • Cohesion Mean, Standard Deviation, Relative Minimum, and Relative Maximum
    • Friction Angle Mean

    Probabilistic Input Data

  • We will not apply Tension Crack, Ponded Water, Plane Water, Seismic Force, or External Forces.
  • Select OK to close the dialog.
  • NOTE: You can learn about RocPlane input data in detail in Overview of RocPlane Input Data.

    5.0 Input Excel File

    Now, let's take a look at the structure of the input Excel file.

    1. Obtain the RocPlane Probabilistic Excel Template by selecting Analysis > Automate Compute > Probabilistic Excel Template from the menu.
    2. A Read-Only Excel workbook titled RocPlane Automation Template_Probabilistic.xlsx will be automatically opened (if you have Excel installed on your local machine).

      Input Excel File

      The RocPlane Probabilistic Input Data Automation Template Excel workbook and worksheets are protected to prevent any accidental modification to the tab structure and headers. The input Excel template contains 9 worksheets for inputting numerical parameters for automation.

    3. Create a folder called Tutorial 09 Automate Compute - Probabilistic.
    4. Navigate to the SLOPE worksheet.
    5. Under the Wedge ID column, provide the names of the wedges. We will name them according to Bench Face Angle (i.e., Slope Angle). Each row in the input Excel file represents one Probabilistic Analysis case in RocPlane. We will run a case for each Bench Face Angle ranging from 30 to 90 degrees, by 5 degree increments.
    6. Enter the following for:

    Wedge ID

    Slope

    Dip

    Height

    Unit Weight

    Mean

    Mean

    Mean

    BFA 30

    30

    30

    26

    BFA 35

    35

    30

    26

    BFA 40

    40

    30

    26

    ...

    ...

    ...

    ...

    BFA 90

    90

    30

    26

    NOTE: As set up previously in the RocPlane Probabilistic Input Data dialog, only the above input data are required since Slope Length and Statistical Distributions are not applicable. Be aware of units set in RocPlane Project Settings when entering data into the input Excel file. The units should be the same for both!

    The SLOPE worksheet should look like this:

    Slope worksheet

    TIP: Use Formulas or Auto Fill feature in Excel to quickly populate the Wedge IDs

  • Navigate to the UPPER FACE worksheet.
  • Under the Wedge ID column, provide the names of the wedges.
  • Enter the following:
  • Wedge ID

    Upper Face

    Bench Width

    Dip

    Width

    Mean

    BFA 30

    0

    10

    BFA 35

    0

    10

    BFA 40

    0

    10

    ...

    ...

    ...

    BFA 90

    0

    10

    NOTE: As set up previously in the RocPlane Deterministic Input Data dialog, the above input data are required since Bench Width is checked. Be aware of units set in RocPlane Project Settings when entering data into the input Excel file. The units should be the same for both!

    The UPPER FACE worksheet should look like this:

    UPPER FACE worksheet

  • Navigate to the FAILURE PLANE worksheet.
  • Under the Wedge ID column, provide the names of the wedges.
  • Enter the following:
  • Wedge ID

    Failure Plane

    Angle

    Waviness

    Mean

    Mean

    BFA 30

    45

    0

    BFA 35

    45

    0

    BFA 40

    45

    0

    ...

    ...

    ...

    BFA 90

    45

    0

    The FAILURE PLANE worksheet should look like this:

    Failure plane worksheet

  • Navigate to the STRENGTH worksheet.
  • Under the Wedge ID column, provide the names of the wedges.
  • Enter the following:
  • Wedge ID

    Strength

    Cohesion

    Friction Angle

    Mean

    Std. Dev.

    Rel. Min.

    Rel. Max.

    Mean

    BFA 30

    20

    5

    20

    20

    30

    BFA 35

    20

    5

    20

    20

    30

    BFA 40

    20

    5

    20

    20

    30

    ...

    ...

    ...

    ...

    ...

    ...

    BFA 90

    20

    5

    20

    20

    30

    The STRENGTH worksheet should look like this:

    Strength worksheet

    We do not need to enter any data in the TENSION CRACK, SEISMIC, PONDED WATER, PLANE WATER, or SCALE WEDGE worksheets since those are not applicable.

  • Save the Excel file as Tutorial 10 Automate Compute - Probabilistic_inputs.xlsx to the Tutorial 10 Automate Compute - Probabilistic folder previously created.
  • NOTE: Since the RocPlane Automation Template_Probabilistic.xlsx file is Read-Only, you must rename and save in a new location.

    We are now ready to automate computations in RocPlane by reading from the input Excel file.

    6.0 Automate from Excel

    Return to the RocPlane model.

    The Automate Compute dialog allows you to add Excel input automation files to the queue, select a an output format, and compute the results.

    6.1 ADD FILES TO FILE QUEUE

    To add multiple files to the File Queue:

    1. Select Automate from Excel from the Analysis menu to open the Automated Compute dialog.
      Automate from Excel
    2. Select the Open button to open a standard dialog to choose an Excel input file. Navigate to the Tutorial 10 Automate Compute - Probabilistic folder and select the Tutorial 10 Automate Compute - Probabilistic_inputs.xlsx file.

    You will see the Excel input file appear under the File Queue list box.

    File Queue

    NOTE: Alternatively, you can choose a folder containing multiple files by selecting the Add Folder button.

    7.0 Output Result Files

    Results files are automatically generated and saved into the same directory as the input Excel file after Automated Compute is complete. Before we run Compute, first ensure that the Output File Format is set to the desired format. Users can select from either Text File or Excel format.

    7.1 TEXT FILE FORMAT

    While still in the Automated Compute dialog:

    1. Set the Output File Format dropdown to Text File.
    2. Select the Compute button to start the automated computing process.

    The Total Progress can be seen at the bottom of the dialog. When files have finished computing, they will appear in the Completed Files list box.

    Text File Format

    1. When all files have finished computing, select Exit to close the dialog.

    For each input Excel file case, a text file (.txt) containing all results data is generated..

    For a Probabilistic Analysis (Tutorial 10 Automate Compute - Probabilistic.xlsx), the results data for each case are output to a separate text file since each case tends to contain hundreds or thousands of wedge samples. Inside each text file, results for all probabilistic wedge samples in the case are outputted following the header row. Each row of data represents one sample wedge. Each data type is separated by a comma (,) for easy parsing.

    • Take a look at the ResultsBFA 30[0].txt result file.

    Probabilistic Analysis

    NOTE: For Slope Angle = 30 deg, no valid wedge geometries are formed. Remember that in order for a valid geometry to be formed, Slope Angle > Failure Plane Angle > Upper Face Angle.

    Note that a total of 13 files with the same format (i.e., ResultsBFA 30[0].txt, ResultsBFA35[0].txt, ..., ResultsBFA 90[0].txt ) have been created; one file per case.

    7.2 EXCEL FILE FORMAT

    Now, we will do the same as before, but this time we will generate the results as an Excel output file format.

    1. Select Automate from Excel from the Analysis menu to open the Automated Compute dialog.
    2. Select the Open button to open a standard dialog to choose an Excel input file. Navigate to the Tutorial 10 Automate Compute - Probabilistic folder and select the Tutorial 10 Automate Compute - Probabilistic.xlsx file.
    3. You will see the Excel input file appear under the File Queue list box.

    4. Set the Output File Format dropdown to Excel.
    5. Excel File Format

    6. Select the Compute button to start the automated computing process.
    7. When all files have finished computing, select Exit to close the dialog.
    8. For each input Excel file case, an Excel file (.xlsx) containing all results data is generated..

      For a Probabilistic Analysis (Tutorial 10 Automate Compute - Probabilistic.xlsx), the results data for each case are output to a separate Excel file since each case tends to contain hundreds or thousands of wedge samples. Inside each Excel file, results for all probabilistic wedge samples in the case are outputted following the header row. Each row of data represents one sample wedge. Each data type is separated by column.

      • Take a look at the ResultsBFA 30[0].xlsx result file.

    Probabilistic Analysis

    Note that a total of 13 files with the same format (i.e., ResultsBFA 30[0].xlsx, ResultsBFA35[0].xlsx, ..., ResultsBFA 90[0].xlsx ) have been created; one file per case.

    8.0 Error Log

    As you may have noticed, an Error Log is also generated for each input Excel file. For each input Excel file, an Error Log text file (Automate Compute Error Log.txt) is generated, and saved into the same directory as the output file directories. Always check that the Error Log reports "No errors found" before post-processing the raw results data. If any errors do occur as a result of missing (i.e., blank cells) or invalid inputs, the Error Log will indicate which worksheet(s) and cell(s) are problematic.

    9.0 Bench Analysis Using Post-Processed Results Data

    For demonstration purposes, we are going to post-process the results generated from Automate Compute in Excel. We want to generate a plot of [SUM(Volume of Wedges Failed) / SUM(Volume of Valid Wedges)] vs. Bench Angle.

  • Open a new Excel worksheet.
  • Grab the raw data from all Results Excel files.
  • Under the Data tab, select Get Data > From File > From Folder.
  • Browse for the Automate Compute Results Excel Files folder containing the Results Excel files.
  • Bench Analysis

    1. Select Combine > Combine & Load.
    2. Select Probabilistic Values and OK to extract the data from each Excel file.
    3. Probabilistic Values

    4. Wait while Excel runs the background query. The combined data will contain all the computed data.
    5. Post-process the data in Excel.
    6. Consider only valid wedges (i.e., Safety Factor is not "N/A").
    7. Group wedges by Bench Face Angle (i.e., Slope Angle = 30, 35, ..., 90).
    8. Group wedges by Safe (i.e., Safety Factor >= 1) and Failed (i.e., Safety Factor < 1).
    9. Sum Weight of Failed Wedges.
    10. Sum Weight of Valid Wedges.
    11. Weight Fraction Failed = Sum Weight of Failed Wedges / Sum Weight of Valid Wedges.
    12. Plot Weight Fraction Failed vs. Bench Face Angle in Excel:
    13. Weight Fraction Failed vs. Bench Face Angle

      Note that no valid wedges are formed when the Slope Angle is less than or equal to the Failure Plane Angle.

      This concludes the tutorial. You are now ready for the next tutorial, Tutorial 11 - Back Analysis of Bolt Properties in RocPlane.

    Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee