The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Slope Roughness

In this tutorial we will demonstrate the Slope Roughness option for Rigid Body analysis in RocFall. The Slope Roughness option allows you to generate physical geometric roughness along selected slope segments by defining spacing and amplitude statistical distributions for selected materials.

Topics Covered in this Tutorial:

  • Rigid Body analysis
  • Slope Roughness
  • Endpoint graphs

Finished Product:

The finished product of this tutorial can be found in the Tutorial 05 Slope Roughness data file. All tutorial files installed with RocFall can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall main menu.

1.0 Model (NO Slope Roughness)

Let's start by opening the file for the tutorial:

Select: File > Recent Folders > Tutorials Folder and open the Tutorial 05 initial file. You should see the following model.

Image of model model upon opeing

All slope and rock properties have already been defined.

  • The Rigid Body rock shape is a 1000 kg sphere
  • Number of Rocks = 50
  • Slope Roughness is NOT enabled
  • Initial Horizontal Velocity = 1.5 m/s
    • Distribution = Normal
    • Std. Dev = 0.15 m/s
    • Rel. Min = 0.45 m/s
    • Rel. Max = 0.45 m/s

2.0 Results (NO Slope Roughness)

Now we'll switch to Results mode to run the analysis and see results without any Slope Roughness assigned.

  • Click Results Results icon on the toolbar

Image of model

2.1 GRAPH ENDPOINTS

Next we'll generate an Endpoints graph of results.

  1. Select Graph Endpoints Graph Endpoints icon on the toolbar or the Graphs menu. The Graph Endpoints dialog should appear.
  2. Set Data = Endpoint Location.
  3. Set Value = Number of Rocks.
  4. Set Number of Bins = 50.
  5. Set Paths to Plot = All Rock Paths.
  6. Graph Endpoints dialog

  7. Select Plot Data to generate the Distribution of Rock Path End Locations graph.
  8. Right-click on the graph and click Toggle End Reasons.
    You should see the following graph.

Distribution of Rock Path End Locations graph

As you can see, most of the rocks have simply reached the end of the model without stopping. These are paths are indicated by "Edge Model".

3.0 Slope Roughness

We’ll now look at how adding Slope Roughness will affect the results. Slope Roughness is added using the Slope Material Library.

Slope Material Library icon Select: Slope > Slope Material Library

  1. Switch back to Design mode.
  2. Select Slope Material Library on the toolbar or the Slope menu.
  3. Select the Type Two material.
  4. Select the Slope Roughness check box.
  5. Keep Spacing = 0.20 m.
    • Distribution = None
  6. Keep Amplitude = 0.00 m
    • Distribution = Normal
    • Std. Dev = 0.2 m
    • Rel. Min = 0.6 m
    • Rel. Max = 0.6 m
  7. Slope Material Library dialog Distribution dialog
  8. Follow the same steps for material Type Three.
  9. Select OK.

4.0 Results (Slope Roughness)

Now we'll switch back to Results Results icon mode to run the analysis and view results with Slope Roughness added. You should note that the rockfall paths differ significantly from the model with no Slope Roughness.

Next we'll generate an Endpoints graph to compare it with the one we generated above with no Slope Roughness.

  1. Select Graph Endpoints Graph Endpoints icon on the toolbar or the Graphs menu. The Graph Endpoints dialog should appear.
  2. Set Data = Endpoint Location.
  3. Set Value = Number of Rocks.
  4. Set Number of Bins = 50.
  5. Set Paths to Plot = All Rock Paths.
  6. Graph Endpoints dialog

  7. Select Plot Data to generate the Distribution of Rock Path End Locations graph.
  8. Right-click on the graph and click Toggle End Reasons.
    You should see the following graph.

Distribution of Rock Path End Location graph

The rock endpoint graph is very different compared to the model with no Slope Roughness. Many rocks have come to rest on the upper bench and bottom of the slope, although some still reach the end of the model.

4.1 ANIMATE PATHS

Now we'll use the Animate Path option to view the rock fall.

  1. Select Animate Path Animate Path icon on the toolbar or the Results menu and zoom in if necessary.
  2. In the Animate Result dialog, click through each rock path using the forward arrow beside the rock ID number.

Image of model

NOTES:

  • Notice that, each time you view a new rock path, you can see the actual Slope Roughness generated for each rock throw. The Slope Roughness is randomly generated according to the Spacing and Amplitude statistics you defined above.
  • As you view the different rock paths, notice the actual Slope Roughness generated for the Type Two and Type Three material segments. For the spacing and amplitude values we have entered, the physical roughness is very jagged and not very realistic for an actual slope surface.

Image of model and Animate Results dialog

image of model and Animate Result dialog

5.0 Modify Slope Roughness Parameters

Let’s modify the Slope Roughness parameters and re-run the analysis to achieve a more realistic modeling of the surface roughness.

  1. Switch back to Design mode.
  2. Select Slope Material Library Slope Material Library icon on the toolbar or the Slope menu.
  3. Select the Type Two material.
  4. Set Spacing = 0.5 m and Distribution = None.
  5. Change Std. Dev: for Amplitude = 0.1 m.
    Slope Material Library dialog
  6. Select the Type Three material and repeat the steps above.
  7. Click OK.

6.0 Results (Modified Slope Roughness Parameters)

Now we'll switch back to Results Results icon mode to re-run the analysis and view results with Slope Roughness parameters modified.

Image of model

The rock paths look similar to the previous model. Let’s now generate an Endpoints graph for further comparison.

  1. Select Graph Endpoints Graph Endpoints icon on the toolbar or the Graphs menu. The Graph Endpoints dialog should appear.
  2. Set Data = Endpoint Location.
  3. Set Value = Number of Rocks.
  4. Set Number of Bins = 50.
  5. Set Paths to Plot = All Rock Paths.
  6. Graph Endpoints dialog

  7. Select Plot Data to generate the Distribution of Rock Path End Locations graph.
  8. Right-click on the graph and click Toggle End Reasons.
    You should see the following graph.

Distributions on Rock Path End Locations graph

NOTE:

Compare the distribution of endpoints to the previous model and compare the End Reasons. With the reduced Slope Roughness, a greater proportion of rocks have stopped, fewer rocks have wedged, and we have eliminated the Chattering End Reason, which is a numerical issue where rocks have essentially stopped but continue to move slightly and must be arbitrarily stopped. It is preferable that Chattering be avoided, if possible.

6.1 ANIMATE PATHS

Now we'll use the Animate Path option to view the rock fall.

  1. Select Animate Path Animate Path icon on the toolbar or the Results menu and zoom in if necessary.
  2. In the Animate Result dialog, click through each rock path using the forward arrow beside the rock ID number.
  3. Observe the slope roughness generated with the new spacing and amplitude parameters for each rock path.

Image of model and Animate Results dialog

Image of model and Animate Results dialog

NOTES:

  • In general, the modified Slope Roughness parameters (increased Spacing and decreased Amplitude variability) give a more realistic slope surface roughness.
  • To achieve a realistic surface roughness, it is recommended that you always experiment with the Spacing and Amplitude parameters, and observe the generated surfaces in order to simulate the actual field conditions as closely as possible.

This concludes the tutorial. You are now ready for the next tutorial, Tutorial 06 - Crest Loss in RocFall.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee