The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Rock Shapes in RocFall

In this tutorial, the Rigid Body analysis method will be used to define rock shapes in RocFall, focusing on the effect of rock shape and size.

Topics Covered in this Tutorial:

  • Importing DXP files
  • Using different shapes
  • Defining slope materials
  • Filtering paths

Finished Product:

The finished product of this tutorial can be found in the Tutorial 02 Rock Shapes data file. All tutorial files installed with RocFall can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall main menu.

1.0 Model

1.1 IMPORT DXF

For this example, slope coordinates will be imported from a DXF file using the Import DXF option on the File > Import menu.

  1. Select: File > Import > Import Slope from DXF.
    If necessary, navigate to the installation folder: C:\Users\Public\Documents\Rocscience\RocFall Examples\Tutorials, and open the file Tutorial 02_slope_profile.dxf.
  2. Click OK.

The slope should look as follows:

image of slope

1.2 SPECIFY PROJECT SETTINGS

The Project Settings dialog is used to configure the main analysis parameters of the model. To open the dialog, select Project Settings on the toolbar or the Analysis menu.

Project Settings icon Select: Analysis > Project Settings

The default Analysis Method is Lump Mass. With this method, rocks are assumed to be very small point masses. To use rock shapes, the Rigid Body method must be used.

  1. Select Rigid Body as the Analysis Method.
  2. Set Units = Metric (m, kg, kJ).
    Project Settings dialog
  3. Click OK.

1.3 DEFINE ROCK TYPES

First, let’s define the rock types for the analysis. Rock Types (Groups) are defined in the Rock Type Library dialog. To open the dialog, select Rock Type Library on the toolbar or the Seeder menu.

Rock Type Library icon Select: Seeder > Rock Type Library

Rock Type Library dialog

  1. In the dialog, change the name of Group 1 to Small rocks.
  2. Click the Smooth Shapes button.
    The Smooth Shapes popup appears.
    Smooth Shapes popup
  3. In the Available Shapes list, select Sphere, Oval (5:6), Hexagon, and Rhombus.
  4. Click OK.

Back in the Rock Type Library dialog, let's define the Distribution for Mass, Density, and Initial Rotation of the rocks for the Small rocks group:

  1. Ensure Mass (kg) = 1000.
  2. Click the Distribution icon Distribution icon next to Mass and set the parameters as shown below:
    Rock Type Library dialog
    By default, 3x std. dev. is selected to calculate the relative minimum and maximum to be three times the standard deviation; these values can be changed manually if necessary.
  3. Set Density (kg/m3) = 2700.
  4. Click the Distribution icon Distribution icon next to Density .
  5. Set Distribution = Normal and Std. Dev: = 50, and leave 3x std. dev. selected.
  6. Click OK.

Back in the Rock Type Library dialog, let’s add a second rock type:

  1. Click the Add button in the bottom-left corner of the dialog.
  2. Rename the new type as Large rocks.
  3. Set Mass (kg) = 10000.
  4. Click the Distribution icon Distribution icon next to Mass and set the parameters as shown below:
    Rock Type Library dialog
  5. Click OK.
  6. Set Density (kg/m3) = 2700.
  7. Click the Distribution icon Distribution icon next to Density .
  8. Set Distribution = Normal and Std. Dev: = 50, and leave 3x std. dev. selected.
  9. Click OK.
  10. Click the Smooth Shapes button to open the Smooth Shapes dialog.
    Smooth Shapes dialog
  11. In the Available Shapes list, select Square and Pentagon.
  12. Click OK in the Smooth Shapes dialog.
  13. Click OK in the Rock Type Library dialog.

1.4 DEFINE SEEDER

Next we'll define a Point Seeder to specify the initial conditions of the falling rocks, using the Add Point Seeder option and the Seeder Properties dialog.

  1. Select: Seeder > Add Point Seeder Add Point Seeder icon .
  2. In the prompt line at the bottom-right of the application window, enter the coordinates (1, 44).
    The Seeder Properties dialog appears.
  3. Keep Seeder Name as Seeder 1 and set Number of Rocks = 100.
  4. Ensure both Small rocks and Large rocks are selected in the Rock Types list.
  5. Set Horizontal Velocity (m/s) = 3.
  6. Click the Distribution icon Distribution icon next to Horizontal Velocity and set Distribution = Normal and Std. Dev: = 0.4. Leave 3x std. dev. selected.
  7. Leave Vertical Velocity (m/s) and Rotational Velocity (m/s) as 0 with Distribution = None.
  8. Set Initial Rotation = 0 and set Distribution = Uniform.
    Seeder Properties dialog
  9. Click OK.

1.5 DEFINE SLOPE MATERIALS

Next we'll define slope materials using the Slope Material Library. For this tutorial, we'll keep the three default materials. To view the materials, open the library by selecting Slope Material Library on the toolbar or the Slope menu.

Slope Material Library icon Select: Slope > Slope Material Library

Slope Material Library dialog

  • Click Cancel to close the dialog.

1.6 ASSIGN SLOPE MATERIALS

Now we'll assign slope materials to the model according to the figure below:

Image of model with assigned slope materials

To assign materials:

  1. Select Assign Materials Assign Materials icon on the Slope menu or the toolbar.
    The Assign Materials dialog appears.
    Assign dialog
  2. In the dialog, click the material you want to assign.
  3. On the model, click the slope line segments to which you want to assign the material.
  4. Repeat the steps above until you have finished assigning materials to the model as shown.
  5. Close the Assign Materials dialog.

2.0 Results

Finally, we'll run the analysis. To do that, you must switch over to Results mode by clicking the Results button on the toolbar Results icon . You should see the figure below showing the rock paths on the slope. The Analysis Tools should also now be available on the toolbar and the main menu.

Image of model

2.1 ANIMATE PATHS

A very useful feature of RocFall is the ability to animate the path individual rocks on your model take as they fall using the Animate Result dialog.

To animate rock paths:

  • Right click on any rock path and select Animate Path Animate Path icon .

Observe how the rock shape travels down the slope. The gold paths represent the Large Rocks Rock Type.

Image of model

To cycle through each rock in the model and animate its path:

  1. In the Animate Result dialog, click through different rock paths using the forward arrow beside the rock ID number.
    The rock ID numbers can be used to differentiate the Large Rocks (50-99)from the Small Rocks (0-49).
  2. Click the Expand button in the dialog to display information about the current rock (i.e., rock shape and mass) as shown in the figure below.

Image of model

To view the contact points of a rock shape:

  • Right-click on the rock's path and select Display Contacts. Zoom in to the contact points to see them more clearly

Image of model

2.1.1 Rigid Body vs. Lump Mass Rock Paths

A frequently asked question for the Rigid Body analysis is, “why are the rock paths hovering above the slope??”

With the Rigid Body analysis method, it is important to note that the rock paths represent the path of the centroid of each rock shape. Therefore, the rock paths do not touch the slope, even when the rock shapes are in sliding or rolling mode along slope segments.

With the Lump Mass analysis method, since the rocks do not have a physical size, the paths overlap the slope segments when the rocks are in sliding or rolling mode.

2.2 GRAPH ENDPOINTS

Now we'll create a graph of the rock endpoint locations by selecting Graph Endpoints Graph Endpoints icon from the Graphs menu or from the toolbar. The horizontal axis of the Distribution of Rock Path End Locations graph is the x-coordinate of the slope and the vertical axis is the number of rocks that ended in the bin at that location.

To create the graph:

  1. Select: Graphs > Graph Endpoints Graph Endpoints icon.The Graph Endpoints dialog should appear.
  2. Set Data = Endpoint Location.
  3. Set Value = Number of Rocks.
  4. Set Number of Bins = 50.
  5. Set Paths to Plot = All Rock Paths.
  6. Graph Endpoints dialog

  7. Select Plot Data to generate the Distribution of Rock Path End Locations graph.
  8. Select Tile Horizontally on the toolbar or the Window menu.
  9. Click in the slope model and press F2 to Zoom All.
    You should see the following.

Image of model

By default, the Endpoints Graph plots the end locations of all rocks regardless of the rock type.

2.3 FILTER RESULTS

You can use the Filter Results dialog to filter results by rock type, rock shape, and other criteria. To open the dialog, select Filter Options on the toolbar or Results menu.

Filter Options icon Select: Results > Filter Options

  1. Under Available Filters, select Rock Type.
  2. In the Rock Type drop-down, select Small rocks and click OK.
    Filter Results dialog
  3. Image of model

  4. Click OK and view the Endpoints histogram with the filter applied.
  5. Distribution of Rock Path End Locations

    Now let's filter on Large rocks:

  6. Re-open the Filter Results dialog.
  7. Select Large rocks as the Rock Type as above.

Distributions of Rock End Locations dialog

The filtered results show that the small rocks have a broader distribution of endpoints and, on average, travel farther than the large rocks. However, since different rock shapes were used for the large and small rocks, this must be considered as well.

2.4 ENVELOPE GRAPHS

Now let's generate a Total Kinetic Energy graph using the Graph Data on Slope dialog.

Graph Data on Slope icon Select: Graphs > Graph Data on Slope

  1. In the dialog, set Data = Total Kinetic Energy.
  2. Set Paths to Plot = Paths with Selected Rocks.
  3. Leave both Small rocks and Large rocks selected.
    Graph Data on Slope dialog
  4. Click Plot Data.

You should see the following graph.

Total Kinetic Energy on Slope Maximum Value graph

NOTES:

  • Notice that Rock Types are separated into different series when they are plotted in the graph. To plot one series at a time, return to the Graph Data on Slope dialog to select only one rock type.
  • Since we are plotting Kinetic Energy, you can see that the energy of the Large rocks (red curve) is much greater than the Small rocks (blue curve) since the Large rocks are 10 times heavier on average.

This concludes the tutorial. You are now ready for the next tutorial, Tutorial 03 - Barriers and Collectors in RocFall.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee