The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

RocFall Quick Start

This tutorial is a simple introductory tutorial that helps you become familiar with the basic modeling and data interpretation features of RocFall. RocFall is a 2D statistical analysis program designed to assist with assessment of slopes at risk for rockfalls.

Topics Covered in this Tutorial:

  • Creating/editing slopes
  • Defining/editing seeders
  • Assigning slope materials
  • Animation tool
  • Analysis tools

Finished Product:

The finished product of this tutorial can be found in the Tutorial 01 Quick Start data file. All tutorial files installed with RocFall can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall main menu.

1.0 Creating a RocFall File

Start RocFall by selecting Programs > Rocscience > RocFall > RocFall from the Windows Start menu. RocFall automatically opens a new blank document, which allows you to begin creating a model immediately. If the RocFall application window is not already maximized, maximize it now so the full screen space is available for use.

Image of creating a RocFall file

2.0 Model

2.1 PROJECT SETTINGS

The Project Settings dialog is used to configure the main analysis parameters of the model. To open the dialog, select Project Settings on the toolbar or the Analysis menu. For the tutorial, we'll keep all the default parameters.

Project Settings icon Select: Analysis > Project Settings

2.1.1 Analysis Method

In RocFall there are two possible Analysis Methods to choose from in the Project Settings General tab: Lumped Mass and Rigid Body.

Project Settings dialog

  • The default method is Lump Mass. With the Lump Mass method, the rocks are assumed to be very small point masses with no physical size. We will be using the Lump Mass method for this tutorial.
  • The Rigid Body analysis method allows you to define rock shapes. Rock shapes are covered in later tutorials.

2.1.2 Engine Conditions

  • Select the Engine Conditions tab.

Project Settings dialog

Note the various control parameters. Once one of these conditions is met, the rock will stop moving. For more help on engine stopping conditions, see Engine Stopping Conditions Settings in RocFall.

  1. For this tutorial, leave the default settings.
  2. Click OK.

2.2 CREATING / EDITING THE SLOPE

In RocFall, the slope can be drawn either manually with the cursor using Add Slope or by inputting vertex coordinates using the Edit Boundary Coordinates dialog. Both options are on the Slope menu. In this tutorial, we are going to input coordinates to draw the slope.

NOTE: You must be in Design mode to draw or edit the slope geometry. To enable Design mode, select the Design icon Design icon on the toolbar.

  • To open the Edit Boundary Coordinates dialog:

Edit Coordinates icon Select: Slope > Edit Coordinates

Edit Boundary Coordinates table

In this dialog, you can use the tools at the top of the dialog to edit the datasheet. For example, you can add a new vertex to the slope by adding a row and entering the coordinates of the new vertex. You can either enter the coordinates shown below or use the Import function to import the coordinates from a CSV file.

NOTE: You can also use the dialog to export coordinates.

XX stdvYY stdv
0000
3.10-12.20
6.70-12.20
9.80-24.40
13.40-250
260-22.50

NOTE: In this analysis, the standard deviation for all the vertices is set to zero since we are not going to consider any probabilistic variation of the slope surface.

To import coordinates:

  1. Click Import at the bottom of the dialog.
  2. Select the CSV file and click Open.
  3. Click OK.
  4. Press F2 to Zoom All.
    The slope geometry should appear as shown below.
    Image of slope geometry

You can always open the Edit Boundary Coordinates dialog by right clicking on the slope and selecting Edit Slope Coordinates. You can also manually move vertices or delete them using right-click shortcuts. :

2.3 ADDING / EDITING SEEDERS

In RocFall, seeders determine the drop location for rocks. You add seeders to your model using the Add Point Seeder option on the toolbar or Seeder menu.

Add Point Seeder icon Select: Seeder > Add Point Seeder

You can place a seeder at a location using the cursor on the screen or by entering the coordinates in the prompt line. The prompt line is located at the bottom right of the RocFall application window and it is commonly used for entering coordinates while creating the slope geometry.

Image of model

  1. Enter 0.5, 0 in the prompt line.
    The Seeder Properties dialog should appear.
  2. In the dialog, select Group 1 from the rock type list on the left-hand side.
  3. Change Number of Rocks to 50.

You can also use this dialog to define the initial Velocity of each rock group. You can set the mean, standard deviation, and relative minimum and maximum for the initial velocity to get the desired distribution.

  1. Set the mean value for Horizontal Velocity to 1.5.
  2. Click the Distribution icon Distribution icon next to the value.
  3. Change Distribution to Normal.
  4. Set Std. Dev: to 0.15.
  5. Select the 3x std. dev. check box to automatically calculate the Rel. Min: and Rel. Max values to three times the entered standard deviation OR enter the values manually.
    Select Properties dialog
  6. Set Vertical Velocity = 0 and Rotational Velocity = 0, and leave Distribution for both set to None.
    For the Lump Mass method, the Initial Rotation is not applicable, so it is disabled (initial rotation is only applicable for rigid body rock shapes).
  7. Click OK.

NOTE: To edit a seeder after defining it, you can right-click it in the model to open the Seeder Properties dialog.

2.4 ROCK TYPES

Let's now look at the rock properties of the model. Rock properties are set up through the Rock Type Library dialog. To open the dialog, select Rock Type Library on the toolbar or the Seeder menu.

Rock Type Library icon Select: Seeder > Rock Type Library

Rock Type Library dialog

In this dialog, we can create different rock types (Groups) and define the Mass and Density of each one. You can also use the dialog to define rock Shapes if the Analysis Method = Rigid Body. Since we are using the Lump Mass method, rock shapes are not available.

  1. Leave the default settings for Group 1.
  2. Click OK.

2.5 DEFINING SLOPE MATERIALS

Next, let's define slope materials using the Slope Material Library dialog. To open the dialog, select Slope Material Library on the toolbar of the Slope menu.

Slope Material Library icon Select: Slope > Slope Material Library

Similar to the Seeder Properties dialog, the Slope Material Library dialog allows you to change the distribution type and the distribution parameters for each material. You can also add or remove materials.

Let's define three new materials:

  1. Click the Add button in the Slope Material Library dialog to create a new material type.
  2. Change the name of the new material to Type One and enter the properties given in the table below.
  3. Repeat steps 1 and 2 to define two more new materials named Type Two and Type Three. See the table below for their properties:
  4. NameNormal Restitution (mean | sd)

    Tangential Restitution (mean | sd)

    Friction (mean | sd)
    DistributionNormalNormalNone
    Type One0.5 | 0.030.9 | 0.0330 | 0
    Type Two0.4 | 0.030.9 | 0.0330 | 0
    Type Three0.3 | 0.030.9 | 0.0330 | 0
  5. When you are finished entering all of the properties, the dialog should look as follows:
  6. Slope Material Library dialog

  7. Click OK.

NOTE: For more help on these parameters, see RocFall Slope Material Library.

2.6 ASSIGNING SLOPE MATERIALS

You are now ready to assign the material properties to the slope using the Assign Slope Materials dialog. To open the dialog, select Assign Slope Materials on the toolbar or the Slope menu.

Assign Slope Materials icon Select: Slope > Assign Slope Materials

Assign dialog

  1. Select Type One on the list.
  2. Left-click on the first and third line segments from the left on the model to assign them the Type One material.
  3. Select Type Two and left-click on the second segment from the left.
  4. Select Type Three and left-click on the last two segments.
  5. Close the dialog.

The model should appear as follows:
Image of corresponding model

3.0 Results

To view analysis results in RocFall you must first switch to Results mode. To switch, select the Results Results icon icon on the tool bar. In this mode, the analysis tools appear on the main toolbar and the rock paths are shown on the slope.

The image below shows the results of 50 rock throws using the Lump Mass analysis method.
Image of model witht the results of 50 rock throws using the Lump Mass analysis method

3.1 ANIMATING ROCK PATHS

A very useful feature of RocFall is the ability to animate the path individual rocks on your model take as they fall using the Animate Result dialog. To open the dialog, select Animate Path on the toolbar or the Results menu.

To animate rock paths:

Animated Path icon Select: Results > Animate Path.


Image of model and Animate Results dialog

  1. In the dialog, click the Back and Forward arrows to cycle through each rock in the model (Rock ID) and play its animation.
    The rock path variability for this example, is generated by the statistical distributions we defined for the initial velocity of the rocks, and the slope material properties.
  2. Use the Speed setting to change the speed of the animation.
  3. Select the Auto Zoom on Rock check box to zoom in on the selected rock while watching the animation.
  4. Click Expand to view details of the selected rock and its animation.
  5. Close the dialog.

3.2 VISUALIZING RESULTS WITH GRAPHING TOOLS

RocFall has a number of graphing tools that allow you to visualize the results of the analysis. The tools are available on the toolbar and the Graphs menu. For this tutorial, we'll look at the following tools: Graph Endpoints, Graph Data on Slope, and Graph Distribution.

3.2.1 Graphing Endpoint Locations

Graphing the horizontal location of rock endpoints is one of the most common and easily understood results from a RocFall analysis.

To graph Location Endpoints:

Graph End Points icon Select: Graphs > Graph Endpoints

  1. Select Graph Endpoints on the toolbar or the Graphs menu. The Graph Endpoints dialog should appear.
  2. Set Data = Endpoint Location.
  3. Set Value = Number of Rocks.
  4. Set Number of Bins = 50.
  5. Set Paths to Plot = All Rock Paths.
  6. Graph Endpoints dialog

  7. Select Plot Data to generate the Distribution of Rock Path End Locations graph.
  8. Select Tile Windows on the toolbar (Tile Horizontally on the Window menu) to view the model (the Plan View) and the Distribution of Rock Path End Locations graph side-by-side.
  9. Right-click on the model to open the right-click menu.
  10. Select Zoom All (you can also press F2).

Distribution of Rock Path End Locations histogram

As you can see from the endpoint histogram, most rocks come to rest at the bottom of the slope, but a few have stopped on the upper bench.

NOTE: You can view information for the bars in the histogram (e.g., X-location, number of rocks) by hovering the cursor over the bars. Also note the graph distribution may be a bit different from the figure shown due to the random distribution of the rocks falling on the slope for each simulation.

3.2.2 Graphing Data on the Slope

Envelope graphs of rockfall results can be generated with the Graph Data on Slope option. Kinetic Energy (Total, Translational, and Rotational), Velocity (Translational and Rotational) and Bounce Height envelopes can be generated.

To graph Bounce Height on the slope:

Graph Data on Slope icon Select: Graphs > Graph Data on Slope.

  1. Select Graph Data on Slope on the toolbar or the Graphs menu.
    The Graph Data on Slope dialog should appear.
    Graph Data on Slope dialog
  2. Select Bounce Height as the Data to Plot.
  3. Change the Data to Plot Value to Max.
  4. Select Plot Data.

Note that the plot will appear in a new tab and you can switch back to the slope view tab to do other analyses. Bounce Height on Slope maximum Value plot

Note that you can also specify the Mean or a Percentile value to plot, since the Max is generally conservative.

3.2.3 Graphing Distributions

Distribution graphs show the distribution of results at a selected X-location (horizontal location) along the slope. Kinetic Energy (Total, Translational, and Rotational), Velocity (Translational and Rotational) and Bounce Height distribution graphs can be generated.

To graph the Translational Kinetic Energy distribution:

Graphs Distribution Icon Select: Graphs > Graph Distribution

  1. Select Graph Distribution on the toolbar or the Graphs menu.
    Distribution Graph dialog
  2. In the Distribution Graph dialog, select Translational Kinematic Energy as the Data to Plot.
  3. Leave the other settings as is.
  4. Select Plot Data.

The results appear in a new tab as a split view as shown.

Image of results as a split view

As you click on different locations on the slope model at the bottom of the split view, the chart above will update with the distribution results corresponding to the indicator location. You can click the mouse or click and drag the vertical location indicator to update the graph results.

3.2.4 Exporting Graph Results to Excel and the Clipboard

You can view the data from any graph you generate in Microsoft Excel by selecting Export to Excel on the File menu or by right-clicking on the plot area and selecting Plot in Excel

You can also right-click any plot area and select Copy Data to copy the raw data used to generate graphs to the Windows Clipboard. From the Clipboard, the raw data can be pasted into word processing or spreadsheet programs, for further analysis, or report writing.

This allows you, for example, to perform custom analyses that are not available with RocFall. For instance, you could copy the raw data associated with the rock endpoints into your spreadsheet, sort the data and fit an unusual probability distribution to the data.

3.3 REPORT GENERATOR LISTING OF MODEL PARAMETERS

The RocFall Report Generator displays a summary of all RocFall model parameters and summarized results in its own independent app. This includes:

  • Slope geometry
  • Slope materials
  • Seeder properties and rock types
  • Simulation parameters
  • Barrier and collector properties
  • Summary reults*
  • Generated path details and rock geometries*
  • Summary path results*
  • Barrier and collector impact results*
  • Barrier design reports*
  • Added views*

Note: Items with the astericks(*) are only included when in Results mode. Barrier design reports and added views can be added to the report manually by selecting View > Add View to Report or from the right click menu.

To open the Report Generator:

Report Generator icon Select: Analysis > Report Generator

The Report Generator information can be copied to the clipboard using the options in the right-click menu. From the Clipboard, the information can be pasted into word processing programs for report writing.

Note: More details can be found under the Report Generator topic.

3.4 SAVING THE MODEL

Save icon Select: File > Save

Enter the name QuickTutorial for our file.

This concludes the tutorial. You are now ready for the next, tutorial, Tutorial 02 - Rock Shapes in RocFall.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee