The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Polygonal Rock Shapes

This tutorial demonstrates RocFall's ability to define polygonal rock shapes with corners.

Topics Covered in this Tutorial:

  • Polygonal rock shapes
  • Smooth vs. Polygon comparison
  • Endpoint graphs

Finished Product

The finished product of this tutorial can be found in the Tutorial 09 Polygonal Shapes data file. All tutorial files installed with RocFall can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall main menu.

1.0 Model

Let's start by opening the file for the tutorial:

  • Select: File > Recent Folders > Tutorials Folder and open the Tutorial 09 initial file.

You should see the following model.

Image of model

This model already has all slope properties defined except for Crest Loss.

2.0 Rock Shapes

2.1 ROCK TYPE LIBRARY

Next we'll look at the options for creating rock shapes in the Rock Type Library.

  1. Select Rock Type Library Rock Type Library icon on the toolbar or the Seeder menu.
    Rock Type Library dialog
  2. Notice that there are separate options for selecting Smooth Shapes or Polygons:
    • The Smooth Shapes option is exactly equivalent to the rigid body shapes available in earlier versions of RocFall. These are also referred to as Fourier Shapes due to their mathematical formulation.
    • The Polygons option allows you to choose from pre-defined regular polygons (triangle to octagon) or to define custom shapes.

NOTE: In this example file, we have created two groups, one for smooth shapes and one for polygons. This was done for the purpose of comparing results with the filter options. However in general, you may combine smooth shapes and polygons in the same “group”, you do not have to assign them to separate groups.

  1. Make sure smooth shapes is selected in the Rock Type list.
  2. Click the Smooth Shapes button and note that we've selected all the available smooth shapes.
    Smooth Shapes dialog box
  3. Click Cancel to close the dialog.
  4. Select polygons in the Rock Type list.
    Rock Type Library dialog
  5. Click the Polygons button and note that we've selected all available pre-defined polygons.
    Polygons dialog
  6. Click Cancel to close the dialog.
  7. Click Cancel again to close the Rock Type Library.

2.2 PATH RESULTS

Now we'll switch to Results Mode to view the resulting rock paths. Since the seeder is set to throw 100 rocks, this should generate about 50 smooth shapes and 50 polygons.

  • Click Results Results icon on the toolbar

Image of model

2.3 GRAPH ENDPOINTS

Next we'll generate an Endpoints graph to view the distribution of rock path end locations.

  1. Select Graph Endpoints Graph Endpoints icon on the toolbar or the Graphs menu. The Graph Endpoints dialog should appear.
  2. Set Data = Endpoint Location.
  3. Set Value = Number of Rocks.
  4. Set Number of Bins = 50.
  5. Set Paths to Plot = All Rock Paths.
  6. Graph Endpoints dialog

  7. Select Plot Data to generate the Distribution of Rock Path End Locations graph.

Distribution of Rock Path End Locations graph

2.4 FILTER ROCK TYPES

Now let’s use the filter options to see the effect of rock shape. We'll start by filtering on smooth rocks.

  1. With the Endpoints graph in view, select Filter Results/Options Filter Results/ Options icon on the toolbar or Results menu.
    You should see the Filter Results dialog.
  2. Click Rock Type.
    Filter Results dialog
  3. In the Filter Options popup, select Smooth Shapes as the Rock Type and click OK.

The endpoint graph should now look as follows:

Image of endpoint graph

Now we'll filter on Polygons.

  1. With the Endpoints graph in view, select Filter Results/Options Filter Results/Options icon on the toolbar or Results menu.
  2. In the Filter Results dialog, click the Clear Filter button.
  3. Click Rock Type.
  4. In the Filter Options popup, select Polygons as the Rock Type and click OK.
    Filter Results dialog
  5. Click OK.

The endpoint graph should now look as follows:

Endpoint graph

If you compare the endpoint graphs for smooth shapes and polygons, you can see that the distributions are different. The polygons have a more dispersed distribution, and some of them come to rest on the upper slope. In comparison, all of the smooth shapes have come to rest on the bottom sections of the slope model.

This is just a simple quick demonstration of how to assign rock shapes and compare results. You are encouraged to experiment further with different types of shapes (smooth and polygon) to see the effect on results for various types of slope models and input parameters.

3.0 Custom Polygons

In addition to the pre-defined polygons, you can also define custom polygonal rock shapes.

3.1 DEFINE CUSTOM POLYGON

  1. Close the graph view.
  2. Select Design Design icon on the toolbar to switch to Design Mode.
  3. Select Rock Type Library Rock Type Library icon on the toolbar or the Seeder menu.
  4. Select Polygons in the Rock Type list.
    Rock Type Library dialog
  5. Click the Polygons button.
    Ploygons dialog
  6. Select the Custom Polygon 1 check box at the bottom of the Available Shapes list.
  7. Select Custom Polygon 1 on the list and click the Pencil icon Pencil icon below the list.
  8. In the Custom Polygons dialog, define a rock shape by entering the coordinates shown below.
    Custom Ploygons dialog
  9. Click OK twice.
  10. Back in the Rock Type Library, select Custom Polygon on the list.
  11. Click the Smooth Shapes button, clear all the check boxes in the Smooth Shapes dialog and click OK.
  12. Click the Polygons button, clear all the check boxes in the Polygons dialog except for Custom Polygon 1.
    Polygons dialog
  13. Click OK in both dialogs.

3.2 VIEW PATH RESULTS

Now we'll view results, first changing the Number of Rocks to 150 and selecting the custom polygon we just created.

  1. In the slope model, right-click the seeder (the blue cross at the top of the model).
  2. In the popup menu, select Seeder Properties.
  3. Set Number of Rocks = 150.
  4. Select Custom Polygon in the Rock Types list.
    Seeder Proerties dialog
  5. Click OK.
  6. Select Results Results icon on the toolbar.

You should see the following rock paths.

Image of rock paths model

3.3 FILTER RESULTS

Next, filter results so you see only the custom polygon paths and endpoints.

  1. Select Results > Filter Options Filter Options icon .
  2. In the Filter Results dialog, click Shape under the Available Filters.
  3. In the Filter Options popup, select Custom Polygon as the Shape and click OK twice.

You should see the following filtered paths and endpoints.

Image of filtered paths and endpoints

Compare the endpoint distributions for the custom polygon versus the smooth shapes and regular polygons.

Distribution of Rock Path End Locations graph

3.4 USE EXACT SIZE

In the Custom Polygons dialog, you will notice a check box for Use Exact Size.

Custom Polygons dialog

This option allows you to define the actual size and shape of a rock using real coordinates (e.g., obtained from laser scanning). In conjunction with the rock weight, this allows you to define rocks of a specific shape and weight corresponding to actual rocks observed on a slope.

NOTE: If you do NOT use the Use Exact Size option, the rock size is automatically scaled according to the rock weight so the shape is preserved but the actual size is determined by the program. The scaling is done in such a way as to obtain a rock with approximately the same in-plane and out-of-plane dimensions.

This is left as an optional exercise to experiment with.

This concludes the tutorial. You are now ready for the next tutorial, Tutorial 10 - Advanced Friction in RocFall.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee