The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

Barriers and Collectors

This tutorial provides an introduction on how to add Barriers and Collectors to a RocFall model and interpret the results.

Topics Covered in this Tutorial:

  • Adding barriers and collectors
  • Graphing barrier results
  • Generating a Barrier Report
  • Barrier Sensitivity analysis
  • Report Generator

Finished Product:

The finished product of this tutorial can be found in the Tutorial 03 Barriers and Collectors data file. All tutorial files installed with RocFall can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall main menu.

1.0 Model

1.1 OPEN THE TUTORIAL FILE

Let's start by opening the file for the tutorial:

Select: File > Recent Folders > Tutorials Folder and open the Tutorial 03 Initial file.

Image of Tutorial 03 Intial file

This file has all geometry and properties already pre-defined, except for the barrier and collector. File properties include:

  • Rigid Body Analysis
  • A single rock type and shape (sphere)
  • Single slope material with statistical variability of Normal coefficient of restitution
  • Point seeder with statistical variability of initial velocity
  • Number of rocks = 50

Note that the finished version of this tutorial is Tutorial 03 Barriers and Collectors.

1.2 BARRIER OVERVIEW

A barrier in RocFall is a line segment with one end on the slope surface, which can be placed anywhere along the slope to alter the paths of the rocks as they travel down the slope. Barrier properties include:

  • Capacity (option to specify as infinite)
  • Max Height
  • Min Height
  • Free Border
  • Max Elongation
  • Manufacturer

NOTE: Any number of barriers can be added to the slope. Barriers, however, cannot cross other barriers and cannot cross slope segments.

Let’s first look at the results with no barrier.

Results icon Select the Results mode to run the analysis. You should see the following:

Image of model

1.3 ADD BARRIER

Now let's add a barrier.

  1. Select the Design Mode Design icon on the toolbar.
  2. Select Add Barrier Add Barrier icon on the toolbar or the Barriers menu.
    The first point of a barrier line segment must always be on an existing slope segment. The cursor appears as a cross when moving alone the slope; this marker indicates the point on the slope nearest the cursor location and helps when adding the first barrier vertex graphically.
  3. Enter the following coordinates in the prompt line in the bottom right of the application window.
    • Enter starting point on the slope line: (15, -25)
    • Enter barrier height or endpoint: (15, -17)
  4. The barrier is drawn on the slope and the Define Barrier dialog appears. Note that the barrier Height and Inclination can be changed in this dialog.

  5. Click on the button to the right of Barrier Property.
    The Barrier Properties dialog appears.
    Barrier Properties dialog
    The Default Barrier material in RocFall is the Custom barrier (Fence Model) with Barrier Capacity = Infinite. This is the barrier we’ll use for this tutorial. In the Barrier Properties dialog, you can also specify a barrier capacity and elongation or choose from a list of Predefined Fence Models. Note that Fence Properties Elongation has no effect on the analysis.
  6. Click OK in the Barrier Properties dialog.
  7. Click OK in the Define Barrier dialog.

2.0 Results

Now let's run the analysis and view results.

Results icon Select the Results mode to run the analysis.

Image of model

Notice that all the rocks are stopped by the barrier.

Right click anywhere blank (without any elements) in the view and select Add View to Report or go to View > Add View to Report.

Set View Name dialog

Enter a new view name or keep the default view name. Select OK.

2.1 ANIMATE ROCK PATHS

A very useful feature of RocFall is the ability to animate the path individual rocks on your model take as they fall using the Animate Result dialog.

To animate rock paths:

  • Right click on any rock path and select Animate Path Animate Path icon .

Image of model

Notice that, when a Rigid Body rock shape (in this case a sphere) hits a barrier and stops, the rock stops when the centroid of the shape intersects the barrier. The radius or size of the rock is not accounted for when a rock shape collides with a barrier; only the centroid of the shape is used to determine the intersection, shown by the final position of the rock on the barrier.

  • Close the Animate Result dialog.

NOTE: When a rock hits a barrier in RocFall, the rock either STOPS at the barrier or goes THROUGH the barrier (with reduced energy), depending on the capacity of the barrier and the energy of the rock. Rocks do not bounce off fence barriers in RocFall.

2.2 GRAPH ENDPOINTS

Now we'll create a graph of the rock endpoint locations by selecting Graph Endpoints Graph Endpoints icon from the Graphs menu or from the toolbar.

Graph Endpoints icon Select: Graphs > Graph Endpoints

In the Graph Endpoints dialog:

  1. Set Data = Endpoint Location.
  2. Set Value = Number of Rocks.
  3. Set Number of Bins = 50.
  4. Set Paths to Plot = All Rock Paths.
  5. Graph Endpoints dialog

  6. Select Plot Data to generate the Distribution of Rock Path End Locations graph.
  7. Right-click in the graph and select Toggle End Reasons.

The single rock that does not hit the barrier bounces just in front of the barrier without touching it and settles at the lowest vertex in front of the barrier.

Distribution of Rock Path End Locations graph

Right click anywhere in the chart and select Add View to Report or go to Chart > Add View to Report.

Enter a custom view name or keep the default view name. Select OK.

Image of model

2.3 GRAPH BARRIER RESULTS

For each barrier in your model, you can plot the following graphs for rocks that strike the barrier:

  • Total Kinetic Energy
  • Translational Kinetic Energy
  • Rotational Kinetic Energy
  • Translational Velocity
  • Rotational Velocity
  • Impact Along Height
  • Impact Angle

Let's first graph Impact Along Height, using the Graph Barriers and Collectors dialog. To open the dialog, select Graph Collectors on the toolbar or Graph Barriers/Collectors on the Graphs menu.:

Graph Barriers/Collectors icon Select: Graphs > Graph Barriers/Collectors

  • In the dialog, select Impact Along Height under Data to Plot.
  • Select Histogram Plot as the Graph Type.
  • Graph Barriers and Collectors dialog

  • Click Graph.
    The impact locations are plotted in terms of the distance along the barrier, starting at 0 at the first barrier vertex.
  • Impact Along Length on Barrier 1

    Right click anywhere on the chart and select Add View to Report or go to Chart > Add View to Report.

    Enter a new view name or keep the default view name. Select OK.

    Similarly, you can use the dialog to plot graphs of Total Kinetic Energy and Translational Velocity. To view all the graphs generated so far, you can tile the views by selecting Tile Windows on the toolbar. You should see the figure below.

    Image of various graphs

    After analyzing the plots, close the three graph views, maximize the Slope view, and switch to Design mode.

    3.0 Data Collectors

    A data collector in RocFall is simply a line segment that gathers information about rocks passing through the segment while falling down the slope. It is not a physical entity. Data collectors record the velocity, kinetic energy, and location of all rocks that pass through as they travel down the slope.

    NOTES:

    • Unlike barriers, data collectors do not affect the movement of the rocks in any way.
    • Data collectors do not have any properties associated with them (other than the endpoints defining their location) and do not have any directionality (i.e., it doesn’t matter which end is the starting point and which is the ending point).
    • There is no restriction on the number of data collectors or where they can be placed. They may intersect or cross the slope, barriers, or other data collectors at any location.

    3.1 ADD DATA COLLECTOR

    You add a data collector using the Add Collector option.

    Select: Collectors > Add Data Collector

    1. Select Add Collector Add Collector icon on the toolbar or the Collectors menu.
      The cursor turns into cross hairs.
    2. Move the cursor near the lowermost slope vertex at (13.4, –25).
      The cursor should snap to the exact location of the vertex.
    3. Click the left mouse button to enter this as the first point of the data collector.
    4. Enter the second point through the prompt line: (13.4, -10) .

    The model should look as follows (note that the text boxes were added with the Text Box option in the Tools menu):

    Image of model

    3.2 RESULTS

    Results Select the Results mode to run the analysis.

    Image of model

    Note that the data collector has no effect on the rock paths.

    3.3 GRAPH DATA COLLECTOR RESULTS

    Now let's graph the data collector results, using the Graph Barriers and Collectors dialog.

    1. Right-click on the collector and select Graph Collector Data in the popup menu.
    2. Select Collector 1 under Barriers and Collectors.
    3. Select Impact Along Height under Data to Plot.
    4. Select Histogram Plot as the Graph Type.
    5. Change Number of Bins to 30.
    6. Graph Barriers and Collectors dialog box

    7. Click on Graph.
    8. Tile the views.

    Image of

    NOTE: To plot the impact locations in terms of the absolute Y-coordinates of the model, select Vertical Impact Location instead of Impact Along Length in the graph dialog.

    It is interesting to note the Total Number of Rocks on Collector 1 = 52 listed at the bottom of the histogram plot, even though the Number of Rocks Thrown = 50. This is because data collectors register a rock every time it passes through a collector. If a rock bounces through a collector multiple times, each intersection is added to the total number of rocks for the collector. In this case, the difference is due to the single rock that did not hit the barrier and that bounces a few times through the collector.

    3.4 DISTRIBUTION GRAPHS VS. COLLECTOR GRAPHS

    In most cases, data collection is required along vertical lines at given X locations along the slope. For this purpose, the Graph Distribution option in the Graph menu allows the following plots to be created:

    • Bounce Height
    • Total Kinetic Energy
    • Translational Kinetic Energy
    • Rotational Kinetic Energy
    • Translational Velocity
    • Rotational Velocity

    These graphs allow the user to quickly view distributions anywhere along the entire extent of the slope (see the Tutorial 01 - RocFall Quick Start for details). Distribution Graphs are actually derived from a series of equally spaced “invisible” vertical data collectors automatically generated by RocFall. The spacing of these collectors is determined by the Number of Bins in the Graph Distribution dialog and the total X extent of the slope.

    In most cases, the Distribution Graphs provide the user with the desired data. The Data Collectors option described in this tutorial should only be necessary in the case when you want to determine information (i.e., velocity, kinetic energy, vertical location, horizontal location) about the rocks passing through a specified location.

    4.0 Barrier Report

    A very useful feature of the RocFall barrier analysis is the ability to generate a Barrier Report. Based on the barrier input parameters and design criteria, this allows you to determine if a barrier meets the necessary design requirements.

    The Generate Barrier Report option can be found in the Results menu or the right-click menu for a barrier. See RocFall Barrier Report Input and RocFall Barrier Report Output for more help.

    Barrier design reports can also be added to the report generator from the right click pop-up menu or from the menu Edit > Add to Report .

    5.0 Barrier Sensitivity Analysis

    Barrier Sensitivity analysis allows the user to input ranges of values for a barrier location, height, inclination, or capacity and automatically carry out a sensitivity analysis and graph results. For details, see Tutorial 07 - Barrier Sensitivity Analysis in RocFall.

    6.0 Report Generator

    Report Generator is the new reporting tool that replaces Info Viewer to provide more flexibility. So far we have added 3 different views to the report in the previous steps.

    Note: Some sections and saved views are tied to run results. If results are cleared or unavailable, those items will not show up in the report. See the Report Generator topic for more details.

    6.1 Add View to Report

    With the Add Views feature, you can add specific views of your computed model to your report. In the respective view that you want to add to the report:

    1. Select Analysis (model view), Chart (chart view) or Edit (barrier report) > Add View to Report from the menu or the right-click menu. The current view/report will be added to your report and can be seen when we open the Report Generator later.Set View Name dialog
    2. Enter a name for your view.
    3. Click OK.

    6.2 Manage Report Views

    The Manage Report Views dialog allows you to review the views you have added to your report, add further details, and arrange the order of the views. To open the dialog:

    1. Select View/Chart > Manage Report Views from the menu in the model/chart view. A new dialog will appear.Manage Report Views dialog
    2. Use the check boxes to select what views to add to your report.
    3. Use the Up and Down buttons to change the order of the views.
    4. To add a description to your view, select the view in the list of views and enter the description in the Description box.
    5. Click OK to close the dialog.

    You can rename the views (to be shown in the report) and reorder them in this dialog. Images are rotated by default in the report (to be shown in the landscape orientation). Uncheck Rotate image in report for portrait orientation of the specific image.

    6.3 Launching the Report Generator

    Once you have added your views, it is now time to open the Report Generator. To launch the Report Generator:

    1. Select Analysis > Report Generator from the menu or click on the Report Generator icon Report Generator icon in the tool bar.

    A new window will open. Here is where you will see all the various options for customizing your report.

    Report Generator dialog

    6.4 Navigating the Report

    When you launch the Report Generator, the details of your project are automatically populated into the report. A table of contents and cover page are automatically created as well.

    6.4.1 NAVIGATION BAR

    Use the Navigation Bar on the left of the screen to quickly navigate to the different sections of the report. You will note that the added Views have been added to the end of your report under the Report Views section.

    Navigation dialog

    • Use the Document Map tab to find specific sections.
    • Use the Pages tab to navigate to specific pages.
    • You can also use the Search Field to search for specific sections of your report.

    Note: Clicking on a section in the Table of Contents will also take you to that section of the report.

    6.4.2 SECTION VISIBILITY

    The Report Generator allows you to select which sections you wish to include in the report. By default, all sections are included. To add or remove a section from your report:

    1. Click on the Section Visibility button in the tool bar. The list of sections will appear. Section Visibilty icon
    2. Un-check the boxes next to sections you do not want included in the report.Section Visibility dialog
    3. When you’re done, click on the Section Visibility button again to close the menu.

    6.5 Adding Images and Comments

    The Report Generator lets you add images and comments to any section of the report.

    6.5.1 IMAGES

    To add an image to your report:

    Images button

    1. Click the Images button in the tool bar. A new dialog will appear.Images dialog
    2. Click the +Add button to begin adding images.
    3. Use the Section drop down to select the section where you want to add the image.
    4. Click Insert to select file to add.
    5. Repeat the above steps to add more images.
    6. If you wish to remove an image, click on the line you wish to remove and then click Delete.
    7. Click OK to close the dialog.

    6.5.2 COMMENTS

    To add comments to your report:

    Comments button

    1. Click on the Comments button in the tool bar.Comments dialog
    2. Click the +Add button to begin adding comments.
    3. Use the Section drop down to select the section where you want to add the comment.
    4. Click Insert. A window will appear where you can enter your comment.
    5. Click OK.
    6. Repeat the above steps to add more comments.
    7. If you wish to remove a comment, click on the line you wish to remove and then click Delete.
    8. Click OK to close the dialog.

    6.6 Page Breaks

    The Page Breaks button allows you add page breaks between all major sections in the report.

    Page breaks button

    Toggle the Page Breaks button on or off to add or remove the page breaks between each section.

    6.7 Header & Footer

    A Header and Footer are automatically added to your report with relevant content including the Date, Project Name and other details.

    To customize the content in your header and footer:

    Header and footer icon

    1. Click on the Header & Footer icon. A dialog will appear.Header and footer dialog
    2. Click on the Header or Footer tab to select what section edit.
    3. Use the radio buttons to decide the number of columns you wish to include in your header or footer.
    4. Use the drop down menus to change what content appears.
    5. Click Apply to apply the changes to your report.
    6. Click Reset to Default to reset the header and footer to the default options.

    6.8 Cover Page options

    When you launch the Report Generator a Cover Page is automatically created for your report.

    To edit the contents of the Cover Page:

    Cover page button

    1. Click on the Cover Page button in the tool bar. A new dialog will appear.Cover page dialog
    2. Use the check boxes on the left to select what elements to include on the cover page.
    3. Use the drop down menus to select the location and alignment of images.
    4. Click the Choose File... button to change the logo and/or cover image and select your own image file.
    5. You can edit the text in any of the three text boxes.
    6. Once you have made the necessary changes, click OK to close the dialog and apply your changes.

    6.9 Export Options

    When you have completed customizing your report, you have the option to export a digital copy of your report.

    To export your report:

    1. Click on the Export button in the tool bar. Export button
    2. Select PDF. A new dialog will appear.Export Document dialog
    3. Select the File path for your report.
    4. Enter any additional details you wish to include by clicking More Options.
    5. Click OK to finish exporting the file.

    This concludes the tutorial. You are now ready for the next tutorial, Tutorial 04 - Vertex Variation in RocFall.

    Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee