Expert Modelling: Hands-on help from Rocscience Engineers. Register Here
 

Search Results

15 - Stereonet Plot View Templates

This tutorial demonstrates the use of Stereonet Plot View Templates when working with Stereonet Plot Views in Dips. While working in a Stereonet Plot View, the active plot view's Plot Options and Display Settings can be saved to your local machine and loaded (i.e. applied) conveniently to other Stereonet Plot Views in the current Dips file or any other Dips file.

Topics Covered in this Tutorial:

  • Plot Options
  • Display Settings
  • Saving Plot View Templates
  • Loading Plot View Templates
  • Managing Plot View Templates

Finished Product:

The finished product of this tutorial can be found in the Tutorial 14 Plot View Templates.dips8 file, located in the Examples > Tutorials folder in your Dips installation folder.

1.0 Model

If you have not already done so, run the Dips program by double-clicking the Dips icon in your installation folder or by selecting Programs > Rocscience > Dips > Dips in the Windows Start menu.

If the Dips application window is not already maximized, maximize it now, so that the full screen is available for viewing the model.

Dips comes with several example files installed with the program. These example files can be accessed by selecting File > Recent Folders > Examples Folder from the Dips main menu. This tutorial will use the Exampleset.dips8 file to demonstrate the Stereonet Plot View Template feature of Dips.

  1. Select Recent Folders > Example Folder Open Folder Icon option from the File menu .
  2. Open the Exampleset.dips8 file. Since we will be using the Exampleset.dips8 file in other tutorials, save this example file with a new file name without overwriting the original file.
  3. Select Save As Save As Icon option from the File menu.
  4. Enter the file name Tutorial 15 Plot View Templates and Save the file.

You should see the Stereonet Plot View as shown in the following figure.

NOTE: If the example file has been previously opened and saved, the screen may show a different view or plot, since Dips saves the most recent view state when a file is saved.

If you do not see the plot below, then use the Sidebar Plot Options to view pole vectors and contours on the Stereonet.

Stereonet Plot View

2.0 Plot Options and Display Settings

Let's make custom selections for the way we want the Stereonet to appear.

  1. Set the Stereonet Plot view as the active view.
  2. Under Sidebar Plot Options:
    1. Select Planes > Grid Data.
    2. Select Object Visibility > Global Mean.
    3. Select Object Visibility > Global Best Fit.
      Plot Options
  3. Under Sidebar Display Settings:
    1. Set Cross Hairs = Show.
    2. Set Tick Spacing = 1°.

Display Settings

The stereonet should appear as follows:

Stereonet Plot View

3.0 Plot View Templates

3.1 SAVING TEMPLATES

Dips is capable of saving up to 10 Plot View Templates to your local machine.

To save the current Plot Options and Display Settings to a Plot View Template:

  1. Set the current Stereonet Plot View as the active view.
  2. Select Save Template from the View menu.
  3. In the Add View Template dialog:
    1. Enter View Template Name = All Planes.
      Add View Template Dialog
      By default, the saved Plot View Template is named New View Template 1 (2, 3, ...).
  4. Select OK to save the current Plot View Template.

NOTE: The Dips template file is saved to the Dips install directory on your local machine. Any previously saved templates will be made available when opening a Dips file on this local machine.

3.2 LOADING TEMPLATES

To demonstrate that we can load Plot Options and Display Settings from a template:

  1. Select New Pole Vector Plot New Window Icon from the toolbar or Window menu to generate a new default pole vector plot.
  2. The stereonet should only have pole vectors shown, with default Plot Options and Display Settings.

    Stereonet with Pole Vectors

  3. Select Load Template > All Planes from the View menu to instantly load the previously saved Plot Options and Display Settings to the active Stereonet Plot View.

The stereonet should appear as follows:

Stereonet Plot View

NOTE: Save Template and Load Template options apply to only the active Stereonet Plot View.

3.3 MANAGING TEMPLATES

You can rename, delete, import, or export Plot View Templates by using the View Template Manager dialog.

  1. Select Load Template > Manage Templates from the View menu.
  2. In the View Template Manager dialog:
    View Template Manager

To rename All Planes template:

  1. Select All Planes from the template list.
  2. Select the Rename button.
  3. Set the View Template Name = Example Template 1.
  4. Select OK in the Rename View Template dialog.

To export Example Template 1:

  1. Select Example Template 1 from the template list.
  2. Select the Export Export button button. A standard Save As dialog will appear allowing you to select the filename and directory to save the .dipssvt file.

To import a template to the current active Stereonet Plot View:

  1. Select the Import Import Button button. A standard Open dialog will appear allowing you to select the file and directory.
  2. If a valid template is opened, the Template will be added to the template list and the Plot Options and Display Settings will be applied to the active Stereonet Plot View.

To delete Example Template 1:

  1. Select Example Template 1 from the template list.
  2. Select the Delete Delete Buttonbutton.

NOTE: Changes to saved templates (i.e., Rename, Import, Delete) are machine-specific and not Dips document-specific. A maximum of 10 templates can be saved to your local machine.

  1. Select OK to close the dialog.

This concludes the tutorial. You are now ready for the next tutorial, Tutorial 16 - Dips Import Wizard.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee