The Rocscience International Conference 2021 Proceedings are now available. Read Now
 

Search Results

2 - Creating a Dips File

This tutorial shows the steps required to create a typical Dips file. Starting with a new blank file, the file which was used for the Tutorial 01 - Dips Quick Start ( Example.dips8) is recreated.

Topics Covered in this Tutorial:

  • Global Orientation Format
  • Quantity Column
  • Traverse information
  • Extra Columns

Finished Product:

The finished product of this tutorial can be found in the Tutorial 02 Creating A Dips File .dips8 file, located in the Examples > Tutorials folder in your Dips installation folder.

1.0 Model

If you have not already done so, run Dips by double-clicking on the Dips icon in your installation folder. Or from the Start menu, select Programs > Rocscience > Dips > Dips.

If the Dips application window is not already maximized, maximize it now, so that the full screen is available for viewing the model.

Dips comes with several example files installed with the program. These example files can be accessed by selecting File > Recent Folders > Examples Folder from the Dips main menu. This tutorial will use the Example.dips8 file to demonstrate the basic plotting features of Dips.

  1. Select Recent Folders > Example Folder Open Folder Icon option from the File menu .
  2. Open the Example.dips8 file.

You should see the Stereonet Plot View shown in the following figure.

NOTE: If the example file has been previously opened and saved, the screen may show a different view or plot, since Dips saves the most recent view state when a file is saved).

Model Stereonet Plot View

Switch to the Grid Data view:

Select the Grid Data view tab at the bottom left of the view.

Model Grid Data view

Notice that this file contains the following columns:

  • Two Orientation Columns
  • A Quantity Column
  • A Traverse Column
  • Three Extra Columns (spacing, type, surface)

When you have finished examining the Example.dips8 data, close the file, and we will discuss how to re-create this file from scratch.

2.0 Creating a New File

To begin creating a new Dips file:

  1. Select New New File Iconfrom the toolbar or the File menu.
  2. Select Save Save File Icon from the toolbar or the File menu.
  3. Enter the file name Tutorial 02 Creating A Dips File and save the file.

You will see the following blank Dips spreadsheet, which contains:

  • Two Orientation Columns
  • 100 rows

 Creating A Dips File

If you have not already, maximize the Grid Data view.

As you can see from the titles of the two Orientation Columns, the default Global Orientation Format for a new Dips file is DIP/ DIP DIRECTION. For this example, we need to change this to STRIKE/DIP (right hand rule). This is done through the Project Settings option.

3.0 Project Settings

When creating a new Dips file, you will generally need to use the Project Settings option before proceeding to enter data.

  1. Select Project Settings Project Settings Icon from the toolbar or the Analysis menu.
  2. The Project Settings dialog will appear. Project Settings General

For this example, we need to configure the:

  • Global Orientation Format
  • Declination
  • Quantity Column

3.1 GLOBAL ORIENTATION FORMAT

The Global Orientation Format in the Project Settings dialog determines how Dips will interpret the data in the two Orientation Columns.

For this example, most of our data is in STRIKE/DIP (right hand rule) format.

In the Project Settings dialog:

Set the Global Orientation Format = Strike (Right) / Dip in the dropdown.

NOTE: Mixed orientation formats can be combined in the same Dips file by using the optional Traverse Orientation Format, described later in this tutorial.

3.2 DECLINATION

In the Project Settings dialog:

Enter a Declination = - 5.5 degrees .

The Declination is typically used to correct for magnetic declination, but can be used to adjust to grid north.

NOTE: The declination is ADDED to all azimuth values, therefore a POSITIVE value corrects for EAST declination, and a NEGATIVE value corrects for WEST declination (which is the case in this example).

3.3 QUANTITY COLUMN

A Quantity Column in a Dips file allows you to record single data entries which refer to multiple identical features having the same orientation.

In the Project Settings dialog:

  1. Select the Quantity Column checkbox.



    Project Settings Dialog
  2. Select OK.

Note the following changes to the spreadsheet in the Grid Data view:

  • The titles of the two Orientation Columns are now Strike (Right) and Dip.
  • A Quantity Column has been added to the spreadsheet. For convenience, the Quantity Column values are initially set to 1 when the column is created. The user can enter higher values as necessary (e.g., 2, 3, 4, ...).

NOTE: The Grid Data rows are highlighted in pink and indicates "Invalid data after row 0. The rest of the rows will be ignored" in the Sidebar. This is because we have not yet fully defined the Orientation columns.

4.0 Traverses

Traverses are used to group data units; to weight the data to correct for measurement bias; and to process oriented core data.

To define Traverses:

Select Traverses from the Analysis menu (or through the Project Settings dialog).

The Traverse Information dialog will appear.

4.1 TRAVERSE TYPE

Seven Traverse Types are available in Dips:

  • Linear
  • Planar
  • Linear BH Oriented Core
  • Linear BH Televiewer
  • Curved BH Oriented Core
  • Curved BH Televiewer
  • Clinorule

See the Traverses topic for more information about Traverse Types in Dips.

4.2 ADDING TRAVERSES

The Example.dips8 file uses four Traverses: one Linear, two Planar, and one Linear Borehole Oriented Core.

We will create these as follows:

  1. Select the Linear Traverse Type.
  2. Select the Add Add Row Icons button.
  3. In the Add Rows dialog, enter Number of Rows to Add = 1. Select OK to add 1 row.
  4. In the first row of the Linear Traverses tab:
  5. Enter ID = 1.
  6. Set Data Format = Strike (Right) / Dip from the dropdown.
  7. Enter Trend = 120.
  8. Enter Plunge = 30.
  9. Enter Comments = Level 3,Stope 3.A,sublevel 310.
  10. Traverse Information Dialog

  11. Select the Planar Traverse Type.
  12. Select the Add Add Rows Icon button.
  13. In the Add Rows dialog, enter Number of Rows to Add = 2 . Select OK to add 2 rows.
  14. In the first row of the Planar Traverses tab:
  15. Enter ID = 2 .
  16. Set Data Format = Strike (Right) / Dip from the dropdown.
  17. Enter Orient1 = 100 .
  18. Enter Orient2 = 10 .
  19. Enter Comments = Level 5,Stope 5.D roof before shrinkage .
  20. In the second row of the Planar Traverses tab:
  21. Enter ID = 4 .
  22. Set Data Format = Dip / Dip Direction from the dropdown.
  23. Enter Orient1 = 10 .
  24. Enter Orient2 = 190 .
  25. Enter Comments = Level 5 Stope 5.D roof(aux data) .
  26. Traverse Information Dialog

  27. Select the Linear BH Oriented Core Traverse Type.
  28. Select the Add Add Rows Icon button.
  29. In the Add Rows dialog, enter Number of Rows to Add = 1. Select OK to add 1 row.
  30. In the first row of the Linear BH Oriented Core Traverses tab:
  31. Enter ID = 3 .
  32. Enter Orient1 = 20 .
  33. Enter Orient2 = 145 .
  34. Enter Orient3 = 120.
  35. Enter Comments = Level 5 Stope 5.D roof(aux data) .
  36. Traverse Information Dialog

  37. Select OK when all four Traverses have been defined.

4.3 TRAVERSE ID

The Traverse ID can be any alpha-numeric value. When you initially add Traverses, they are automatically assigned default ID codes based on the Traverse type. After Traverses have been added, you can change the ID to any user-defined alpha-numeric code.

Each Traverse must have its own unique ID.

4.4 DATA FORMAT

The Traverse Data Format is very important, because it allows you to combine mixed orientation formats in the same Dips file. Whenever the Traverse Data Format is different from the Global Orientation Format, Dips will interpret the orientation data for the Traverse according to the Data Format.

In this example:

  • Traverses 1 and 2 have the same data format as the Global Orientation Format: Strike (Right)/Dip.
  • Traverse 3 is a Linear BH Oriented Core Traverse. For oriented core Traverses, the Data Format is always Alpha / Beta, since orientations are measured in terms of local Alpha and Beta angles on the oriented core. See the Oriented Core Borehole Data topic for detailed discussion of oriented core Traverses.
  • Traverse 4 uses a different orientation format from the Global Orientation Format. In this case, the data on Traverse 4 is in Dip/Dip Direction format.

4.5 TRAVERSE FORMAT

The Traverse Format refers to the orientation of the Traverse itself. The orientations required to define the Traverse orientation depend on the Traverse Type, and may also depend on the Traverse Format.

  • Traverse 1 is a Linear Traverse. For a Linear Traverse, the Traverse Format is ALWAYS Trend/Plunge.
  • Traverse 2 is a Planar Traverse. For a Planar Traverse, the Traverse Format is the same as the Data Format, in this case Strike(Right)/Dip (i.e., Orient1 = Strike, Orient2 = Dip).
  • Traverse 3 is a Linear Borehole Oriented Core Traverse, which requires THREE orientations to define. See the Linear Borehole Oriented Core Traverses topic for details.
  • Traverse 4 is a Planar Traverse. In this case, the Data Format is Dip/DipDirection therefore the Orient1 and Orient2 values are also in Dip/DipDirection format (i.e., Orient1 = Dip, Orient2 = Dip Direction).

4.6 TRAVERSE COMMENT

Optional Comments can be added for each Traverse, to further identify / describe each Traverse.

You may inspect the original Example.dips8 file to view the comments added for these four Traverses.

4.7 TRAVERSE COLUMN

When you are finished entering the Traverse Information, you will see that a Traverse c olumn has been added to the spreadsheet in the Grid Data view, after the Quantity column.

The Traverse column is for recording the Traverse ID of each data unit. In this case the Traverse ID numbers are 1, 2, 3, and 4.

Also notice that the titles of the two Orientation Columns are now Orient 1 and Orient 2, instead of Strike (Right) and Dip. Since there are mixed orientation formats in this data file (remember that the Traverse Format for Traverse 4 is Dip / Dip Direction while the Global Orientation Format is Strike (Right) / Dip), the titles of the Orientation columns are simply Orient1 and Orient2, to avoid misinterpretation of the data.

Grid Data View - Traverse Column

NOTE: The Grid Data rows are highlighted in pink and indicates "Invalid data after row 0. The rest of the rows will be ignored" in the Sidebar. This is because we have not yet fully defined the Orientation columns.

5.0 Extra Column

In Dips, any columns AFTER the two mandatory Orientation Columns, and the optional Quantity and Traverse Columns (if present), are referred to a s Extra Columns.

Extra Columns can be used to store any other quantitative or qualitative data that you wish to record.

Recall that the Example.dips8 file used three Extra Columns:

  • SPACING
  • TYPE
  • SURFACE

Extra Columns are added to the Dips spreadsheet with the Add Column Add Column Icon option in the Edit menu.

Since Extra Columns can only be added AFTER the Orientation, Quantity and Traverse columns, in order for the Add Column Add Column Icon option to be enabled, the current highlighted spreadsheet cell must be either:

  • In an existing Extra Column, or
  • In the last of the Orientation, Quantity, Traverse, or Distance columns, as applicable.

In this case, since no Extra Columns currently exist:

  1. Click the mouse in the Traverse column. The Add Column option will be enabled.
  2. Select Add Column Add Column Iconoption from the Edit menu.
  3. In the Add Column dialog:
    1. Enter the Column Name = SPACING:







      Add Column Dialog
    2. Select OK to add the Extra Column to the Grid Data spreadsheet.

NOTE: The title of an Extra Column is always displayed in UPPERCASE.

Now let’s add the TYPE and SURFACE Extra Columns. An alternative way to add an Extra Column, is to RIGHT-CLICK on the title of an existing Extra Column, or the LAST of the Orientation, Quantity or Traverse columns, as applicable.

For example:

  1. Right-click the mouse on the title of the SPACING column which you just created.
  2. Select Add Column Add Column Icon option from the right-click menu.
  3. In the Add Column dialog:
    1. Enter the Column Name = TYPE.
    2. Select OK to add the Extra Column to the Grid Data spreadsheet.
  4. Right-click the mouse on the title of the TYPE column which you just created.
  5. Select Add Column Add Column Icon option from the right-click menu.
    1. Enter the Column Name = SURFACE.
    2. Select OK to add the Extra Column to the Grid Data spreadsheet.

You have now re-created all of the columns of the Example.dips8 file as shown below. You are now ready to start entering data.

Add Column

6.0 Entering Data

To conclude this tutorial, we will:

  • Open the Example.dips8 file and copy the data into our new file.
  • Generate contour plots for both files, and hopefully they will be identical!

To view the Example.dips8 file:

  1. Select Recent Folders > Examples Folder Open Folder Icon from the File menu.
  2. Open the Example.dips8 file and switch to the Grid Data view.
    1. In the Example.dips8 spreadsheet, click on the ID button at the upper left corner, to select the entire spreadsheet.
    2. Right-click the mouse anywhere in the Example.dips8 spreadsheet and select Copy Copy Icon.
    3. Use the tabs at the bottom of the view to switch to the Grid Data view of the new file. Click the mouse in the FIRST cell of the new spreadsheet (i.e., the Row 1, Orient 1 cell). Right-click and select Paste Paste Icon.
    4. The data from the Example.dips8 file should now be pasted into the new file.
    5. Drag the mouse from row 41 to 100. Right-click and select Remove Row(s) Remove Rows icon to delete the remaining rows after row 40.
  3. Let’s verify that we have correctly re-created the Example.dips8 file.

  4. Select the Contour Plot Contour Plot icon toolbar button. Compare this to the contour plot of the original Example.dips8 file.







    The plots should be identical for both files:
    • Maximum Density = 23.44%
    • Vector Count = 61/40 entries
  5.  Contour Plot

  6. Select the Terzaghi Weighting checkbox in the Sidebar for both contour plots, to view the weighted contours.







    The plots should be identical for both files:
    • Maximum Density = 26.77%
    • Vector Count = 102/40 entries

 Terzaghi Weighting

If the plots are not identical, examine the Project Settings and Traverse Information dialogs of the new file, and make sure they are the same as the Example.dips8 file. Also check that there are 40 rows of data in the new file, since the Example.dips8 file contains forty rows.

You may have noticed that we defined a Linear Borehole Traverse (in the Traverse Information dialog) but we did not actually enter any borehole data in the main Dips spreadsheet (i.e., Traverse ID = 3 is not used in the Traverse column, only ID numbers 1, 2 and 4 are used).

Oriented core borehole data is discussed in more detail in Tutorial 11 - Oriented Core and Rock Mass Classification.

That concludes the tutorial. You are now ready for the next tutorial Tutorial 03 - Sets (Add Set Window) in Dips.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee