RSWebinar: Designing Cost-Effective Ground Improvement Solutions with Settle3 | June 7th, 2023 Register Now
 

Search Results

Selecting

For many options in RS3, you are required to select aspects of an entity on the screen while creating and editing the model, for example:

  • Geometry, for editing, applying loads, etc.
  • Support (e.g. bolts, liners, piles) for editing
  • Loads

Here are some useful tips to remember when selecting.

General Rules

When an entity is selected, it will temporarily change colour or line style to indicate that it is selected. For example, selecting any geometry changes the selected vertex, edge, surface or entity to an orange colour.

Selection Mode

There are several Selection Mode options available in the toolbar or Edit menu you can use to capture the desired entity, face, edge or vertex. Only Geometry Entities can use the face, edge or vertex selection options.

  • Entity Selection Entity Selection icon : Select the entire entity.
  • Faces Selection Faces Selection icon: Select a plane on a Geometry Entity .
  • Edges Selection Edges Selection icon : Select a line on a Geometry Entity .
  • Vertices Selection Vertices Selection icon : Select a point on a Geometry Entity.
  • Face, Edge, Vertex Selection Face, Edge, Vertex Selection icon : Select the closest face, edge or vertex to your cursor. If you are not hovering over a Geometry Entity, the selection will default to Entity selection mode. If you double-click a Geometry Entity you will select the entire Entity .
  • Disable Selection Disable Selection icon : no further item in the program will be selected, but you will not lose the previously selected items.

Clear Selection

You can also clear all selections using the Clear Selection Clear Selection icon option in the toolbar or Edit menu.

Selection Region Mode

There are several Selection Region Mode Image options available in the toolbar or Edit menu to select groups of desired entities, faces, edges or vertices by drawing a selection region around them using the mouse. Only Geometry Entities can use the face, edge or vertex selection options. To draw a selection region, do the following:

  1. Hold down left-click and drag the mouse to draw a region.
  2. Release the left-click when you have finished selection.
  3. Based on the Selection Mode, the entities, faces, edges and/or vertices that touch the highlighted region will be selected.

The regions can be drawn as the following shapes:

  • Rectangle Image: rectangular shape.
  • Lasso Image: freehand shape where the start and end points do not need to touch.

Below is an example where the Selection Mode is set to vertex only and a Rectangle Selection Region Mode (left) is compared to a Lasso Selection Region Mode (right):

Rectangle Selection Region ModeLasso Selection Region Mode
Video of Rectangle Selection ModeLasso Selection Mode

Selection from Visibility Pane

You can select any Entity in the Visibility pane.

  • When you select entities this way, it will automatically be an Entity select.
  • In the Groups tab of the Visibility pane, you can use the checkboxes to the right of any entity or simply click on the entity name to select the Entity. The entities are arranged according to their application type such as Geology, Groundwater etc.
  • In the Tree tab of the Visibility pane, you simply click on the entity name to select the Entity.

Special Select from Right-Click Menu

There are three special selection tools available in RS3 that can be available using the right-click menu.

Special Select Options from Right-Click Menu

Select Top Faces of External

This is a convenient option to quickly select the top faces of the model. This option is not available if the model does not have an external volume. The location of the mouse cursor when you use this option determines the top faces selected:

  1. If you hover over the empty space in the viewport, this option selects ALL top faces of the model
  2. If you hover over a specific external piece, this option tries to select the top faces of the model associated with this particular piece
  3. If you hover over an external piece where no faces are at the top of the model, this option does not select any faces
  4. If you hover over non-external geometry, this option does not select any faces

Select the Faces Between Materials

This is a convenient option for the user to quickly select the shared faces between two divided pieces. The use case of this lies in adding surfaces such as joint surfaces, or slide3 surface types that were meant to specify properties between the specific boundaries between materials.

Select Component

To enable the option, do the following:

  1. Hover over a face with Face, Edge, Vertex Selection or Face Selection mode ON.
  2. Right-click the face
  3. Special Select > Select Component
  4. The program will automatically select all faces created from the same geometry
Portal Account Log Out Home Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee