Rocscience International Conference 2023 | April 24-26, 2023 Learn More about RIC2023
 

Search Results

RocFall2 Section Creator

This tutorial will show you how to create 2D cross-sections for export to RocFall2, including batch section creation and export.

Topics Covered in this Tutorial:

  • RocFall2 multi-section export
  • The group plotting function in RocFall2
  • Exporting reference lines in RocFall2

Finished Product:

The finished product of this tutorial can be found in the Tutorial 05 Terrain Generator data file. All tutorial files installed with RocFall3 can be accessed by selecting File > Recent Folders > Tutorials Folder from the RocFall3 main menu.

1.0 Import RocFall3 Model

Start RocFall3 by selecting Programs > Rocscience from the Windows Start menu. RocFall3 automatically opens a new blank document, which allows you to begin creating a model immediately. If the RocFall3 application window is not already maximized, maximize it now so the full-screen space is available for use.

  1. Select the File > Recent > Tutorial Folder > Tutorial 05 initial.
  2. Go to the Tutorials folder included with your RocFall3 install. The default location of this folder is C:\Users\Public\Documents\Rocscience\RocFall3 Examples\Tutorials. Select the Tutorial 05 Initial file and click Open.

Tutorial 5 import

This model geometry was created from the satellite locater option in the Import Terrain dialog. The hard and soft material regions were defined using the Image Segmentation feature, and the water body regions were manually drawn. The line seeder properties and location were also set. These settings are already preset in the file, so you don’t need to change anything. For more information on the process described above, you can visit Tutorial 2 Terrain Generator.

2.0 Reference Line

  1. Select Geometry > Draw Polyline.
  2. Draw a line along the 2500 m elevation line, on the eastern slope, ensuring that it fully spans the model.

If you want to use the exact values of this model, navigate to and open the provided Tutorial 05 Reference polyline.txt file in the Tutorials folder. Alternatively, you can save the .txt file by right clicking here and selecting Save Link As. Select import in the Draw Polyline dialog and import the points.

  1. Right click and select Done.
  2. Name the polyline "reference line".

    Reference Line Dark
The transparency of the slope was decreased to emphasize the location of the reference line (shown in red).

3.0 Compute

  1. Click on the Compute compute icon in the toolbar (or select Analysis > Compute in the menu).

4.0 Results

Navigate to the Results tab. Contours of translational velocity are shown for the rock paths by default. The legend bar on the right can be used to toggle between the different outputs.

Results

5.0 RocFall2 Multi-Section creation and Export

RocFall3 now supports batch section creation and export to RocFall2.

This feature is only applicable if you also own RocFall2.

5.1 Creating Multiple Sections

  1. Select the Geometry tab.
  2. From the menu, select Geometry > RocFall2 Section Creator.
  3. In the Create/Edit Sections dialog, click Create Multiple Sections Create multiple sections .
  4. Select the Sections per Segment option as the creation method.
  5. For Number of Sections enter 1. This means 1 cross-section will be created perpendicular to each segment of the drawn polyline (discussed next).
  6. Click Draw, and then proceed to trace a line similar to the reference line as shown in the image below.

    Batch Section Creator

If you want to use the exact values of this model, navigate to and open the provided Tutorial 05 Creating Sections.txt file in the Tutorials folder. Alternatively, you can save the .txt file by right clicking here and selecting Save Link As. Select import in the Batch Section Creator dialog and import the points.

  1. You'll notice that 6 number of cross sections are created, right click, and select Done to exit drawing mode, and then select Ok to close the dialog.

5.1.1 Deleting Sections

We will delete the sections that don't intersect the reference line and line seeder.

  1. To delete a section, select the section and then select the Delete Icon delete located on the bottom-left of the dialog. Section 1-1, shown below, is an example of a plane that does not intersect the reference line and line seeder.

    Deleting 1-1

  2. Delete sections 1-1and 1-6.
  3. Click OK to close the Create/Edit Sections dialog.

5.1.2 Adding a Single Section

  1. Select Geometry> RocFall2 Section Creator.
  2. To add a single section, click on the Add a Single Section Icon add section located in the bottom-left corner of the dialog.
  3. Click Draw, then select the 2 arbitrary vertices of the cross section on the model preview. The following image showcases the drawn section in green.

    Section 4

  4. Click OK to save and close the dialog.

5.2 Exporting Multiple Sections to RocFall2

You need to have RocFall2 installed on the same machine to continue. Please also ensure RocFall2 is updated to the latest version.
  1. Ensure that you're in the Geometry tab and select the Export All Section to RocFall2 button. export section rf2
  2. In this dialog, we can control the information that is transferred to RocFall2. Ensure that all sections are selected.

    Exporting to RF2

  3. Ensure that the polyline defined as "reference line" is selected from the drop-down Reference Lines menu, then click Open to load RocFall2.

Once RocFall2 is open, you should be able to view all exported sections.

The line seeders from RocFall3 are now point seeders in RocFall2.

The reference line from the RocFall3 model is also visible in RocFall2.

If you do not see a point seeder, check that the 2D section intersects the line seeder in RocFall3. You can also manually insert a point seeder by selecting Seeder > Add Point Seeder.

RF2 Models

6.0 Compute RocFall2 Model

  1. Click on the drop-down arrow next to the Compute Icon in the toolbar, and then select Batch Compute batch compute .

7.0 Group Analysis

7.1 Group Plots

Group Plot show results from multiple sections in the same plot. This is a powerful tool that can be used to compare rockfall trajectories among multiple cross-sections.

  1. Select the Results tab.
  2. From the menu, select Graphs > Group Plots > Graph Endpoints.
  3. We can plot the data using the reference line, select the Endpoint Distance From option in data settings, and select the defined polyline "reference line".
  4. Click Plot Data to load up the histogram.

Graphed Endpoint Dialog

Runout distances

In the group plot, we can see the runout distribution in each slope section with respect to the same reference line. Each section has a colour associated, shown in the legend on the right side of the plot. Notice that some of the runout distances are negative, mainly from Section 1-5 and 1-4. This is because the rock paths stopped before reaching the reference line.

Account Icon - click here to log in or out of your account Shopping Cart icon Click here to search our site Click here to close Learning Tech Support Documentation Info Chevron Delete Back to Top View More" PDF File Calendar Location Language Fees Video Click here to visit Rocscience's LinkedIn page Click here to visit Rocscience's YouTube page Click here to visit Rocscience's Twitter page Click here to visit Rocscience's Facebook page Click here to visit Rocscience's Instagram page Bookmark Network Scroll down for more Checkmark Download Print Back to top Single User Multiple Users RSLog RocFall3 CPillar Dips EX3 RocFall RocPlane RocSupport RocTopple RS2 RS3 RSData RSPile Settle3 Slide2 Slide3 SWedge UnWedge Commercial License Education License Trial License Shop safe & secure Money-back guarantee